Jump to content
TNG Community

All Activity

This stream auto-updates     

  1. Today
  2. Katryne

    Surname cloud and trees

    MERCI ! Brett. I understand now.
  3. Newfloridian

    Surname cloud and trees

    Hi Brett Following on from your last post perhaps I could comment from my own experience. I have two trees on board but they serve two totally distinct and separate functions and populations. The much larger and active tree is my own family history and that tree is divided into seven branches. The much smaller tree is my University Year Club and the only common factor between the two is me. Consequently I do NOT want people from the smaller tree being displayed alongside people from the larger one. I achieved this by creating a session variable which was filled by the tree variable according to which part of the website the reader was coming and then disabling the treedropdown feature. From my home page, the first seven parts accessed from the banners in the left hand column are controlled by the larger tree and its branches; the tartan banner is controlled by the smaller tree; the grey pages which are not tree dependent does not have treedropdown disabled. So, for instance, surnames from any of the seven pages display larger tree names; surnames from the tartan pages displays surnames from the smaller tree; surnames from the grey pages displays all surnames. I have placed the surnames cloud onto this landing page (which is not exactly within the TNG environment). It probably only shows surnames from the larger tree anyway because the largest number in the smaller tree is only 18. The Extended Craxford Family Web Site Alan (If you want to try it out I could give you a particular surname to search for)
  4. Brett

    Surname cloud and trees

    In Setup >> Configuration >> General Settings Site Design and Definition, Katryne had a Default Tree chosen. Removing this shows persons from all trees, as was wanted.
  5. Brett

    Surname cloud and trees

    Thanks. Change that back if you are ready. PMd you.
  6. Katryne

    Surname cloud and trees

    Same with Template 12. See by yourself : http://tng12.katrynou.fr/
  7. Brett

    Surname cloud and trees

    I have tested this on Template 12 and works as it should. A quick suggestion. Change to Template 12 and see if it still does not work as expected.
  8. Katryne

    Surname cloud and trees

    Hi Brett ! It occurs whether one is logged or not. The only restriction is that details less 100 years old are hidden from non logged users (only the surname is displayed with first letter of given name, but all the persons are displayed to anyone) I haven't restricted access to any tree according to user. The difference between 24 and 10 is that there are 24 persons on the whole site, all trees included and 10 persons on the main tree (I mean the first created) The surname cloud displays information (number of persons, and size of the name according to it) for the whole site, but the links under each surname leads only to the main tree. NOTE : it is not important for me, since I decided that organization in trees was not what I needed. I will keep to one only tree for the main site.
  9. Brett

    Surname cloud and trees

    Does this occur where a user is logged in? Have you restricted a non logged in user to the one tree? Is the difference between the 24 and 10 persons only because of names in a different tree or are some Private due to user not logged in?
  10. Hello ! On a test site http://tng12.katrynou.fr/ , I tried to organize the people in trees, while I never used them on the main site. I cannot remember exactly, but I do not think that the surname cloud is included in Template 13, so I must have modified the files somehow. Problem lies with using several trees. The surname cloud displays the names and number of persons for the whole site, all trees included. While the links when you click on a surname leads only to the main tree. Look at the surname Deroudille : it's large enough because, when you hover it, its population is 24. But when you click on it, the list includes only 10 persons. Some name may appear only in secondary trees : look at Bompar. In the cloud you can see there are 5 persons. When you click on it, it leads to a no-result page. Because the search is made only on the main tree. I think that the surname cloud code should be modified so that by default the search from its surnames is done on the whole site, all trees included and not on the main tree only.
  11. Yesterday
  12. I am using the standard (default) table names. Thanks again for your help.
  13. raisondetre

    To-do/Research log development

    I realize this is a very old post but I thought I would offer a possible simple solution that 'might' work for others. First, I do not use the 'Private' indicator for Notes very often. If you do use that on a regular basis then stop here because this idea won't work very well for you. I use the notes field to remind myself of next steps . . . leading the assignment with the words, "Research Task:" and then mark the Private box. These are then easily brought up under a Notes search - looking for Private notes only. I expect a report would be fairly easy to generate if needed using find "Research Task" in Notes as criteria. I'm sure there is a better way by now but just throwing this 'out there' . . .
  14. Thanks John, I might have misinterpreted your previous post. Edited - Are you using your original table names or the standard tng_table names?
  15. All 3 options are set to No. I don't recall deleting anything that was installed before uninstalling it first and if it was partially installed, doing a cleanup before uninstalling it. I tried your new 10.1.1.4 again. I uninstalled 10.1.1.3d, copied 10.1.1.4 back into the mod folder & installed it. I stand corrected from earlier: 10.1.1.4 works as it is supposed to. So as you said, when I had that error 500 but managed to use my browser's back button, grasping at straws I may have deleted the mod when it showed as being partially insalled. So as of now, I am up & running with your new 10.1.1.4, and my tables are back to default.
  16. John, What is your Mod Manager Options in the Other section of that page? The Mod Manager should not allow a mod to be deleted if it is partially install, unless you changed the option for Allow Delete Selected of Partially Installed Mods: to Yes Edited to add - Allow Delete of individually Installed Mods: to Yes Delete only removes or the cfg file from the mods folder and does nothing to the code. The following leads me to belied that you are not Uninstalling the mod first. If the above options are not the default of NO, please change them back to No. V4 should work unless you are not uninstalling mods before deleting them, so the options allow delete of partially or installed mods, please change both options to NO.
  17. It seems that Genlib was the problem. Please excuse my verbal-diarrhea below, but I want to be as concise as possible ­čśü. I renamed all my tables back to default, and adjusted my config file accordingly. Started up TNG, with Count Ancestors n Descendants v10.1.1.4 still installed, and my site was accessible, plus the mod was working. But... I did notice that the mod showed as being Partially Installed, so I did a Cleanup & reinstalled it, then went back to my main page: Error 500. Restored Genlib, checked the mods page, and the mod showed as being Partially Installed again. I then deleted 10.1.1.4, and did a restore of 10.1.1.3d. When I checked my mods page, it showed 10.1.1.3d as being installed, even though I had deleted it earlier & just restored it. I uninstalled 10.1.1.3d & reinstalled it, my main page is working without any errors, and now that I renamed my tables back to default earlier, 10.1.1.3d works perfectly. So, 10.1.1.3d works correctly, but 10.1.1.4 does not. All the wasted work that I put you through today, Ken, and on top of that on your leisure day off to boot. Please accept my apologies for wasting your time. Note & lesson to myself: don't touch the tables, especially with something as complex as TNG, with all of its mods. If there's anything other testing that you wish done, Ken, now that I'm pretty good with restores, I'm willing to be one of your beta testers ­čśÄ. Have a great weekend, everyone. Regards, John
  18. Scott, My new mod version should have worked, unless I overlooked some other changes that is required. I did test the mod before sending it to you. I really would like to see what error message was issued, because mod developers should not hard-code the table names. Reverting to standard TNG table names does not help me fix the mod so it works correctly if users change the table names.
  19. Katryne

    Password protection for Features

    I started with version 10 and I am very happy now with 12.1. Just as Michael did, I erased the DNA part. My familly site is private, but the village site is half public and requires login to view recent details and media. Members are very few and are mostly contributors. So yes, my site needs login and hides tmedia from non connected visitors via the Public Access Control mod. And overall, I love the last template I installed (Nr 13) on the village site. I even started from it to build a theme for my Online photo album.
  20. I'm changing all tables back to normal (default) at this time.
  21. $families_table = "tng_a2_families"; $children_table = "tng_a2_children"; The reason why my tables contain the a2_ , is because my site is hosted elsewhere, but I also have a local test site in my home, and years ago things got screwed up royally, hence me differentiating between the two.
  22. Apologies for the confusion. The original error, with the original 10.1.1.3d´╗┐ installed, caused the error: When I tried to modify ´╗┐all references to´╗┐ tng_children & tn´╗┐g_families in the ´╗┐10.1.1.3d´╗┐ CFG file to be tng_a2_c´╗┐hildren & tng_a2_fam´╗┐ilie´╗┐s, and also with your test 10.1.1.4´╗┐ installed, those were the times when I got the 500 error. Sorry for the confusion.
  23. SiEiNo

    Mod Bot-trap

    Error message when trying: "Run Checks": Warning: include(begin.php): failed to open stream: No such file or directory in /customers/b/c/6/sieino.com/httpd.www/tngslekt/mods/bot-trap_v12005/bt_check.php on line 2 Warning: include(): Failed opening 'begin.php' for inclusion (include_path='.:/usr/share/php') in /customers/b/c/6/sieino.com/httpd.www/tngslekt/mods/bot-trap_v12005/bt_check.php on line 2 Warning: include(adminlib.php): failed to open stream: No such file or directory in /customers/b/c/6/sieino.com/httpd.www/tngslekt/mods/bot-trap_v12005/bt_check.php on line 3 Warning: include(): Failed opening 'adminlib.php' for inclusion (include_path='.:/usr/share/php') in /customers/b/c/6/sieino.com/httpd.www/tngslekt/mods/bot-trap_v12005/bt_check.php on line 3 Warning: include(getlang.php): failed to open stream: No such file or directory in /customers/b/c/6/sieino.com/httpd.www/tngslekt/mods/bot-trap_v12005/bt_check.php on line 4 Warning: include(): Failed opening 'getlang.php' for inclusion (include_path='.:/usr/share/php') in /customers/b/c/6/sieino.com/httpd.www/tngslekt/mods/bot-trap_v12005/bt_check.php on line 4 Warning: include(/admintext.php): failed to open stream: No such file or directory in /customers/b/c/6/sieino.com/httpd.www/tngslekt/mods/bot-trap_v12005/bt_check.php on line 5 Warning: include(): Failed opening '/admintext.php' for inclusion (include_path='.:/usr/share/php') in /customers/b/c/6/sieino.com/httpd.www/tngslekt/mods/bot-trap_v12005/bt_check.php on line 5 The directory 'bot-trap' already exists. The file 'blacklist.dat' already exists. The file 'robots.txt' already exists. The file '.htaccess' already exists. You may proceed with installation This happened after update to TNG 12.10. Bot-trap v. 12.0.0.5. What can be done? ENo
  24. manofmull

    Password protection for Features

    Sharon From TNG11, there were changes made to homepage links and the inclusion of a new DNA section, neither of which I wanted. After upgrading to 11, I've tweaked my homepages (I use three) to the link-style of 10 and also deleted the DNA section. Having said that, TNG11 isn't too bad, it's just a matter of preference. If I were in your shoes, I'd upgrade to 10 and give that a try first. M
  25. Newfloridian

    Password protection for Features

    TNG 10.1.3 - my favourite. Still is! Sent you a PM Alan
  26. SharonM

    Password protection for Features

    Mine's only a very small site, and I'm the only editor, plus, I manage my data using desktop software and just use the TNG site to make information available to any of my family who are interested (not many are, and usually only briefly ) , so maybe that's why I haven't felt the need for any mods - until now that is. As a matter of interest, why was v10 your favourite? And what is it about 11 and 12 that put them lower on your list? Sharon
  27. manofmull

    Password protection for Features

    Sharon Yes, mod is short for the bigger word. No mods!? - omg, I have 72 installed. My site would be lost without at least half of them. FWIW dept: my fav version of TNG was 10 Michael
  1. Load more activity
×