Jump to content
TNG Community

Search the Community

Showing results for tags 'wordpress'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • TNG Specific
    • Announcements
    • Questions and Answers
    • Installation and Configuration
    • New Ideas and Suggestions
    • Code Discussion
    • Templates or Design Questions
    • CMS Integrations
    • TNG Wiki
  • Community
    • Member Webpages
    • Genealogy
    • Chit Chat
    • Questions and Answers
    • Offers And Requests

Blogs

  • Community News
  • TNG News

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 19 results

  1. reesjel

    Kloosterman method display issues

    I've used the Kloosterman method to integrate WordPress with TNG (v.12.0.1) but I'm running into a few little issues. When I go to: http://www.rootz.one/genealogy/surnames.php I get two issues, one on desktop, one on mobile that I don't know how to resolve: 1. Desktop: TNG menu, language switcher covers links below. In the image above, on the right hand side of the TNG menu you can see that the language drop down covers whatever text is shown below. It does this without me doing anything at all. I also have a language switcher in my Wordpress menu above, and that one is aligned to the top on TNG pages but sits in line with the rest of the menu on my other pages. 2. Mobile: No Wordpress layout, only TNG with fixed, expanded menus As you can see in the screenshot above, whe I check my website on mobile I encounter two issues. I don't see my WordPress environment at all anymore and the mobile environment I do see has the menu expanded and I'm not able to undo that. I would like to see my WordPress layout with the TNG data underneath, just like it is the desktop version. Has anybody encountered these issues before and/or know how to fix them?
  2. After a while I’ve updated WP (4.9.8) and TNG (12.0.1) The integration was running before all the upgrades, but now I get HTTP 500 error on the integration page. TNG standalone woks fine (some fine tuning will be done with the new template, when integration woks again) https://kuhnert.ch/tng/ But https://kuhnert.ch/stammbaum/ shows HTTP 500 ! My Homepage is https://kuhnert.ch/ I followed step by step the manual for the TNG WP Plugin. Some ideas? Thanks, Klaus
  3. tngweb

    Chubbuck Family

    The Genealogy of the Chubbuck Family is quite interesting (AND confusing) to say the least. Keep in mind, this is a constant work in progress and I feel it'll never be complete. Please feel free to visit http://www.chubbuckgenealogy.com/ You can log in using ID: guest PW: guest Running TNG-v12 with the latest Wordpress.
  4. Turned this on live March 2 after about a week of learning TNG. https://www.kenspratlin.com/our-genealogy/ The link below describes the integration process. https://www.kenspratlin.com/2018/02/about-this-website/ I'm excited about the possibilities TNG provides to better share our genealogy research with the family. Also looking forward to learning more about Mods. Best regards, Ken
  5. teylleghin

    Links don't work when integrated

    Hi everyone, I was quiet for a long time, because my website was working properly. But now I had to set up everything by scratch again, and I have some new issues. I created a subdomain https://test.thieltg.es for testing everything, before doing it live. There is wordpress installed in https://test.thieltg.es/wordpress and TNG v11 in https://test.thieltg.es/tng. Both systems are working. Then I installed the wp integration plugin. On my wp-page https://test.thieltg.es/stammbaum/ it shows the TNG index.php correctly. But the links are not working. It always shows me the same page. When I go directly through the TNG pages, everything works. If I change the adress manualy (e.g. from https://test.thieltg.es/tng/browsemedia.php?mediatypeID=headstones to https://test.thieltg.es/stammbaum/browsemedia.php?mediatypeID=headstones), it doesn't work either. Has somebody an idea? I imagine, that I had this issue some years ago, but I don't now the solution. I'm not able to compare my current setup to the old one. Thanks for help and kind regards, Andreas
  6. Chris Lloyd

    Tng with WordPress

    This is a pertinent post about Wordpressattacks for anyone considering integrating TNG: https://www.wordfence.com/blog/2017/07/wpsetup-attack/?utm_source=list&utm_medium=email&utm_campaign=070717
  7. LordOfKent

    WordPress hacked

    Hi there, I have just read the following in a letter from my web host although I dont use WP I know others do. Action needs to be taken urgently. (OOps already posted by Chris) Hope no-one gets hacked Happy Christmas
  8. Jastro

    Show TNG in Wordpress

    We have TNG 11.1.2 and the latest Wordpress 4.8.3 witch we want to integrate with the TNG WordPress Integration plugin 10.1.1. All setup steps seems to be ok and it sort of works. When I go to the Wordpress page where TNG is connected to, TNG pops up, but takes the whole screen. Moving on in TNG from there and it shows up inside Wordpress again. It a bit annoying and I'm not sure whats happening... Jastro
  9. KmBdev

    Custom event with hyperlink

    I have tng in word press using the wordpress plug in. I have a custom event "Links" which lists mainly the name of battles the person was involved in. What I would like to do is make the battle name, in my custom event, link to a wordpress page I have in my web site about the battle. Is there any way to do this? Thank you for any help.
  10. I have been working for days attempting to integrate my website with WP by using Mr. Kloosterman's method. I am using TNG V11.1.1 and WP 4.8.2 running Twenty Seventeen theme. I am doing this on wampserver installed on my home computer before I attempt it with my site. Initially, it seemed to work. The devil is going to be in the details, obviously. However, before I can get to work on making it more aesthetically pleasing, I need to solve a couple of problems. When I try to link to files in my tng history folder, I receive the following two errors; Warning: require_once(C:\wamp64\www\mywebsite\tng/wp-includes/load.php): failed to open stream: No such file or directory in C:\wamp64\www\mywebsite\tng\wp-load.php on line 49 Fatal error: require_once(): Failed opening required 'C:\wamp64\www\mywebsite\tng/wp-includes/load.php' (include_path='.;C:\php\pear') in C:\wamp64\www\mywebsite\tng\wp-load.php on line 49 Wordpress is installed in the root folder and tng is installed in a subfolder. I followed Mr. Kloosterman's instructions to the best of my ability and I created the new topmenu, footer, and header files and pasted in his examples. I have them in the root of the tng folder. I have been unable to find a solution so far. Looking at the beautiful Kloosterman Genealogy website, it is obvious that I must have made an error somewhere. Thanks
  11. There is a long thread on this subject started nearly 14 years ago and I was in two minds whether i should start a new one, but as technology has changed in that time and several of the provided links no longer work, I thought it a good idea. Also the last comment on that thread was about 9 months ago. Presumably someone will move this comment to that one, if that is the preferred way to go. Firstly, this is completely new territory for me and totally outside my comfort zone but what the hell, I'm a young 67 and keen to learn! So I want to set up a stand alone copy of my site, so I can 'experiment a little with it, without it affecting my online site and then eventually copy it all across. And play around with this Wordpress thingy. I have successfully downloaded WAMPserver version 3.1.0 - 64 bit latest version and following the guidance notes written by Royce Tivel, which someone kindly provided the link to, earlier in the other thread. I have updated and installed all the redistributable VC packages to make it work and it turns green in the systems tray, as it should. But I am now confused and I wonder whether I am trying to solve problems that might have existed in earlier versions (and when the guidance notes were written) but don't now, such that some of the instruction is irrelevant. For example: there is an instruction to create database tables within the phpadmin database and the instruction is to import the "create_tables.sql" files located at: C:\wamp\apps\phpmyadmin-3.5.3-english\examples\create_tables.sql My version of php is actually 4.7.4 so substituting that for 3.5.3 is my logic but within that folder there is no folder called, 'english'. There is one called, 'examples' but in there, there is nothing called, 'create_tables.sql.' So is this something that is not now necessary to do? Is the file located somewhere else? or indeed, having got Wamp up and running, with no error messages, can I simply copy and paste my online site (SimplyHosting) into Wamp via Filezilla without further ado? If yes, it would be helpful to know what to copy and to where. I hope that is all intelligible to someone. I'm on version 10 of TNG
  12. Between the upgrades to WordPress as well as the TNG core, the old TNG WordPress plugin has become completely useless. This forced me to use an alternate method for integration. I chose the Kloosterman method which worked great. Unfortunately, this left me without Single Sign-In capability so that only site members would have access to the genealogy section, TNG. Even if I left the TNG directory out of all the site's navigation and links and used ROBOTS.TXT to prevent it being indexed by searchbots (at least the compliant, reputable ones,) it would still be accessible by any user (logged in or not) that entered the TNG directory address directly or had a link or bookmark that led to it. The imperfect workaround I went with was to use the .HTACCESS file to check the already existing WordPress cookie to see if a user is logged in. This applies only when they try to visit that directory or any of its subdirectories or files. If they go there and they're not logged in, they get redirected to the login page. (It's an imperfect method, because it's still hackable, but it's the best I could come up with on the spot.) <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_URI} ^.*tng/.* RewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in.*$ [NC] RewriteRule . /wp-login.php?redirect_to=%{REQUEST_URI} [R,L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> INSTRUCTIONS (Use at your own risk. I am will not be held responsible for any damage or losses to you or your site for trying this nor is it my responsibility to help you fix things if they break. I'm sharing a method that I use that works for me. I think it will work for most others as well, but I can't guarantee that.) Copy the code above, and be sure to change the TNG folder name to the one you use on your site. Open your own HTACCESS file, and find the basic WordPress code that looks like this: # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress Overwrite the part between BEGIN and END WORDPRESS with the new, edited code. Save your changes, and upload the new file back to the server. ADDITIONAL ACTIONS These are additional actions I went with for my site. I hope they help you as well. I turned REQUIRE LOGIN off so that users only had to log in to the membership section of the site once to see the full genealogy section. This keeps them from being able to edit the records. They can only suggest changes. This also prevents hackers that bypass my method above from being able to easily make changes without a login. I removed all LOGIN and ADMINISTRATION links from the TNG pages. Now I have to use my bookmarked links to get to the admin.php and login.php pages.
  13. Renze

    Problem with login

    My website is built according to the method of Kloosterman (Wordpress & TNG). This works perfectly only when logging in, then it's going wrong. As soon as I click on login, he refers to: https://tng.petersohn.nl/img/ssl-certificates-icon.png. I use SSL on my website. I would like to refer to my website after logging in. Someone an idea how I can solve this? Account: Website: https://petersohn.nl click on "genealogie" Username: Test Password: 12345
  14. My site was hacked so I decided to start fresh which included using a new WP Theme - MH Magazine (not lite). Slowly the is coming together but then attempted to bring TNG via the plugin into the system. Upgraded to TNG 11 and using Wordpress 4.8. Installed the Plugin - When I click on any of the TNG widget menus or the main Genealogy page I just get a blank page. Does anybody have any ideas or does anybody know if MH Magazine works with this Theme?? The path to TNG and URL both seem fine and the "GO to TNG Admin on the Plugin work fine. http://www.seaburnemay.ca Thanks for your help Peter.
  15. I'm going to give this another try, but I'm wondering, is there a WP theme that has had consistently favorable results with the Kloosterman method of merging WP and TNG? I'm using TNG 11.1, along with WP 4.7.5, and would like to experiment with a proven theme to find out where I have messed things up, as I most likely did. Thanks! David PS. Has anyone tried the Kloosterman method with the WP Twenty Seventeen theme?
  16. I have successfully integrated Wordpress and TNG using the Kloosterman method. One issue I have that I am unable to fix is the issue of disappearing lines. The top line of the box outlining the new user registration form has disappeared. I am a novice at this so I am having difficulty understanding why it disappeared and how to get it back. In the image I attached if you look above "Username" you can see the grey outline box has disappeared. Can anyone assist me with this?
  17. Roger_NZ

    Login problems

    Recently I have been having problems logging into my site. Fortunately, I am staying logged in with my Chrome and Firefox browsers, but if I try to log in from another browser or another device I get an error message ("ERROR: Sorry, there was an error. Please be sure JavaScript and Cookies are enabled in your browser and try again.") on the processlogin.php address. Looking at my server error logs, there is a clue that this is an issue with the tng-wordpress plugin. The relevant entries are attached. The plugin is ver 10.1.1, PHP ver 5.3 - mysqli is selected. WordPress 4.7.2, TNG v 11.1. Any guidance on how to resolve this would be appreciated. servererrorlog.txt
  18. Paul Barrett

    TNG Search Plugin

    I am running a non integrated TNG/WordPress installation All the key features i want to access in TNG are accessed from hyperlinks in a sidebar widget menu. This means I have no need for the TNG home page (with one possible exception) so I have configured TNG to use the WordPress Home page: This works very nicely and means the TNG home page is completely bypassed. Thanks for making that so easy Darrin. The one thing that I mildly hanker for is the simple search capability on the home page: If there were a WordPress widget for that I would use it. Sadly I can't create it myself as I don't have the skills Even better would be a single search box into which you could enter a single string, instead of having to separate first and last names.
  19. Nathaniel Christopher

    Images and thumbnails not working

    Hello, I'm having issues with images and thumbnails on my TNG site. Specifically, they don't display. I tried to poke around with the Media settings but I hid a roadblock. I'll explain. When I go into the "General Settings" (Administration > Setup > General Settings) menu I'm unable to expand any of the options including Media. So when I click on them nothing happens. I've attached a screenshot of the page in question. I should mention that I use TNG v.11.1 as well as TNG Wordpress Integration v.10.1.1. Anyways, here's the relevant information: Website: http://www.robertrobertsonsmith.ca TNG install: http://www.robertrobertsonsmith.ca/wp/genealogy/ Admin page: http://www.robertrobertsonsmith.ca/wp/genealogy/admin.php User: Test Password: bilateral_autoenucleation Thanks in advance for any advice.
×