Jump to content
TNG Community

Search the Community

Showing results for tags 'mod'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • TNG Specific
    • Announcements
    • Questions and Answers
    • TNG Modifications
    • Installation and Configuration
    • New Ideas and Suggestions
    • Code Discussion
    • Templates or Design Questions
    • CMS Integrations
    • TNG Wiki
  • Community
    • Member Webpages
    • Genealogy
    • Chit Chat
    • Questions and Answers
    • Offers And Requests

Blogs

  • Community News
  • TNG News

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 183 results

  1. XerxX

    Watermark mod

    @Michel KIRSCH Hi Michel. I've tried your Watermark mod a little bit at my Localhost and I like the little I've seen very much. I have one wish, though: Is it possible to have one directoriy (or more ) excluded from the watermark function? At one of my sites, I have a directory of old public domain maps and watermarking them looks ... well, not good. Therefore I can't use it where it's needed: The site is almost fully open showing medis and what not. Thanks In Advance, Erik
  2. After I updated my online web site to ver. 13.2, the Public Access mode is not showing any text on the Admin_genconfig.php page. (See image.) The Mod still seems to work and I can figure out the selections by looking at the Wampserver page on my computer. It is still on Ver. 13.0 and working correctly. However, that's a rather awkward way to set things up. I've tried manually adding the $text entries to text.php in both English language folders, but that didn't help. I have the following Mods installed: Google Maps - More Place Levels Image Captcha Mod Open my Page Open Street Map OSM Auto Geocoding Mod Settings Block Regroup Person: Profile, Branch, Date place, No living, and Sources User Footer Copyright They all installed correctly and are functioning as expected. Would appreciate any suggestions and also wondering if anyone else has had this problem.
  3. Leo te Braake

    Add Person Siblings Row mod

    I like that this mod enables the main person's siblings to be shown on the getperson page. I often have families with many children with rather incomplete data, and the place of the main person in the row of siblings is not always obvious, especially if there are children with equal names as deceased ones. Therfore I include the main person in the list, but that does not seem right. I propose that the mod includes the main person in the row of siblings, but after that replaces the name etc. by a graphical element (e.g. a frame with text: "main person belongs here")
  4. I installed v.13.0.1 (update from 12x) and everything seems to work fine except when I go to mod manager where I get an Error 500 - internal server error. Is there anything I can do to recover from this? The site is: http://elizabethriemer.com/index.php Thank you for any help, Liz
  5. Rob Severijns

    Private Media Flag

    Hello everyone, I have several media files that are provided to me by family members. The deal is that I can use the media files as long as they are not visible within the family tree and as long as certain family members are still alive. This means these media files need to be marked as Private. Setting the media files marked as Private results in these files being visible to users with rights to view Private content only. It would be nice if the Private flag could, by default be set as mentioned above and that besides that there is an option to override this setting for specific Inividuals and/or families. Basicly saying: Private for all except for users who have the right to view Private content set in the User rights and specific Individuals and/or Families set for each applicable media file. This creates the possibility for the provider of the media file to view that specic media file. Hope this explanation is clear enough. Rob
  6. When using the Dutch language on my site I saw that the word "ancestors" is translated in voorvaders, but this is not correct it should be translated as voorouders, is there a way to correct this?
  7. Hi Everyone! I hope this is in the right place! I'm following the instructions for using SimpleSAML as a method to create single sign-on between TNG and Media WiKi. So far, I have everything working including testing the SSO "admin" source. However, I can not get the "authsources" code that is mentioned on the WiKi integration page Single sign-on integration with SimpleSAMLphp - TNG_Wiki (lythgoes.net) to work - whether I modify the code or not, I get the same error: SimpleSAML\Error\ConfigurationError: The configuration (config/authsources.php) is invalid: syntax error, unexpected ';', expecting ')' I am using PHP 7.2 and my suspicions are that something has changed with the upgrades in PHP and there must be something that needs to be changed or is missing in order to make the code work. I am not a code writer but I have been somewhat successful getting some code to work. Unfortunately, this one I am afraid I can not. So, any PHP code writers out there that want to take a look at this and let me know what I'm missing? the code is below. Many thanks! Dave Authsource code: $config = array( 'tngidpauth' => array( 'tngextauth:External', 'dsn' => 'mysql:host=localhost;dbname=yourdatabasename', 'username' => 'yourdatabaseusername', 'password' => 'yourdatabasepassword', 'tngpath' => '/home/example/public_html/tng/', // the TNG path from (and including) the 'home' directory; ends with a slash. 'loginpage' => 'http://example.com/tng/login.php', // full URL to TNG's login page. 'logoutpage'=> 'http://example.com/tng/logout.php', // full URL to TNG's logout page. ), /* Other authentication sources follow. */
  8. I wanted to play the apprentice-sorcerer. But I am ignorant about it. Now I can no longer install Mods. An error message appears each time. ''the version is only from TNG version 13.0.1 onward" Any idea how I can help? http://www.mes-racines.com/saga/index.php François (FRANCE) TNG 13.0.2
  9. Hello ! I just discovered that when searching for a place and displaying it on the map, there is a pop-up proposing riding directions. When clicking on it, one gets out of the TNG onto the Google route planner. I want to keep my visitors on my site. I do not want them to be driven elsewhere and be tracked by google. I want to stay respectful of their private life. I would like to hide the prompt to click on the link. And for anyone who might wonder, this is NOT Google bashing. So please do not try this troll.
  10. ton van lil

    Sosa

    I like the Sosa mod. But when a list it my surnames have no surname prefix anymore. Am I doing something wrong? See picture below.
  11. Rob Severijns

    Default Photo

    Hello everyone, In order to quickly see which photo is set as the default photo one has to go to Admin --> People. It would be nice if there was a the possibility to easily remove the default photo for multiple selected individuals. Especially if someone by "accident" assigns the first photo as default photo for an individual via the Admin --> Media --> Thumbnails. But of course for any other reason one might want to remove multiple default photo's. This prevents the opening of each individual media file and unchecking the default photo checkbox which is time consuming and requires a lot of mouseclicks. An extra icon in the Action Collumn or a checkbox right of the thumb could be an option. Has anyone ever missed this feature before or is there a mod that accomplishes this? Kind regards, Rob
  12. Hi all, For some reason the geocoding facility in Edit place: has not worked for a while, according to reports. I get the error in TNG v11 and 12 on-line and TNG v13 in localhost. I'm investigating why, but today I haven't found any mention of a reason on-line. /Erik
  13. I posted in the other recent thread about this, but I think it fell to the bottom of things: I have had the same issue for a month or two. I followed the steps Ken said here (unload and reload all the mods and delete to old files) and it did not work for me. I have the same issue - the censuses appear twice, and two buttons that say "check census links" on the import/export page. I don't know how I got two versions installed either. I'm using TNG 13.0/ You can see it on the 1850 and 1860 censuses on this page: https://ancestors.pitard.net/getperson.php?personID=I4239&tree=1sttree Thanks for any help-- Derrick
  14. marcirish

    Suppress showing some fields

    I have a number of fields that I import from my Reunion 12 database. These fields are really flags to indicate various things, like Died Young, Veteran, Has a Signature and the like. I use these flags to generate reports on people who have this flag set. These flags also show up under events for a person. I would like to suppress these items from showing up on the GetPerson Page but keep them active in the database for use on reports. Is this possible. https://marcirish.us Thanks. Marc
  15. Hi I am using TNG V.12.0.3 I am trying to install Forum for TNG V10.1.3.4 I loaded the files to my mods directory The Mod manager shows cannot install Here is the log: flags: @ optional ^ (provisional) must be available ~ protected line 41: %target:processlogin.php% verified line 42: %location:% #1 not installed line 59: %target:genlib.php% verified line 60: %location:% #1 not installed line 86: %location:% #2 not installed line 110: %location:% #3 not installed line 182: %target:admin_genconfig.php% verified line 183: %location:% #1 not installed line 196: %location:% #2 not installed line 209: %location:% #3 not installed line 227: %target:admin_utilities.php% verified line 228: %location:% #1 not installed line 248: %target:admin_backup.php% verified line 249: %location:% #1 not installed line 266: %target:admin_optimize.php% verified line 267: %location:% #1 not installed line 284: %target:admin_restore.php% verified line 285: %location:% #1 not installed line 302: %target:getperson.php% verified line 303: %location:% #1 not installed line 332: %location:% #2 not installed line 355: %location:% #3 Bad target line 388: %location:% #4 not installed line 422: %copyfile: forum_admin_job.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_admin_job.php line 423: %copyfile: forum_anmelan.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_anmelan.php line 424: %copyfile: forum_functions.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_functions.php line 425: %copyfile: forum_index.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_index.php line 426: %copyfile: forum_initForum.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_initForum.php line 427: %copyfile: forum_makeFFile2.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_makeFFile2.php line 428: %copyfile: forum_nyPost.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_nyPost.php line 429: %copyfile: forum_nyTrad.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_nyTrad.php line 430: %copyfile: forum_openForum.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_openForum.php line 431: %copyfile: forum_openThread.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_openThread.php line 432: %copyfile: forum_regedit_job.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_regedit_job.php line 433: %copyfile: forum_soktext.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_soktext.php line 434: %copyfile: forum_user_job.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_user_job.php line 435: %copyfile: forum_setup.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_setup.php line 436: %copyfile: forum_setup_end.php not copied Source: mods/forum_for_tng_mod_v10.1.3.4/forum_setup_end.php line 441: %target:@forum_index.php% file missing (optional) will ignore line 468: %target:languages/English/cust_text.php% verified line 469: %location:% #1 not installed line 488: %target:languages/English-UTF8/cust_text.php% verified line 489: %location:% #1 not installed line 508: %target:@languages/Danish/cust_text.php% file missing (optional) will ignore line 529: %target:@languages/Danish-UTF8/cust_text.php% file missing (optional) will ignore line 550: %target:@languages/Dutch/cust_text.php% file missing (optional) will ignore line 571: %target:@languages/Dutch-UTF8/cust_text.php% file missing (optional) will ignore line 592: %target:@languages/French/cust_text.php% file missing (optional) will ignore line 613: %target:@languages/French-UTF8/cust_text.php% file missing (optional) will ignore line 634: %target:@languages/German/cust_text.php% file missing (optional) will ignore line 655: %target:@languages/German-UTF8/cust_text.php% file missing (optional) will ignore line 676: %target:@languages/Swedish/cust_text.php% file missing (optional) will ignore line 697: %target:@languages/Swedish-UTF8/cust_text.php% file missing (optional) will ignore line 722: %target:customconfig.php% verified line 723: %location:% #1 not installed code modifications specified: 18; modified: 0 file copies specified: 15; copied: 0 new files specified: 0; created: 0 new folders specified: 0; created: 0 errors: 1 Any hints? Thanks, Byron
  16. Hi All, Version 13.0.0.2b of the Fixed Family Tab mod is published with these important updates: * Multiple marriages are supported * No conflict with Robin Richmond's Regroup Person Profile mod v13.0.0.19e <-- Note version 19e (published Nov 28, 2020) Grab it here: https://tng.lythgoes.net/wiki/index.php?title=Fixed_Family_Tab Note for TNG 12 users: A version is coming today or tomorrow, but it will NOT include the Regroup Person Profile adaptation. BTW! Public Access Control is updated by Robin to solve conflicys. See here: https://tng.lythgoes.net/wiki/index.php?title=Public_Access_Control Best regards, Erik
  17. In my mod I'm going to replace 55 lines of the original php file. What is the best way to achieve this? Is it the only way to put the whole block of lines in the %location% ... %end% statement? (I know that it could be line fragments, but still fragments of ALL lines). Please give any suggestions. Best regards Michal
  18. I am running TNG 12.0.2 with a standard installation and I try to install the Submit Photo/Document Form Mod but Mod Manager is giving me a Cannot install message. The error appears to be line 76 and I don't have a clue what it is looking for. Any help is appreciated. Steven W line 42: %target:languages/English-UTF8/cust_text.php% verified line 43: %location:% #1 not installed line 74: %target:getperson.php% verified line 76: %location:% #1 Bad target line 87: %target:familygroup.php% verified line 89: %location:% #1 not installed line 101: %newfile: submit_photo.php not created line 512: %target:@submit_photo.php% file missing (optional) will ignore
  19. Brett

    Mod Manager changing code

    I have a clean install of TNG13 with no changes and no Mods installed. It is running on WAMPSERVER 3.2.3, PHP 5.6.40 - 7.4.9, MySQL 5.7.31. When I install a Mod affecting getperson.php, lines 197, 200 and 203 are modified, even when those lines are not a Location in the Mod. It is always the same 3 lines, no matter which Mod is installed. Those lines, on a clean getperson.php end with a blank. Mod Manager removes the blanks on installing the Mod but does not return them when the Mod is uninstalled. I have tested this with several Mods. One to try is Collapse Family Children. Why is Mod Manager making these unnecessary changes? Additionally, shouldn't Mod Manager return any changes to how it was before the Mod was installed?
  20. Hello. I'm trying to install the Ancestor Map MOD version 13.0.0.8 onto a TNG website running 13.0.1 on a Digital Ocean droplet running NGINX. The cust_text.php files have read/write priviledges under each language. Any idea what I can do to finish up the installation?
  21. When you have a conflict with mods, uninstall and see what the culprit is. Well, that didn't work. I've been working with Robin Richmond on his Regroup Person-Child2Parent as it can have conflicts with Collapse Family Children. Default Not Living is still no ready for version 13 I gather. Regroup-Child2Parent requires Mod Settings Blocks, so that is the only Mod installed. Here is the display: Does anybody have an idea?
  22. I upgraded TNG to version 13 and also re-installed the OpenStreetMap-mod V13. When the heatmap is opened, it seems ok but you can not click or pan the map. What am I doing wrong? (example is at https://www.familielagarde.nl/stng/heatmap_OSM.php?tree=lagarde) Best regards, Patrick
  23. Rob Severijns

    Person_Media_Title

    Hello Brent, It's not my intention to put any pressure on you at all but do you have any idea if and when the Person_Media_Title mod will be upgraded again? "You'll see it when it gets there" is fine too. Tried to make some changes myself but no luck there Kind regards, Rob
  24. There is unfortunate conflict between the two mods: Regroup Person Profile (13.0.0.19c) and Fixed Family Tab (13.0.0.2a) concerning line 583 of getperson.php (13.0.1). It's quite easy to resolve the problem temporarily, but of course it could be better to have it definitely correlated by the authors. Both mods are extremely useful and both are among my favourites for years. I wonder why they are still not included in TNG... Best regards Michal
×