Jump to content
TNG Community

Search the Community

Showing results for tags 'install'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • TNG Specific
    • Announcements
    • Questions and Answers
    • TNG Modifications
    • Installation and Configuration
    • New Ideas and Suggestions
    • Code Discussion
    • Templates or Design Questions
    • CMS Integrations
    • TNG Wiki
  • Community
    • Member Webpages
    • Genealogy
    • Chit Chat
    • Questions and Answers
    • Offers And Requests

Calendars

  • Community Calendar

Categories

  • Feedback

Blogs

  • Community News
  • TNG News

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 141 results

  1. When I upgraded my hosted site to 13.1.2, everything is perfect. When I did a new install on my new Dell pc, I get this in the screenshot. anyone see or run into this from other users? Thanks
  2. I installed a 2nd tree via the "Trees" tab where I created a new tree. Then I went to import and successfully imported the 2nd tree. What I really want is the link to get to a pedigree chart for person number 1 in my "greentree" tree file which is my 2nd tree I just added. Does someone know what code I'd use to do that? Thank you.
  3. Hello. I have a TNG site up and running (https://belard.pt). I am now trying to implement a second TNG site, for another family, on the same server/hosting service. I bought a second TNG license, created a second SQL database on my server, created a second database user and installed the TNG software on a different folder, but when it comes to connecting it to the database I get the message "Existing user records have been detected. To proceed you must first log in or remove all records from the users table". I am a bit puzzled and, of course, afraid of damaging anything on the first, up-and-running site. Can anyone give me a tip on what should I do next? Thank you.
  4. Andi 2020

    OpenStreetMap installation problem

    Hello everybody, I'm using TNG 13.0.3 together with the TNG Wordpress plugin and tried to install the OSM mod v13.0.0.7c. Unfortunately I can't install the mod correctly, please see my screenshot for the error messages. I found several threads of people having the same problem, but unfortunately the suggested solutions didn't help. I've disabled all other mods, but without results. I've set the permissions for the folder openstreetmap_v13.0.0.7c to 0755 and for the file openstreetmap_v13.0.0.7c to 0644. I also updated the file cust_text.php. The files are empty, is this right? Unfortunately I don't know, what these files are needed for. In the map-settings I've set OSM as the key name. Can someone tell me where the error could be? Thank you very much in advance! Andreas
  5. I had an operating local server on my computer when it crashed. When restoring my backup image didn't work, I decided to start over. I reinstalled the latest Visual C ++, the latest wampserver v3.2.6, and TNGv13.1.2. I can connect the localhost/DSMtree/readme.html and follow the steps to Step 7 and then it stops. I think I remember from the past, I need to do something to phpmyadmin in wamp but can't remember what. Can anyone out there help me ?? I've been trying for a week and can't get it to work. BobD
  6. John Paul

    Google Maps

    Gooday Everyone. I'm new to this setting up google maps in tng. But here's what I've done so far. Searched the wiki, there's about a million references to google maps, but I found the getting started guide. Logged into my google account and made it to the google cloud platform. I created an api key and set the restrictions to http referrers both my live site and my local host. I enabled the 3 keys ( Maps JavaScript API , Geocoding API and Places API ). This where I get confused. Do I use the api key I generated for all this? I added the code to the map settings in admin and followed what it said in the guide. So now what do I do? what mod(s) do I need to install? Do I need to do more in my project at google? I hope someone could help me out here, in newbie terms. Like I said I'm totally new to this. The only experience I've had with google maps is getting driving directions somewhere. Any help here would be very much appreciated, JP EDIT: I found papa tango's google maps tutorial and followed it to the t and downloaded and installed the person map mod to do a little testing. If you have any more ideas/suggestions please feel free to let me know. Thanks
  7. New install V13. Software installed OK and all the people are there. but no images for the people. The install is at www.delandre-grogan.uk/tree. Separately my old version is on a different website www.delandre-grogan.co.uk at the root. Thia may have caused me to get confused. I am using Template 4 and the home page is OK. I used FTP to upload all the images of the people to root/tree/image. For any given person, I think the software is looking in the wrong place. Any suggestions ?
  8. Cor Kuipers

    installation

    Due to some problems with installation when I go to my site I get the install screenfor a new site what i do want to do is a uograde see for yourself at http/genealogs.nl
  9. Hanne B. Stegemüller

    Video guide in Danish - relevant here?

    I've made a video guide that in 28 minutes explains the purpose of TNG and explains readme.html (that I've also translated fra A - Z) for people who have absolutely never tried to establish a website before. I.e. they are wondering how to get data from their local machine to the internet, don't know what FileZilla is, don't know what a host is and so on. But they a great genealogists, without a chance to distribute and share their results achieved for maybe 30 years. I want them to see how easy it actually is to get TNG up running - and save a lot of money every year to some companies. Everything is down to earth and explained slowly, so that everybody can follow it. The introductory text in my Danish FAQ is: "If you follow this link, you will get to a video guide where I explain the purpose of TNG and the whole basic installation. You'll discover how easy it is to get started. The guide is intended for users who have never worked with websites before. If you follow the guide, you'll end up with a website." I've sent a link to Darrin so he can see whether he finds it precise enough for him to distribute the link to his (new) customers. He is busy these days but will have a look as soon as possible. Would a link to the guide be relevant somewhere in this community? Are there programs that can translate the video so you enthusiasts can maybe understand it a tell me what you think about it? I have spent really much time recording it (it is my first video tutorial), so now I know how difficult it is.
  10. Hello everyone, I am currently trying to install TNG (v. 13.3) for the first time, but I ran into some strange errors. Firsty, I use a debian 10 server with root access and with nginx 1.14.2, PHP 8.1.3 and MariaDB 10.3.31. I downloaded TNG 13 and unziped it into /var/www/tng. Further I changed the permissions to 755 and the ownership to www-data to avoid some other errors I received. I created a database named tng and a user named tng and granted the user all permissions via: GRANT ALL PRIVILEGES ON tng.* TO 'tng'@'localhost'; The installation process crashes on the 7th step, the creation of the tables. Everything works fine and TNG can also connect to the database, but after this I receive this error: FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught mysqli_sql_exception: Table 'tng.tng_users' doesn't exist in /var/www/tng/tngconnect.php:170 Stack trace: #0 /var/www/tng/tngconnect.php(170): mysqli_query() #1 /var/www/tng/checklogin.php(58): tng_query_noerror() #2 /var/www/tng/ajx_tnginstall.php(34): include('...') #3 {main} thrown in /var/www/tng/tngconnect.php on line 170" So I enabled the general log in MySQL to see the issued query which causes the problem. The MySQL log: 220313 9:33:49 144 Connect tng@localhost as anonymous on tng 144 Init DB tng 144 Query SELECT userID FROM tng_users 144 Quit Sometimes this query also throws an PHP error: 220313 9:45:27 146 Connect tng@localhost as anonymous on tng 146 Init DB tng 146 Query SET SESSION sql_mode = '' 146 Query SET NAMES utf8 146 Query SELECT * FROM tng_templates WHERE template = "" 146 Quit If I understand this correctly, TNG tries to receive data from the tables which don't exist. So, something failed within the creation of the tables, but no MySQL query was issued to create them. Maybe someone could help me with this rather technical problem. Greetings Ryusoken
  11. Rachael Williams

    Okay. I am fed up.

    What Desktop Genealogy Software do I need to buy? I need TNG to import a GEDCOM file that will link to the images that I have uploaded to the server, and not just the file name of the images! I will use the newly purchased desktop software, as an intermediary step, in order to import my FTM Gedcom and create a new Gedcom that was processed through this new software so that I am able to have a working TNG website.
  12. I'm stuck on step 6 of the Readme HTML installation guide with the dreaded "Please wait, attempting to process..." message. TNG v12.3, MariaDB 10, PHP 7.2, DB name: "tng", DB username: "tng-local". I'm running the Readme from the URL to the web volume on the Synology DS916. Also have referenced SKDavis' install guide for Synology. I believe I have followed all of the other steps without missing or having issues. Screen shots attached to show privileges, versions, etc. (password omitted on screen shot but included during install). Have googled this and tried other suggestions, but I appear to be overlooking or misunderstanding something. Appreciate any guidance for this rookie mistake. Thanks. John
  13. Hanne B. Stegemüller

    readme.html in Danish

    readme.html is now available in Danish. Darrin has approved the translation. You can grab the latest version of the file from here. Darrin suggested, that I placed a link to the Danish video guide for absolutely beginners in readme.html. So that link is now placed in the very beginning (line 380) with a text that means this in Danish: readme.html
  14. Hi there Upgrading from 12.3 to the latest 13 version. All OK till step 7 database structure: A change in this version allows private notes to be withheld from all visitors without express permissions. Please choose an option below to indicate which current registered users should initially receive those permissions: When finished, click the Submit button below. That operation will open a new window and make a few database structure changes. Your data should not be affected. You will see a short list of messages detailing what is being done, as well as a message when the script has finished. When the operation is complete, you can remove the upgrade_db12x-13x.php file from your site if desired. and when I hit submit I get: File not found Firefox can’t find the file at /C:/Users/User/AppData/Local/Temp/upgrade_db12x-13x.php. Check the file name for capitalisation or other typing errors. Check to see if the file was moved, renamed or deleted. I have made sure that the read me file is from my site database - this is what is displayed in the bar when I open the HTML document: file:///C:/Users/User/AppData/Local/Temp/upgrade_db12x-13x.php Any thoughts would be most welcome. Regards Martin
  15. MarsFlower819

    Help installing.

    Hello, First I want to say I am new to all of this. Second, I watched 3 didn't videos, read the guide. And am still confused. I got me a hosting site and domain, on DreamHost, and through that WordPress. But I try to follow the instructions, and I am just lost. I get to the file zilla part, on the file manager part, I put my info for the WordPress server, but I have no idea where to put my files, I tried it, and I ended messing up my WordPress domain completely, and it wouldn't even let me on it. I went and got me another one, while they are fixing the first one. I am new, I am doing a full new install, which is what I downloaded. I'm confused which or if any updates I needed? I honestly didn't know it would be this difficult to figure out, I watched his review video, and he said it wasn't hard to install and setup. I think we have 2 different versions of difficult. Any help is appreciated, because I really want this website to work. Thank you.
  16. Doug120745

    Install readme.html hangs.

    Hello, I am just attempting to reinstall TNG v12.3 after a year away from it. I am having difficulty getting TNG initialized on my home server. TNG is installed at location C:\xampp\htdocs\tng I started to follow your excellent YouTube video for installation and didn't get very far with the readme.html file before it hung up. The readme.html file is correctly accessed through my browser from http://localhost/tng/readme.html as shown in the attached snapshot below. I get to step 3 Set Permissions in the readme.html file, click the set permission button and receive the following " Please wait, attempting to process..." which never is returned. The same thing happens when I click the rename folders button in Step 4. Is there a way to do this manually if the readme.html file does not work? Exactly what permissions are to be set here anyways? I am using version 12.3 14 of March 2020 - Full version (not an update)
  17. What is the proper way to add media to a cemetery. I created a cemetery, and now I want to add the picture/media to it. But I have 93 pictures that need to be added to the cemetery. I don't want to edit each of 93 picture and assign them to the cemetery. There must be a way to add them all in one shot. (a lot of thumbnail are missing, I'm working on it) Thanks, Jean-Luc
  18. What's wrong?? Fatal error: Call to undefined function tng_adminlayout() in /storage/content/61/154861/tng.lundhog.se/public_html/admin_templateconfig.php on line 144
  19. I have done a fresh install of Linux Mint 20.3 and XAMPP for Linux 8.0.14 I have used Mint and XAMPP for several years without any problem. Now with a fresh install with the versions above, the http://localhost/jan/readme.html failed ti install. Example: "4. Rename two folders: For security reasons, we recommend you choose different names for the GEDCOM and Backups folders. If you've completed this step before, you'll get an error here. Don't worry, just keep going. Backups Folder: backupsjan Folder backups could not be renamed (<error) GEDCOM Folder: gedcomjan Folder gedcom could not be renamed (<error) 5. Choose your language and character set: If the choices you see are what you want, then you don't need to do anything here. If your language includes a lot of special characters, choose the UTF-8 variant. Language: Norwegian (UTF-8) Please wait, attempting to process..." (<error hanging forever) I have also tried chmod -R 777 . on dir. /opt/lampp/htdocs/jan Perhaps permissions are an issue here, but i dont know. Anyone? Thanks!
  20. Hello Everyone, I'm just updating to the latest version and get the below message when I attempt to Back up the tables from Utilities. Any suggestions before I go any further? An error has occurred in the TNG software. This could be due to a setup issue, an incomplete upgrade or a program bug. If you are the site owner, you may contact TNG support for help with this problem. Please copy the query below and paste it into your message. Query: SELECT * FROM LIMIT 0, 10000 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'LIMIT 0, 10000' at line 1
  21. I have been following the upgrade instructions for 11.x to 13.x and all was going well until i tried to execute 7. Update the database structure. I got the error: This page isn’t working [sitename] is currently unable to handle this request. HTTP ERROR 500 I now get this error on every page on my site. Please can someone advise what I may have done wrong or where to look.
  22. My site was working without any problem but now I cannot open any page without receiving the following error: Query: SELECT MAX(visitDate) AS max1 from WHERE visitUser = 'Admin'; You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'WHERE visitUser = 'Admin'' at line 1 Any suggestions? I did make an small adjustment to the customconfig.php file. Removed the change same result, Installed a blank customconfig,php file stilll the same result. www.lathro.pe
  23. Just installed the update to 13.1 from 12.x. All went well except, when I tried to log in, my Admin login failed. After panicking and tearing my hair for an hour or so, I discovered that the problem was that version 12.x would accept upper and lower case letters in the user name as being equivalent. However, 13.1 has (rightly so) eliminated this equivalency and insists that both the User Name and password match EXACTLY! Of course my browser had happily stored my login credentials precisely as I had entered them including the wrong case for one letter! Hope this helps someone.
  24. I'm just installing a new tng on my new ampps. Ran into this error when trying to go into admin: any help with explanation and fix would greatly appreciated. btw, I had to do about 1/3 of the install by editing the config.php filr. I got that precious "Please wait, attempting to process" Fixed those i think. now i get this one: Well, i can't get to admin page or home page yet.
  25. Anyone know what this crap means? trying to reinstall lazarusgb....again. works great on the wamp server but can't get past the installer screen because of: Warning: mysqli_connect(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/joneshy1/public_html/lazarusgb/lib/mysqli.class.php on line 33 Warning: mysqli_connect(): (HY000/2002): php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/joneshy1/public_html/lazarusgb/lib/mysqli.class.php on line 33 Warning: mysqli_select_db() expects parameter 1 to be mysqli, bool given in /home/joneshy1/public_html/lazarusgb/lib/mysqli.class.php on line 38 any help in this matter will be greatly appreciated. close this thread. My hosting site took care of it.
×