Jump to content
TNG Community

Search the Community

Showing results for tags 'tng-v12'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • TNG Specific
    • Announcements
    • Questions and Answers
    • Installation and Configuration
    • New Ideas and Suggestions
    • Code Discussion
    • Templates or Design Questions
    • CMS Integrations
    • TNG Wiki
  • Community
    • Member Webpages
    • Genealogy
    • Chit Chat
    • Questions and Answers
    • Offers And Requests

Blogs

  • Community News
  • TNG News

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 188 results

  1. bryanlewis

    Private Media Mod Issue

    I have a fresh install of TNG 12.3 that I am using to start a new tree (no data import). I want to keep certain photos/documents completely private, even for deceased people, so I installed the Private Media Mod, thinking that was the perfect solution. The install went fine and I marked a few photos and docs as private and they vanished from the public interface (I didn't want a placeholder that said they were private/living, I just wanted them gone). I thought everything was working fine, until I went back to view them as my own (admin) user and they were still gone. The photos simply don't show up at all in the "public-facing" interface, they only appear in the Media management admin interface. My user is in the "Admin" role and has all permissions, including the newly added "Allow to view private media" permission from this mod. But I can only view these private items through the management interface, not browse them through the normal interface (logged in as me). Am I misunderstanding how this mod works? I don't see any configuration options that I have missed. Any pointers would be appreciated. Thanks, Bryan
  2. I was disappointed tonight to discover no Heatmap button after a search involving my census records. Is this because they are held as an event? (IE The PLACE is not in the main person record but off in a child?) Is it an enhancement we could reasonably ask for - would be very useful?
  3. The mod 'Shows issues' cannot install, and an error message says "Bad Target". TNG: 12.3 Mod: Shows issues: 12.0.0.3a Anyone who knows . . . .? ENo
  4. thomsi

    Visitor Counter

    Hi I am new to TNG and web building. Is there a mod available to add a visitor count to the website or if not how would I add one. Many Thanks
  5. Hi All, I am new to TNG and have just set up our genealogy site. When I loaded up the Gedcom file the Dad's side and Mom's side is wrong. It's as if the system is using my mother as the starting point. Is there a way to correct this? Thanks in advance, Dave
  6. Before installing the new version I removed all the "mods". Then I removed the parent mod from the website. Then I uploaded the new version. Immediately it gives an error "cannot install". Here the error code:
  7. Indicates the following error (line 416 & line 570): My installed mods: 1. Cemeteries Columns cemeteries_columns_V10.1.0.8.cfg 10.1.0.8 Geïnstalleerd [Opties] 2. Create Sitemap create_sitemap_v12.0.0.1.cfg 12.0.0.1 Geïnstalleerd [Opties] 3. GeoCode Assistant geocode_assist_v11.0.0.3.cfg 11.0.0.3 Geïnstalleerd 4. Map Pins Map_pins_v12.01.cfg 12.01 Geïnstalleerd 5. Mobile Site Enhancements mobile_site_v12.1.0.5a.cfg 12.1.0.5a Geïnstalleerd 6. Open My Page mod OpenMyPage_mod_v10.0.0.4b.cfg 10.0.0.4b Geïnstalleerd 7. OpenStreetMap openstreetmap_v12.3.0.6.cfg 12.3.0.6 Geïnstalleerd [Opties] 8. OSM Automatic Geocoding osm_automatic_geocode_v12.2.0.2.cfg 12.2.0.2 Geïnstalleerd 9. Person Media Title person_media_title_v12.3.0.4.cfg 12.3.0.4 Kan niet installeren 10. Public Access Control public_access_control_v12.3.0.3a.cfg 12.3.0.3a Geïnstalleerd [Opties] 11. Redundant Person Tabs redundant_person_tabs_v12.0.0.0.cfg 12.0.0.0 Geïnstalleerd 12. Show Husband or Wife mod Show_Husband_or_Wife_mod_v11.0.1.1c.cfg 11.0.1.1c Geïnstalleerd 13. Show Nickname show_nicknames_v12.3.0.0.cfg 12.3.0.0 Geïnstalleerd [Opties] 14. Simple SEO simple_seo_v12.0.3.6a.cfg 12.0.3.6a Geïnstalleerd [Opties]
  8. Hi All, I created my first page in TNG today (an FAQ for visitors to my site). However, there was one thing that was frustrating and I am wondering if I could have done something differently. How do I chose the right size for the images without guessing a bunch of times and reloading the page after each adjustment. What is a good size for images that works? (width = , height = ). Here's what I did. I altered the template for a page as directed in the creating user pages documentation. I captured images I wanted to use with screenshots in Windows 10 (and then I edited the images (cropped, put in circles or underlining)). I used an online WYSIWYG HTML Editor for the text and inserted the images accordingly. I guessed on the sizing of the images and then changed them as I saw fit. I cut and pasted the code into the right place on the page blank. I uploaded the changes to the site, and all came out well, except the images are kind of different sizes. How do I fix that? Check out the page I created if you like: https://landgen.us/extrapgs/User FAQ.php Thanks for your help! Best, Bob
  9. andrewfindlay

    FH GEDCOM Import Failing

    I have exported a Gedcom from Family Historian 6 and then imported into TNG 12 following all the advice on the FH and TNG help pages, user groups, wikis etc. However all that will import are 520 people (of over 6,000) and they are fragmented, with links only going one generation. I have checked the exported Gedcom, cleared trees, made new trees and anything else I can think of, with no result. Only thing that worked was exporting a Gedcom based on a diagram of 469 people. Is there a setting in TNG that is limiting the number of people imported? If not, does anyone have any other ideas?
  10. Branko

    Report -

    Hi, I'm having a little bit of an issue with creating a report by using SQL SELECT where I want to list all children that have passed under the age of 5. The report works (sort off) but I want to filter out those persons that don't have a birthdate or if they have a brithdate but don't have a deathdate. My code is: SELECT tng_people.personID, lastname, firstname,birthdate,deathdate FROM (tng_people ) WHERE birthdate IS NOT NULL AND (right(deathdate,4) <= right(birthdate,4) + 5) ORDER BY lastname To get around the filtering in SQL I have exported the info to CSV and then filtered via Excel, but that's not the desired option. Branko
  11. zanger02

    reCaptcha Problem

    I'm having trouble with reCaptcha. I added the keys from google reCaptcha and realized I should be using v2 keys. I can't find any options for V2. Where would I find the V2 keys? My website TNG V 12.1 (Mac OS Catalina)
  12. ton van lil

    Error in place list

    I get an error massage when I focus on my place list. See below An error has occurred in the TNG software. This could be due to a setup issue, an incomplete upgrade or a program bug. If you are the site owner, you may contact TNG support for help with this problem. Please copy the query below and paste it into your message.Query: SELECT tng_people.ID, tng_people.personID, lastname, lnprefix, firstname, tng_people.living, tng_people.private, tng_people.branch, prefix, suffix, nameorder, /*###Placesearch-More Info Location 14: add birth & death fields*/ birthdate AS birthdate1, deathdate AS deathdate1, birthplace as birthplace1, deathplace as deathplace1, /*###Placesearch-More Info Location 14: End of Trimreplace*/ place, date, tng_people.gedcom, treename FROM (tng_people, tng_trees ) WHERE tng_people.gedcom = tng_trees.gedcom AND tng_people.gedcom="total" AND place = '' ORDER BY lastname, firstname, datetr LIMIT 50Unknown column 'place' in 'field list' What can I do.
  13. SiEiNo

    Show Siblings mod

    The edit options won't work. I want to be able to choose between a collapsed list or not - and where the list will show up, just as the options are in the Mod Manager. But trying to change the options in the Mod Manager doesn't help. Trying to edit the options gives a "0" and no change for the siblings list, no list at all. TNG v.12.3 Mod: ShowSiblings v10.1.0.4b What . . . .? I've tried to uninstall and reinstall and use of different languages, but no help. ENo
  14. Hello everyone, I figured out that my site displays incorrectly when I visit it for the first time. I think this happens since update 12.3 but I am not completely sure. It changes to normal view, when I change the language in the dropdown menu or log in to my admin account. I would be very happy if someone would have a look at the site, because unfortunately I have too little knowledge to find the error myself. Maybe it is a outdated PHP Version, but the site was not affected by now. Here is the link to my site: https://hauge.de
  15. Hi, I have been working with a local version of TNG and WP to set it up with the TNG Wordpress Plugin. All seems to work fine in the local version, but if I try to do the same in the online version the TNG header shows up expanded vertical under Wordpress, like this: ../wp/genealogy The local version looks normal like this: ../wp/genealogy I dont know why this is happening or what is triggering it and more important how to fix it. To make it more confusing so will the same index.php thats used for this show up normal if addressed directly: ../tng/index.php Any tip or idea of how to solve this will be much appreciated Regards Jastro
  16. Greg Martin

    OpenStreetMaps mod

    I updated to TNG v12.3 yesterday, removed the old OpenStreetMaps mod, downloaded and unzipped the new OpenStreetMaps v12.3.0.6a mod, and put the unzipped files in the mods folder on my website. Cleared the cache, also. I believe I've followed the instructions correctly, but as you can see in the attachment, OpenStreetMaps is not in the list of mods. I'm obviously not doing something right, and if you're read this far, you know that I'm no tech wizard who can figure it out for himself. Will greatly appreciate any help. In case it's needed for any reason, the URL of my website is Thank you!
  17. Martin Kilkie

    My page

    A really obvious question with an obvious answer that I cannot see? I have set TNG to attach each user to their database id. This usefully creates a mypage tab on the individual page. Great. What my users want is a mypage option on the front end. I use template 13 which my users like (i have tested others and my own efforts). I can see how to attach any specific user id but not the logged in person's. I assume there is an internal variable that is set when you log in and this creates mypage, but I cannot see how to use this elsewhere. Any help as usual appreciated. best regards Martin Kilkie
  18. Hi, I'm trying to turn off the use of templates to better customize the homepage (index.php). But, since I already have some useful text stored in the templates, I was wondering if its possible to access them without using templates directly? And maybe there will be some better ways to use text in the customized homepage without storing it in the index.php file itself? Best regards Jastro
  19. zanger02

    Photos Index isn't private

    TNG 12.1 / template 18 /MacOS Catalina 10.15.2 When visiting my website a user who's not logged in can view the index list of images. They can also view the individual image when clicking the link. Everything else seems restricted to user login. Any thoughts on how to correct this?
  20. zanger02

    Template 18 - links on home page

    I'd like to add more links to the right of the existing links on the home page. No matter what I try the extra links don't show or they are duplicates of the first two. TNG v12.1 and template 18. Not sure what I'm missing. I'm a developer but I'm really new to PHP. Before changes <?php include($cms['tngpath'] . "surname_cloud.class.php"); $flags['noicons'] = true; $flags['noheader'] = true; $flags['nobody'] = true; $tngconfig['showshare'] = false; tng_header( $sitename ? "" : $text['ourhist'], $flags ); if(!$cms['support'] && $sitever != "mobile") echo "<body id=\"bodytop\" class=\"" . pathinfo(basename($_SERVER['SCRIPT_NAME']), PATHINFO_FILENAME) . " homebody\">\n"; $dadlabel = getTemplateMessage('t18_dadside'); $momlabel = getTemplateMessage('t18_momside'); ?> <div class="theader"> <div id="thomemast" class="mast"> <h1><?php echo getTemplateMessage('t18_maintitle'); ?></h1> <span class="tsubtitle"><?php echo getTemplateMessage('t18_headsubtitle'); ?></span> </div> <div id="tmenu"> <ul> <?php if($dadlabel) { ?> <li><a href="<?php echo $cms['tngpath']; ?>pedigree.php?personID=<?php echo $tmp['t18_dadperson']; ?>&tree=<?php echo $tmp['t18_dadtree']; ?>"><?php echo $dadlabel; ?></a></li> <?php } if($momlabel) { ?> <li><a href="<?php echo $cms['tngpath']; ?>pedigree.php?personID=<?php echo $tmp['t18_momperson']; ?>&tree=<?php echo $tmp['t18_momtree']; ?>"><?php echo $momlabel; ?></a></li> <?php } echo showLinks($tmp['t18_featurelinks'],false); ?> </ul> </div> </div> I tried adding two more links ............ $dadlabel = getTemplateMessage('t18_dadside'); $momlabel = getTemplateMessage('t18_momside'); $stepdadlabel = getTemplateMessage('t18_stepdadside'); $stepmomlabel = getTemplateMessage('t18_stepmomside'); ............ <?php if($dadlabel) { ?> <li><a href="<?php echo $cms['tngpath']; ?>pedigree.php?personID=<?php echo $tmp['t18_dadperson']; ?>&tree=<?php echo $tmp['t18_dadtree']; ?>"><?php echo $dadlabel; ?></a></li> <?php } if($momlabel) { ?> <li><a href="<?php echo $cms['tngpath']; ?>pedigree.php?personID=<?php echo $tmp['t18_momperson']; ?>&tree=<?php echo $tmp['t18_momtree']; ?>"><?php echo $momlabel; ?></a></li> <?php } if($stepdadlabel) { ?> <li><a href="<?php echo $cms['tngpath']; ?>pedigree.php?personID=<?php echo $tmp['t18_stepdadperson']; ?>&tree=<?php echo $tmp['t18_stepdadtree']; ?>"><?php echo $stepdadlabel; ?></a></li> <?php } if($stepmomlabel) { ?> <li><a href="<?php echo $cms['tngpath']; ?>pedigree.php?personID=<?php echo $tmp['t18_stepmomperson']; ?>&tree=<?php echo $tmp['t18_stepmomtree']; ?>"><?php echo $stepmomlabel; ?></a></li> <?php } echo showLinks($tmp['t18_featurelinks'],false); ?>
  21. I am trying to create a report similar, or exactly if needed, like the one on the demo site. However I am only getting an error. I'm simply trying to create a report for persons that have been created and/or modified in the last 30-60 days. Thank you. This is what I have entered for the report: This is what I get in return:
  22. I am using template 13 on TNG version 12.1 if that means anything. I am trying to figure out what to change in order for the Calendar to display the year in a different color. As you can see in my attachment, the year that appears next to the person's name is in white and barely visible. I opened the css titled Calendar.css and thought it would be an easy find. But I cannot figure out which line to change. I tried adding a line to the acal.Event, but that did not seem to change it. /* calendar */ #calHeader { font-size: 14pt; font-weight: bold; text-align: center; } #calLegend { background-color:#D6E7FF; border: 1px solid #5576BE; font-size: 9pt; font-weight: bold; margin-top: 8px; padding: 4px; text-align: center; } #calWrapper { width: 100%; } a.calDate { color: #000; float: left; font-size: 11pt; font-weight: bold; } a.calMore { font-size: 8pt; line-height: 24px; margin-left: 16px; } a.calEvent { font-size: 8pt; } a.hidden { background-color:silver; font-style:italic; padding:2px; } a.nothidden { padding:2px; } div.calEvents { margin-left: 16px; position: relative; top: -14px; } div.calKey { margin: 8px; font-weight: bold; } img.calIcon { margin: 2px; position: relative; top: 2px; } table.calTip { background-color: #fff; border: 1px solid #5576BE; padding: 0; } table.calendar { background-color: #eee; border: 1px solid #6687CD; margin: 4px 0px; } td.calDay { background-color: #fff; border-top: 1px solid #5576BE; border-left: 1px solid #5576BE; border-bottom: 2px solid #5576BE; border-right: 2px solid #5576BE; height: 110px; margin: 4px; padding: 2px; text-align: left; vertical-align: top; width: 14%; -moz-border-radius: 4px; -webkit-border-radius: 4px; border-radius: 4px; } th.calDay { font-size: 10pt; font-weight: bold; text-align: center; } td.calSkip { height: 110px; width: 14%; } td.calToday { background-color:#FFF5E4; border-top: 1px solid #5576BE; border-left: 1px solid #5576BE; border-bottom: 2px solid #5576BE; border-right: 2px solid #5576BE; height: 110px; margin: 4px; padding: 2px; text-align: left; vertical-align: top; width: 14%; -moz-border-radius: 4px; -webkit-border-radius: 4px; border-radius: 4px; } li.flat { display: inline; list-style: none; margin: 0px 8px; } ul.flat { display: inline; Thank you
  23. For some reason, my source citations are no longer showing up at the bottom of the individual page, and I have no idea where to start looking for the problem. I'm guessing it's a "Setup" option, but have looked through there and I don't see anything that would be appropriate. The footnote anchors are still there -- clicking on them just doesn't do anything. The sources show that they're attached to the proper individuals. The only problem is the lack of the list of citations that's usually at the bottom of the page.
  24. Hi,I have a issue after upgrading to TNG 12.3. My Census Plus International Mod wont install. I'm using Template 18 and Mod is v.12.0.0.10a. Any suggestions? Line 44: %target:@extensions/cp_settings.inc% verified line 50: %parameter:$cp_addusa:USA% line 54: %parameter:$cp_adduk:% line 58: %parameter:$cp_unlink:n% line 62: %parameter:$cp_addcounty:County% line 66: %parameter:$cp_addtreeid:n% line 70: %parameter:$cp_ancestrySite:com% line 74: %parameter:$cp_searchlink:n% line 78: %parameter:$cp_DOMsource:n% line 82: %parameter:$cp_overlayEvent:n% line 87: %parameter:$cp_addnewpeople:y% line 91: %parameter:$cp_returnall:y% line 95: %parameter:$cp_medialinked:y% line 99: %parameter:$cp_displayID:y% line 103: %parameter:$cp_displayRef:y% line 107: %parameter:$cp_deleteEvent:n% line 111: %parameter:$cp_displayShowHide:y% line 115: %parameter:$cp_NextPreviousLinks:n% line 118: %target:css/genstyle.css% verified line 119: %location:% #1 not installed line 238: %target:@templates/template1/css/templatestyle.css% verified line 241: %location:% #1 not installed line 261: %target:@templates/template4/css/templatestyle.css% verified line 264: %location:% #1 not installed line 282: %target:@templates/template5/css/templatestyle.css% verified line 285: %location:% #1 not installed line 326: %target:@templates/template9/css/templatestyle.css% verified line 329: %location:% #1 not installed line 359: %target:@templates/template10/css/templatestyle.css% verified line 362: %location:% #1 not installed line 385: %target:@templates/template11/css/templatestyle.css% verified line 388: %location:% #1 not installed line 416: %target:@templates/template13/css/templatestyle.css% is not writable, check permissions line 446: %target:templates/template14/css/templatestyle.css% is not writable, check permissions line 474: %target:personlib.php% verified line 477: %location:% #1 not installedline 492: %location:% #2 not installedline 512: %location:% #3 not installedline 520: %location:% #4 not installedline 529: %location:% #5 not installed line 536: %target:admin_merge.php% verified line 537: %location:% #1 not installed line 555: %target:admin_main.php% verified line 556: %location:% #1 not installed line 563: %target:admin_leftbanner.php% verified line 564: %location:% #1 not installed line 573: %target:admin_secondmenu.php% verified line 574: %location:% #1 not installed line 581: %target:admin_secondary.php% verified line 582: %location:% #1 not installed line 691: %target:languages/English/cust_text.php% verified line 692: %location:% #1 not installed line 719: %target:languages/English-UTF8/cust_text.php% verified line 720: %location:% #1 not installed line 747: %target:customconfig.php% verified line 748: %location:% #1 not installed line 762: %target:admin_genconfig.php% verified line 763: %location:% #1 not installedline 773: %location:% #2 not installed line 782: %target:admin_utilities.php% verified line 783: %location:% #1 not installed line 795: %target:admin_backup.php% verified line 796: %location:% #1 not installed line 804: %target:admin_optimize.php% verified line 805: %location:% #1 not installed line 813: %target:admin_restore.php% verified line 814: %location:% #1 not installed line 822: %target:deletelib.php% verified line 825: %location:% #1 not installedline 840: %location:% #2 not installed line 848: %target:admin_deleteevent.php% verified line 851: %location:% #1 not installed line 867: %target:ajx_delete.php% verified line 870: %location:% #1 not installed line 878: %target:treelib.php% verified line 880: %location:% #1 not installed line 958: %copyfile: admin_censusplus.php not copied Source: mods/censusplus_v120010a/admin_censusplus.php line 959: %copyfile: admin_cpcreate.php not copied Source: mods/censusplus_v120010a/admin_cpcreate.php line 960: %copyfile: admin_cpdelete.php not copied Source: mods/censusplus_v120010a/admin_cpdelete.php line 961: %copyfile: admin_cpdeleteselected.php not copied Source: mods/censusplus_v120010a/admin_cpdeleteselected.php line 962: %copyfile: admin_cpedit.php not copied Source: mods/censusplus_v120010a/admin_cpedit.php line 963: %copyfile: admin_cpimage.php not copied Source: mods/censusplus_v120010a/admin_cpimage.php line 964: %copyfile: admin_cplinkIDs.php not copied Source: mods/censusplus_v120010a/admin_cplinkIDs.php line 965: %copyfile: admin_cprestore.php not copied Source: mods/censusplus_v120010a/admin_cprestore.php line 966: %copyfile: admin_cpscrape.php not copied Source: mods/censusplus_v120010a/admin_cpscrape.php line 967: %copyfile: admin_cpupdate.php not copied Source: mods/censusplus_v120010a/admin_cpupdate.php line 968: %copyfile: admin_cpxfamsearch.php not copied Source: mods/censusplus_v120010a/admin_cpxfamsearch.php line 969: %copyfile: admin_cpxtngsearch.php not copied Source: mods/censusplus_v120010a/admin_cpxtngsearch.php line 970: %copyfile: copycentables.php not copied Source: mods/censusplus_v120010a/copycentables.php line 971: %copyfile: cpaddimage.php not copied Source: mods/censusplus_v120010a/cpaddimage.php line 972: %copyfile: cpcheck_tables.php not copied Source: mods/censusplus_v120010a/cpcheck_tables.php line 973: %copyfile: cpcreate.php not copied Source: mods/censusplus_v120010a/cpcreate.php line 974: %copyfile: cpcreateindices.php not copied Source: mods/censusplus_v120010a/cpcreateindices.php line 975: %copyfile: cpdelete.php not copied Source: mods/censusplus_v120010a/cpdelete.php line 976: %copyfile: cpdisplay.php not copied Source: mods/censusplus_v120010a/cpdisplay.php line 977: %copyfile: cpdroptables.php not copied Source: mods/censusplus_v120010a/cpdroptables.php line 978: %copyfile: cpfindID.php not copied Source: mods/censusplus_v120010a/cpfindID.php line 979: %copyfile: cpfind2linkID.php not copied Source: mods/censusplus_v120010a/cpfind2linkID.php line 980: %copyfile: cphouseholdupdate.php not copied Source: mods/censusplus_v120010a/cphouseholdupdate.php line 981: %copyfile: cpinclude.php not copied Source: mods/censusplus_v120010a/cpinclude.php line 982: %copyfile: cplinkID.php not copied Source: mods/censusplus_v120010a/cplinkID.php line 983: %copyfile: cploaddata.php not copied Source: mods/censusplus_v120010a/cploaddata.php line 984: %copyfile: cpmakedir.php not copied Source: mods/censusplus_v120010a/cpmakedir.php line 985: %copyfile: cpmakelabel.php not copied Source: mods/censusplus_v120010a/cpmakelabel.php line 986: %copyfile: cpmakesummary.php not copied Source: mods/censusplus_v120010a/cpmakesummary.php line 987: %copyfile: cpmaketables.php not copied Source: mods/censusplus_v120010a/cpmaketables.php line 988: %copyfile: cpmakeveteran.php not copied Source: mods/censusplus_v120010a/cpmakeveteran.php line 989: %copyfile: cpproccreate.php not copied Source: mods/censusplus_v120010a/cpproccreate.php line 990: %copyfile: cpprochousehold.php not copied Source: mods/censusplus_v120010a/cpprochousehold.php line 991: %copyfile: cpproclabel.php not copied Source: mods/censusplus_v120010a/cpproclabel.php line 992: %copyfile: cpprocupdate.php not copied Source: mods/censusplus_v120010a/cpprocupdate.php line 993: %copyfile: cpscrapeALL.php not copied Source: mods/censusplus_v120010a/cpscrapeALL.php line 994: %copyfile: cpsearch.php not copied Source: mods/censusplus_v120010a/cpsearch.php line 995: %copyfile: cpUSsummary.php not copied Source: mods/censusplus_v120010a/cpUSsummary.php line 996: %copyfile: cpUSvet.php not copied Source: mods/censusplus_v120010a/cpUSvet.php line 997: %copyfile: cpsummary.php not copied Source: mods/censusplus_v120010a/cpsummary.php line 998: %copyfile: cpupdate.php not copied Source: mods/censusplus_v120010a/cpupdate.php line 999: %copyfile: cpupdate_eventIDs.php not copied Source: mods/censusplus_v120010a/cpupdate_eventIDs.php line 1000: %copyfile: cpupdate_label.php not copied Source: mods/censusplus_v120010a/cpupdate_label.php line 1001: %copyfile: cpupdate_transid.php not copied Source: mods/censusplus_v120010a/cpupdate_transid.php line 1002: %copyfile: cpxfamsearch.php not copied Source: mods/censusplus_v120010a/cpxfamsearch.php line 1003: %copyfile: cpxsearch.php not copied Source: mods/censusplus_v120010a/cpxsearch.php line 1004: %copyfile: cpxsearchlib.php not copied Source: mods/censusplus_v120010a/cpxsearchlib.php line 1005: %copyfile: cpxtngsearch.php not copied Source: mods/censusplus_v120010a/cpxtngsearch.php line 1006: %copyfile: dropcensustables.php not copied Source: mods/censusplus_v120010a/dropcensustables.php line 1007: %copyfile: micro_cpinclude.php not copied Source: mods/censusplus_v120010a/micro_cpinclude.php line 1008: %copyfile: simple_html_dom.php not copied Source: mods/censusplus_v120010a/simple_html_dom.php line 1009: %copyfile: upgrade_cp_tables.php not copied Source: mods/censusplus_v120010a/upgrade_cp_tables.php line 1010: %copyfile: upgrade_cp_summary.php not copied Source: mods/censusplus_v120010a/upgrade_cp_summary.php line 1011: %copyfile: upgrade_cp_veteran.php not copied Source: mods/censusplus_v120010a/upgrade_cp_veteran.php line 1012: %copyfile2: js/cenplus.js not copied Source: mods/censusplus_v120010a/cenplus.js line 1013: %copyfile2: languages/English/cp_text.php not copied Source: mods/censusplus_v120010a/cp_text.php line 1014: %copyfile2: languages/English-UTF8/cp_text.php not copied Source: mods/censusplus_v120010a/cp_text.php line 1015: %copyfile2: img/cpi_icon.gif not copied Source: mods/censusplus_v120010a/cpi_icon.gif line 1016: %copyfile2: img/cpicon.jpg not copied Source: mods/censusplus_v120010a/cpicon.jpg line 1017: %copyfile2: img/cpsprite.jpg not copied Source: mods/censusplus_v120010a/cpsprite.jpg code modifications specified: 31; modified: 0 file copies specified: 60; copied: 0 new files specified: 0; created: 0 new folders specified: 0; created: 0 errors: 2
  25. I am doing a simple mod to my site that will show who was born or died on todays date. I got it working and get a list of people that is added to the topmenu.php file. My problem is that I also want the names in the list to link to the getperson.php page for more information on that person. This is the code I have echo '<a href="getperson.php?personID=' . $row['personID'] . '&tree=' . $row['gedcom'] . '">' . $row['firstname'] . ' ' . $row['lastname'] . '<br>' . $row['birthdatetr'] . '</a></p>'; This will give me: Parse error: syntax error, unexpected ' ' (T_STRING), expecting ',' or ';' in your code What makes this even more frustrating is that exactly the same line of code works perfectly in Joomla that runs in parallell with my TNG site. I have also tried different variants. If I run it without the HREF it will show the names, see screen shot. This line is in a While loop and if I don't do that loop it will show correctly the last line with working link. Below is the whole thing $query = "SELECT * FROM `tng_people` WHERE DAYOFMONTH( birthdatetr ) =$daynumber AND MONTH( birthdatetr ) =$monthnumber AND YEAR(`deathdatetr`) != 0000 ORDER BY birthdatetr"; if($result = mysqli_query($connection, $query)){ if(mysqli_num_rows($result) > 0) { while($row = mysqli_fetch_array($result)){ echo "<p>"; echo '<a href="getperson.php?personID=' . $row['personID'] . '&tree=' . $row['gedcom'] . '">' . $row['firstname'] . ' ' . $row['lastname'] . '<br>' . $row['birthdatetr'] . '</a></p>'; } } } I'm not a PHP expert but I can normally get it done, this is above my skills. Appreciate any help, thanks.
×