Jump to content
TNG Community
klooster

how I integrated TNG with Wordpress, Artisteer and AllwebMenusPro

Recommended Posts

klooster

For all those who are interested, I made a webpage with an explanation how I integrated TNG with Wordpress, Artisteer and AllwebMenusPro (without the TNG+WP plugin)

Take a look at my genealogy website

Kloosterman Genealogy

and more specific about TNG and Wordpress:

How I made My TNG_WP Webpage

Cees Kloosterman :P

Share this post


Link to post
Share on other sites
greenery

For all those who are interested, I made a webpage with an explanation how I integrated TNG with Wordpress, Artisteer and AllwebMenusPro (without the TNG+WP plugin)

Take a look at my genealogy website

Kloosterman Genealogy

and more specific about TNG and Wordpress:

My TNG_WP Webpage

Cees Kloosterman :P

Very impressive, and if I ever gather the courage, I think the instructions are well laid out and clear enough to give it a try.

Share this post


Link to post
Share on other sites
Mike H

For all those who are interested, I made a webpage with an explanation how I integrated TNG with Wordpress, Artisteer and AllwebMenusPro (without the TNG+WP plugin)

Take a look at my genealogy website

Kloosterman Genealogy

and more specific about TNG and Wordpress:

How I made My TNG_WP Webpage

Cees Kloosterman :P

Cees,

I appreciate your clear directions on integrating with api.

I was able to do the integration on my WAMP site. However I have one issue I can't seem to resolve.

My tng pages display on the "(404) not found pages". The display looks fine, but causes me problems with the themes sidebar. This happens regardless of the wp theme I use.

If I look at my page source(with Chrome) I see this <title>404 - Page not found « Hart Family History</title>

If I look at the page source on your site I notice the same type of reference "Pagina niet gevonden", while this doesn't seem to be a problem for you. Do you have any suggestions on how I might have the integration appear on the "page" pages?

You won't see this on my live site, I am still using the wp-tng plugin.

best regards,

Mike

http://hartfamilyhistory.com/

Share this post


Link to post
Share on other sites
Mike H

Cees,

I appreciate your clear directions on integrating with api.

I was able to do the integration on my WAMP site. However I have one issue I can't seem to resolve.

My tng pages display on the "(404) not found pages". The display looks fine, but causes me problems with the themes sidebar. This happens regardless of the wp theme I use.

If I look at my page source(with Chrome) I see this <title>404 - Page not found « Hart Family History</title>

If I look at the page source on your site I notice the same type of reference "Pagina niet gevonden", while this doesn't seem to be a problem for you. Do you have any suggestions on how I might have the integration appear on the "page" pages?

You won't see this on my live site, I am still using the wp-tng plugin.

best regards,

Mike

http://hartfamilyhistory.com/

Resolved

Share this post


Link to post
Share on other sites
klooster

Resolved

I redesigned and updated met Wordpress / TNG (and Artisteer and WP-TUxedo) website.

. You do not have to use the AllWEBmenu Pro menu any more.

· Just use the standard WP (or Artisteer) menus.

· You also do not really need Artisteer and WP Tuxedo. Any WordPress Theme will work with the TNG integration method I described. I only use Artisteer to design my own personal unique template and WP Tuxedo for the extra export possibilities from Artisteer.

· The great advantage of this method is that (contrary to the Wordpress TNG plugin) is that you are not restricted to the one sidebar theme layout.

· Any theme or theme design (1,2, no sidebars, menu anywhere) will work!

check out:

Kloosterman Genealogy and emigrants to America

If you are interested how I integrated TNG with Wordpress (and Artisteer and WP-TUxedo) read:

TNG and Wordpress

Share this post


Link to post
Share on other sites
klooster

Hi Roger,

Thanks for the info, I did not realise that.

When I started my WP/ TNG integration project the WordPress plugin moved the TNG menu into a WordPress sidebar, I did not want that.

My compliments about your Plugin !

I am absolutely not in competition with you. I had my own reasons to start my TNG/ WP project. I thought it was quite a challenge and that what life is about!

I corrected and updated my page with your information and linked to your excellent site.

Check the update on:

How I made my WP / TNG website

Is this oke with ypu ??

Share this post


Link to post
Share on other sites
theKiwi

Hi Cees

I can't take credit for the plugin - it was developed by Mark Barnes, and then tweaked a little by Darrin, and then I made some changes as TNG 9 was released.

Others have also done some work, particularly on the matter of having joined logins between WordPress and TNG - something that my site doesn't have so I haven't worked on that part of it.

Roger

Share this post


Link to post
Share on other sites
klooster

Hi Cees

I can't take credit for the plugin - it was developed by Mark Barnes, and then tweaked a little by Darrin, and then I made some changes as TNG 9 was released.

Others have also done some work, particularly on the matter of having joined logins between WordPress and TNG - something that my site doesn't have so I haven't worked on that part of it.

Roger

Hi Roger,

Thaks for your reaction, I corrected that part!

Share this post


Link to post
Share on other sites
McKern

For all those who are interested, I made a webpage with an explanation how I integrated TNG with Wordpress, Artisteer and AllwebMenusPro (without the TNG+WP plugin)

Take a look at my genealogy website

Kloosterman Genealogy

and more specific about TNG and Wordpress:

How I made My TNG_WP Webpage

Cees Kloosterman :P

I used basically the same method* to integrate WP and TNG, i.e., I included

require ("../wp-load.php"); 
in begin.php. Everything worked fine while I was running on localhost. Since uploading, however, quotes and apostrophes appear as \" and \' in TNG, while everything is fine on WP pages. Removing
require ("../wp-load.php"); 

from begin.php eliminated the problem. Of course, it also broke the integration. Has anyone else run into this problem?

Thanks for any info,

Bridget

*Differences: the apps are installed in separate directories; they share the stylesheet, and contents of the sidebar, top/banner, and footer divs - which are in the WP subdirectory. (I'm using a basic WP theme that I pieced together a couple of years ago.)

Share this post


Link to post
Share on other sites
klooster

I used basically the same method* to integrate WP and TNG, i.e., I included

require ("../wp-load.php"); 
in begin.php. Everything worked fine while I was running on localhost. Since uploading, however, quotes and apostrophes appear as \" and \' in TNG, while everything is fine on WP pages. Removing
require ("../wp-load.php"); 

from begin.php eliminated the problem. Of course, it also broke the integration. Has anyone else run into this problem?

Thanks for any info,

Bridget

*Differences: the apps are installed in separate directories; they share the stylesheet, and contents of the sidebar, top/banner, and footer divs - which are in the WP subdirectory. (I'm using a basic WP theme that I pieced together a couple of years ago.)

It is probably a theme related thing. I do not have this problem.

Important is:

• Install WordPress in the root folder of your website

• Install TNG in a direct sub-root folder. I called my TNG folder “genealogy” but any name will do.

TNG and WordPress must share the same database.

• Your complete theme, with your stylesheet, sidebar, etc. be in the /wp-content/themes/ directory.

Share this post


Link to post
Share on other sites
McKern

It is probably a theme related thing. I do not have this problem.

Important is:

• Install WordPress in the root folder of your website

• Install TNG in a direct sub-root folder. I called my TNG folder “genealogy” but any name will do.

TNG and WordPress must share the same database.

• Your complete theme, with your stylesheet, sidebar, etc. be in the /wp-content/themes/ directory.

Thank you for responding so quickly.

These 2 are true for my website:

TNG and WordPress must share the same database.

• Your complete theme, with your stylesheet, sidebar, etc. be in the /wp-content/themes/ directory.

However, WP and TNG are in separate directories. (Darrin said that the location of the files shouldn't make a difference regarding this particular issue.)

More info:

About the theme: I'm using a variation on a basic WP theme that I put together a couple of years ago. Quotes and apostrophes in WP display correctly. However, they are "curly" and the quotes in TNG are "straight", in case that makes a difference.

Without the code in begin.php, the quotes display correctly, but the sidebar on TNG pages is empty. (The top and footer divs are text, the sidebar is WordPress widgets.)

Clearly, it's not just that line of code in begin.php that's causing the problem, or you would have the same issue. Let me know if you have any other ideas.

Thank you,

Bridget

Share this post


Link to post
Share on other sites
klooster

Hi Roger,

Thanks for the info, I did not realise that.

When I started my WP/ TNG integration project the WordPress plugin moved the TNG menu into a WordPress sidebar, I did not want that.

My compliments about your Plugin !

I am absolutely not in competition with you. I had my own reasons to start my TNG/ WP project. I thought it was quite a challenge and that what life is about!

I corrected and updated my page with your information and linked to your excellent site.

Check the update on:

How I made my WP / TNG website

Is this oke with ypu ??

No it is is not he change in the begin.php file.

When I export my gedcom file from LEGACY, I use UTF-8 as the character set.

Check what the collation of your databaseis set to? To find this out, go to your controll and find phpMyAdmin, then look at your database by clicking its name in the column on the left. Normal standard installation of TNG doesn set i to URF-8, but to Latin

Be sure to have the database tables collatation set as UTF-8.

If not use the collatation toll changer, link is here:

Collatation Tool Changer

Then make sure you have your character set specified as UTF-8 in the TNG Admin ------> Setup ------> General ------> Language and make the appropriate choice there - for UTF-8 choose "English UTF-8", for latin1 above, choose "English". Save those changes.

Now export a GEDCOM file from your Genealogy program using the appropriate setting UTF-8.

Import this in to TNG with the Replace All data setting and see if that fixes it.

Share this post


Link to post
Share on other sites
McKern

No it is is not he change in the begin.php file.

When I export my gedcom file from LEGACY, I use UTF-8 as the character set.

Check what the collation of your databaseis set to? To find this out, go to your controll and find phpMyAdmin, then look at your database by clicking its name in the column on the left. Normal standard installation of TNG doesn set i to URF-8, but to Latin

Be sure to have the database tables collatation set as UTF-8.

If not use the collatation toll changer, link is here:

Collatation Tool Changer

Then make sure you have your character set specified as UTF-8 in the TNG Admin ------> Setup ------> General ------> Language and make the appropriate choice there - for UTF-8 choose "English UTF-8", for latin1 above, choose "English". Save those changes.

Now export a GEDCOM file from your Genealogy program using the appropriate setting UTF-8.

Import this in to TNG with the Replace All data setting and see if that fixes it.

I appreciate your help - I don't know why this won't work for me.

I've always been set up as "English UTF-8", so that isn't the issue. (TNG is my only program, i.e., I'm not doing any importing or exporting.) Also, installing TNG in a WP subdirectory didn't fix the issue.

BTW - I was wrong when I said this wasn't an issue with localhost. Apparently, I didn't notice the problem because I made corrections directly in the database, rather than through the edit screens. (I'm in the process of cleaning up a database.)

About my WP theme - here is the content of functions.php. Could something in this file be causing the quote/apostrophe issue?

<?php
if ( function_exists('register_sidebar') )
register_sidebar(array(
'name'=>'sidebar1',
'before_widget' => '<div class="drop-shadow curved curved-hz-1">',/*Single horizontal curve*/
'after_widget' => '</div>',
));
register_sidebar(array(
'name'=>'sidebar2',
'before_widget' => '<div class="drop-shadow lifted">',
'after_widget' => '</div>',
));
register_sidebar(array(
'name'=>'sidebar3',
'before_widget' => '<div class="drop-shadow curved curved-vt-2">',/*Vertical curves*/
'after_widget' => '</div>',
));

//--------------------------------------------
//replaces "reply" with "comment"
function comment_reform ($arg) {
$arg['title_reply'] = __('Submit a comment');
$arg['label_submit'] = __('Submit comment');
return $arg;
}
add_filter('comment_form_defaults','comment_reform');

//--------------------------------------------
//replaces "excerpt" with "Read more"
function replace_excerpt($content) {
return str_replace('[...]',
'<a href="'. get_permalink() .'">Read more...</a>',
$content
);
}
add_filter('the_excerpt', 'replace_excerpt');

?>

Perhaps relevant (I don't know enough about php to make the call): the problem persists even when I remove the widgets from the sidebar - which I assume means that TNG is not accessing any WP functions (right?). Under these circumstances, I don't even need the code in begin.php to integrate the apps, but this limits what I can do with the sidebar.

So, any clues in this info?

Thank you,

Bridget

Share this post


Link to post
Share on other sites
klooster

Hi Bridget,

My PhP is not goed enough to check the functions.php, sorry!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×