Jump to content
TNG Community
Sign in to follow this  
CarlWGray

TNG9 with MediaWiki Mod

Recommended Posts

CarlWGray

Hi,

I've installed the Mediwiki mod with TNG version 9.01 and now have a couple of questions.

Since I don't program and I am just learning Mediawiki, I went through the install/uninstall process a few times this week, just to make sure I had a grasp of the concept.

After my final installation this morning, I have the following glitches that I hope someone can help me resolve.

When I log on as administrator, I can see the little boxed X icon for people and places. When I click on the icon (in this instance for a Place since I haven't tried People yet), it launches Mediawiki and allows me to create a page for that place. For this location, I copied the URL from Wikipedia and saved it and tested the new page.

When I go back to my TNG admin page, the little crossed X icon for the newly created page is no longer visible. I assume this is normal. If I click on the hyperlink for that place, it launches Mediawiki and goes to "Category:Places", then I have to click on the place name which then launches the proper page in Wikipedia. I want it to go directly to the page.

When I log out of my site, then log in as a registered user, I am not seeing any page icon. When I click on the hyperlink for the same place name, I get the same results as mentioned above. It goes to "Category:Places", then I have to click on the place name which then launches the proper page in Wikipedia.

Desired results:

  • Have the page icon visible
  • Have TNG go directly to the proper page in Wikipedia instead of Category:Place
I'm sure I've overlooked something minor but just can't find what I am doing wrong.

Thanks in advance.

Share this post


Link to post
Share on other sites
Ken Roy

Hi,

I've installed the Mediwiki mod with TNG version 9.01 and now have a couple of questions.

Since I don't program and I am just learning Mediawiki, I went through the install/uninstall process a few times this week, just to make sure I had a grasp of the concept.

After my final installation this morning, I have the following glitches that I hope someone can help me resolve.

When I log on as administrator, I can see the little boxed X icon for people and places. When I click on the icon (in this instance for a Place since I haven't tried People yet), it launches Mediawiki and allows me to create a page for that place. For this location, I copied the URL from Wikipedia and saved it and tested the new page.

When I go back to my TNG admin page, the little crossed X icon for the newly created page is no longer visible. I assume this is normal. If I click on the hyperlink for that place, it launches Mediawiki and goes to "Category:Places", then I have to click on the place name which then launches the proper page in Wikipedia. I want it to go directly to the page.

When I log out of my site, then log in as a registered user, I am not seeing any page icon. When I click on the hyperlink for the same place name, I get the same results as mentioned above. It goes to "Category:Places", then I have to click on the place name which then launches the proper page in Wikipedia.

Desired results:

  • Have the page icon visible
  • Have TNG go directly to the proper page in Wikipedia instead of Category:Place
I'm sure I've overlooked something minor but just can't find what I am doing wrong.

Thanks in advance.

Carl,

The page-create icon should be replaced with the tng document icon, and the place links should go directly to the Place page.

Did you Edit the Wiki Integration mod after installation to point to the correct location of your wiki?

If you want to send me credentials that give me admin rights to create wiki pages I can take a look at it. Send me the credentials via my web site Contact Us page.

Ken

Share this post


Link to post
Share on other sites
CarlWGray

Carl,

The page-create icon should be replaced with the tng document icon, and the place links should go directly to the Place page.

Did you Edit the Wiki Integration mod after installation to point to the correct location of your wiki?

If you want to send me credentials that give me admin rights to create wiki pages I can take a look at it. Send me the credentials via my web site Contact Us page.

Ken

Ken,

I thought I had made all the necessary changes, but I must have missed something.

Thanks for your offer to take a look.

I'll contact you from your web-site.

Share this post


Link to post
Share on other sites
CarlWGray

Ken,

I thought I had made all the necessary changes, but I must have missed something.

Thanks for your offer to take a look.

I'll contact you from your web-site.

As a followup to my problems, I've just fixed the link to people.

Since I was using "Strategy 1" in the wiki mod, I went back into TNG>>Admin>>Setup >> Configuration >> General Settings>>Names then changed Name Order to "Surname first (with commas)"

After saving this configuration, the page icon displays and launches that person's page in wiki.

Now to find what I am doing wrong on the "Places"? I suspect it may be something with the way I am editing the Place pages in MediaWiki.

Share this post


Link to post
Share on other sites
Ken Roy

As a followup to my problems, I've just fixed the link to people.

Since I was using "Strategy 1" in the wiki mod, I went back into TNG>>Admin>>Setup >> Configuration >> General Settings>>Names then changed Name Order to "Surname first (with commas)"

After saving this configuration, the page icon displays and launches that person's page in wiki.

Now to find what I am doing wrong on the "Places"? I suspect it may be something with the way I am editing the Place pages in MediaWiki.

Carl,

Glad you solved the problem with the person's page icon. Be aware that no such icon displays for MediaWiki created Places pages. The Place name becomes a link on the TNG page.

What do you mean by

it may be something with the way I am editing the Place pages in MediaWiki.

Share this post


Link to post
Share on other sites
CarlWGray

Carl,

Glad you solved the problem with the person's page icon. Be aware that no such icon displays for MediaWiki created Places pages. The Place name becomes a link on the TNG page.

What do you mean by

Thanks Ken, I was looking for the icon on the Places pages and that's why I thought I was missing something there.

When I click on the Place link, it launches the Mediawik page. So I guess it is all working as it should.

I was editing the MediaWiki page and adding an external link from Wikipedia to the Mediawiki page.

I was trying to launch the external link to Wikipedia directly from TNG and thought that would do it.

Share this post


Link to post
Share on other sites
Ken Roy

Thanks Ken, I was looking for the icon on the Places pages and that's why I thought I was missing something there.

When I click on the Place link, it launches the Mediawik page. So I guess it is all working as it should.

I was editing the MediaWiki page and adding an external link from Wikipedia to the Mediawiki page.

I was trying to launch the external link to Wikipedia directly from TNG and thought that would do it.

Carl,

There is a Wikipedia Link Mod that does create a link to Wikipedia, whether a page exists in Wikipedia or not, but it is from the Places search result pages

Share this post


Link to post
Share on other sites
CarlWGray

Carl,

There is a Wikipedia Link Mod that does create a link to Wikipedia, whether a page exists in Wikipedia or not, but it is from the Places search result pages

Ken,

Thanks again. I'll give the Wikipedia Link Mod a try

Share this post


Link to post
Share on other sites
CarlWGray

Ken,

Thanks again. I'll give the Wikipedia Link Mod a try

Thanks Ken,

All appears to be working properly now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×