Jump to content
TNG Community
Sign in to follow this  
Jim Williamson

Mediawiki Mod error with v9 clean installations

Recommended Posts

Jim Williamson

Running TNG 9.0.1 and Mediawiki latest version ?.19 I think?

Both are in the same DB, only problem I seem to have is when I go to the mods page in TNG, everything says Installed except one line:

Existing extensions/link_wiki1.php does not have a version number

So I get the message 'Unable to install this mod'

I check the /link_wiki1 file and it shows me the path to the wiki and the proper prefix, so it's seeing that much...

?? Clues??

Share this post


Link to post
Share on other sites
Ken Roy

Running TNG 9.0.1 and Mediawiki latest version ?.19 I think?

Both are in the same DB, only problem I seem to have is when I go to the mods page in TNG, everything says Installed except one line:

Existing extensions/link_wiki1.php does not have a version number

So I get the message 'Unable to install this mod'

I check the /link_wiki1 file and it shows me the path to the wiki and the proper prefix, so it's seeing that much...

?? Clues??

Jim,

Where did you get the link_wiki1.php file from? The one included in the mod for TNG V9 does include a version number.

I don't recall a version number generating the Unable to install this mod message. Are you sure there is not another error that is flagged in the list? What version of the Wiki Integration mod is it? Is this after an upgrade of TNG where you did not Remove the mods prior to upgrade?

Share this post


Link to post
Share on other sites
Jim Williamson

Jim,

Where did you get the link_wiki1.php file from? The one included in the mod for TNG V9 does include a version number.

I don't recall a version number generating the Unable to install this mod message. Are you sure there is not another error that is flagged in the list? What version of the Wiki Integration mod is it? Is this after an upgrade of TNG where you did not Remove the mods prior to upgrade?

Didn't get a notice from the forums about your reply... sorry for the delayed response.

the link_wiki1 file had to come from the zip, I didn't add anything, it was 'out o the box' as it were.

Here's the full log on the mod install page:

extensions/link_wiki1.php: Location1: Bad target

globallib.php: Location1: Installed

personlib.php: Location1: Installed

personlib.php: Location2: Installed

personlib.php: Location3: Installed

personlib.php: Location4: Installed

personlib.php: Location5: Installed

personlib.php: Location6: Installed

personlib.php: Location7: Installed

getperson.php: Location1: Installed

getperson.php: Location2: Installed

getperson.php: Location3: Installed

getperson.php: Location4: Installed

getperson.php: Location5: Installed

showsource.php: Location1: Installed

showsource.php: Location2: Installed

showrepo.php: Location1: Installed

showrepo.php: Location2: Installed

Existing extensions/link_wiki1.php does not have a version number

extensions/substitution_list.php Installed

extensions/persons.php Installed

Mod updates are required

Unable to install this mod

It's a clean copy of the mod that I had just acquired before trying to install...

Trying to remove it now and redo it.

~Jim

Share this post


Link to post
Share on other sites
Jim Williamson

Just a note--- I went back, renamed the 'bad' link_wiki1' file out of the way, copied the backup file that was there named link_wki1.php.original, to link_wiki1.php, refreshed the mods page and it installed just fine...

Not a doc I would have edited, so not sure what was happening.. but thanks for the clue...

Share this post


Link to post
Share on other sites
Ken Roy

Didn't get a notice from the forums about your reply... sorry for the delayed response.

the link_wiki1 file had to come from the zip, I didn't add anything, it was 'out o the box' as it were.

Here's the full log on the mod install page:

extensions/link_wiki1.php: Location1: Bad target

globallib.php: Location1: Installed

personlib.php: Location1: Installed

personlib.php: Location2: Installed

personlib.php: Location3: Installed

personlib.php: Location4: Installed

personlib.php: Location5: Installed

personlib.php: Location6: Installed

personlib.php: Location7: Installed

getperson.php: Location1: Installed

getperson.php: Location2: Installed

getperson.php: Location3: Installed

getperson.php: Location4: Installed

getperson.php: Location5: Installed

showsource.php: Location1: Installed

showsource.php: Location2: Installed

showrepo.php: Location1: Installed

showrepo.php: Location2: Installed

Existing extensions/link_wiki1.php does not have a version number

extensions/substitution_list.php Installed

extensions/persons.php Installed

Mod updates are required

Unable to install this mod

It's a clean copy of the mod that I had just acquired before trying to install...

Trying to remove it now and redo it.

~Jim

Since the link_wiki1.php file has no version number and since it shows

extensions/link_wiki1.php: Location1: Bad target

my guess is that it is a prior version of this file that was originally provided from Brian's wiki before I updated the mod allow editing of the URL through the Mod Manager. The Bad Target is what is causing the Unable to install this mod message.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×