Jump to content
TNG Community
daves not here

TNG8 and mediawiki

Recommended Posts

daves not here

I'm new to both TNG and wikis, but not to programming and web development.

I'm trying to get TNG integrated with MW, but have not had any success. I need to integrate the two, because there are 1300+ individuals, and will be about 20,000 pages of research materials in about 2000 pdf files accessible for this project.

So, has anyone successfully gotten TNG (8.1.1) working with MW (1.16.2). If not, has anyone done it with TNG 7?

Where I'm currently stuck is getting mediawiki_v8.1.4.cfg installed by the Mod Manager. I've primarily used the information at http://tng.lythgoes.net/wiki/index.php?tit...iki_Integration.

The site is:

TNG http://family.holiday-wiki.com/genealogy/index.php

MW http://family.holiday-wiki.com/mediawiki/index.php/Main_Page

Share this post


Link to post
Share on other sites
Ken Roy

Where I'm currently stuck is getting mediawiki_v8.1.4.cfg installed by the Mod Manager. I've primarily used the information at http://tng.lythgoes.net/wiki/index.php?tit...iki_Integration.

What is the issue you are having with the Mod Manager? What do you mean by you are currently stuck getting the mediawiki_v8.1.4.cfg installed by the Mod Manager?

Ken

Share this post


Link to post
Share on other sites
daves not here

What is the issue you are having with the Mod Manager? What do you mean by you are currently stuck getting the mediawiki_v8.1.4.cfg installed by the Mod Manager?

Ken

Well for starters, the Mod Manager throws the following errors/warnings in the status column:

globallib.php: Location1: Not Installed

globallib.php: Location2: Not Installed

globallib.php: Location3: Not Installed

personlib.php: Location1: Not Installed

personlib.php: Location2: Not Installed

personlib.php: Location3: Not Installed

personlib.php: Location4: Not Installed

personlib.php: Location5: Not Installed

personlib.php: Location6: Not Installed

personlib.php: Location7: Not Installed

getperson.php: Location1: Not Installed

extensions/link_wiki1.php V8.1.4 Not Installed

extensions/substitution_list.php V8.1.0 Not Installed

Local copy of /var/www/vhosts/holiday-wiki.com/subdomains/family/httpdocs/genealogy/mods/mediawiki/new_doc.gif for installation is missing

globallib.php, personlib.php and getperson.php are all in the genealogy dir, and are chmod'd to 777

When I try to clean, I get these notes:

mediawiki_v8.1.4.cfg Cleanup performed with following notes:

Missing file: [/var/www/vhosts/holiday-wiki.com/subdomains/family/httpdocs/genealogy/extensions/link_wiki1.php]

extensions/link_wiki1.php: Missing file,Cannot delete, permissions are

extensions/substitution_list.php: Missing file,Cannot delete, permissions are

/var/www/vhosts/holiday-wiki.com/subdomains/family/httpdocs/genealogy/extensions/new_doc.gif: Not Installed, Cannot delete, permissions are

I was under the impression (from http://genwiki.mcfadyen.ca/index.php?title=TNG_Integration) that I needed to start with installing the mod first.

Share this post


Link to post
Share on other sites
Ken Roy

Well for starters, the Mod Manager throws the following errors/warnings in the status column:

globallib.php: Location1: Not Installed

globallib.php: Location2: Not Installed

globallib.php: Location3: Not Installed

personlib.php: Location1: Not Installed

personlib.php: Location2: Not Installed

personlib.php: Location3: Not Installed

personlib.php: Location4: Not Installed

personlib.php: Location5: Not Installed

personlib.php: Location6: Not Installed

personlib.php: Location7: Not Installed

getperson.php: Location1: Not Installed

extensions/link_wiki1.php V8.1.4 Not Installed

extensions/substitution_list.php V8.1.0 Not Installed

Local copy of /var/www/vhosts/holiday-wiki.com/subdomains/family/httpdocs/genealogy/mods/mediawiki/new_doc.gif for installation is missing

globallib.php, personlib.php and getperson.php are all in the genealogy dir, and are chmod'd to 777

When I try to clean, I get these notes:

mediawiki_v8.1.4.cfg Cleanup performed with following notes:

Missing file: [/var/www/vhosts/holiday-wiki.com/subdomains/family/httpdocs/genealogy/extensions/link_wiki1.php]

extensions/link_wiki1.php: Missing file,Cannot delete, permissions are

extensions/substitution_list.php: Missing file,Cannot delete, permissions are

/var/www/vhosts/holiday-wiki.com/subdomains/family/httpdocs/genealogy/extensions/new_doc.gif: Not Installed, Cannot delete, permissions are

I was under the impression (from http://genwiki.mcfadyen.ca/index.php?title=TNG_Integration) that I needed to start with installing the mod first.

Yes, you need to start by installing the mod. However, it appears that you did not extract the zip file to your TNG mods folder based on the error message.

With an error message that indicates

Local copy of /var/www/vhosts/holiday-wiki.com/subdomains/family/httpdocs/genealogy/mods/mediawiki/new_doc.gif for installation is missing and since everything else shows Not installed, a Cleanup attempt will not resolve this problem

I just downloaded the zip file and the missing component is there. After extracting the zip file to your TNG mods folder, the mod should show an Install button.

You also need to make sure that you are using the same database for MediaWiki as you are using for TNG, otherwise, you will get the following errors when displaying the person in TNG

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in F:\wamp\www\tng\extensions\link_wiki1.php on line 102

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in F:\wamp\www\tng\extensions\link_wiki1.php on line 102

The Wiki Integration mod does not allow for having 2 different databases.

Ken

Share this post


Link to post
Share on other sites
daves not here

Yes, you need to start by installing the mod. However, it appears that you did not extract the zip file to your TNG mods folder based on the error message.

With an error message that indicates

Local copy of /var/www/vhosts/holiday-wiki.com/subdomains/family/httpdocs/genealogy/mods/mediawiki/new_doc.gif for installation is missing and since everything else shows Not installed, a Cleanup attempt will not resolve this problem

I just downloaded the zip file and the missing component is there. After extracting the zip file to your TNG mods folder, the mod should show an Install button.

You also need to make sure that you are using the same database for MediaWiki as you are using for TNG, otherwise, you will get the following errors when displaying the person in TNG

The Wiki Integration mod does not allow for having 2 different databases.

Ken

Ken,

Thanks. I had just uploaded the cfg file, and not the mediawiki folder as well. That solved the install issue.

As for the DB, I do have both TNG and MW using the same database; however, they are installed in different directories on the server. Of course, now I'm getting the error you mentioned.

I've done the following:

1. put persons.php (after changes) into mediawiki/extensions/

2. added include("extensions/persons.php"); to the end of LocalSettings.php

3. Using strategy 1, changed to the following:

$wiki_url = "http://family.holiday-wiki.com/mediawiki";

$wiki_prefix = "mw_";

I've tried several variations on the url. I also have wiki_url_type ="/"

4. Saved the changed files to genealogy/link_wiki_strategy.php

Thoughts on what might be wrong?

For reference:

TNG - http://family.holiday-wiki.com/genealogy/index.php

MW - http://family.holiday-wiki.com/mediawiki/index.php/Main_Page

Share this post


Link to post
Share on other sites
Ken Roy

Ken,

Thanks. I had just uploaded the cfg file, and not the mediawiki folder as well. That solved the install issue.

As for the DB, I do have both TNG and MW using the same database; however, they are installed in different directories on the server. Of course, now I'm getting the error you mentioned.

I've done the following:

1. put persons.php (after changes) into mediawiki/extensions/

2. added include("extensions/persons.php"); to the end of LocalSettings.php

3. Using strategy 1, changed to the following:

$wiki_url = "http://family.holiday-wiki.com/mediawiki";

$wiki_prefix = "mw_";

I've tried several variations on the url. I also have wiki_url_type ="/"

4. Saved the changed files to genealogy/link_wiki_strategy.php

Thoughts on what might be wrong?

For reference:

TNG - http://family.holiday-wiki.com/genealogy/index.php

MW - http://family.holiday-wiki.com/mediawiki/index.php/Main_Page

Did you use the Mod Manager Edit button to make the changes to the wiki url information? and your wiki table prefix?

PM me admin login credentials to your site to my web site and I will take a look at it. I am not using this mod, but did play with it briefly on a test environment.

Ken

Share this post


Link to post
Share on other sites
daves not here

Did you use the Mod Manager Edit button to make the changes to the wiki url information? and your wiki table prefix?

PM me admin login credentials to your site to my web site and I will take a look at it. I am not using this mod, but did play with it briefly on a test environment.

Ken

Ken,

You are both a saint and a scholar. 1000 internets to you. :)

I was trying to do things the hard way and manually editing the files. I didn't even notice the edit button.

Things seem to be working now http://family.holiday-wiki.com/mediawiki/i...php/Ryan,_Grace

Still not sure why it's not working automatically the other way, TNG -> wiki, but I'll dig into that today and look for other posts in the forum. Thanks for the offer to dig deeper too.

Share this post


Link to post
Share on other sites
bsl20b50

Ken,

You are both a saint and a scholar. 1000 internets to you. :)

I was trying to do things the hard way and manually editing the files. I didn't even notice the edit button.

Things seem to be working now http://family.holiday-wiki.com/mediawiki/i...php/Ryan,_Grace

Still not sure why it's not working automatically the other way, TNG -> wiki, but I'll dig into that today and look for other posts in the forum. Thanks for the offer to dig deeper too.

When you created your stub article, did you start from the individual page? If you are admin for both TNG and the wiki, you should have an icon next to the name for all individuals without an associated wiki page. Clicking on that icon will take you to a blank page for you to use to create your wiki page. So...

If you go to your example person page and click on the icon, it takes you to the blank wiki page. This is where you create your wiki article.

So if you copy everything over from your old wiki page to you new wiki page, everything should be just as you want it.

Good Luck,

Bryan

Share this post


Link to post
Share on other sites
daves not here

When you created your stub article, did you start from the individual page? If you are admin for both TNG and the wiki, you should have an icon next to the name for all individuals without an associated wiki page. Clicking on that icon will take you to a blank page for you to use to create your wiki page. So...

Bryan,

Thanks. The problem I was initially having was getting the little page icon to appear at all. After some research and playing around, I realized that I needed to include the TNG ID in the wiki's page name. Now to add some content and more customizations.

-dave

Share this post


Link to post
Share on other sites
Ken Roy

Bryan,

Thanks. The problem I was initially having was getting the little page icon to appear at all. After some research and playing around, I realized that I needed to include the TNG ID in the wiki's page name. Now to add some content and more customizations.

-dave

Dave,

Don't forget to also install the MediaWiki language extension from Brian's site

See the Customizing the person.php file for changes you have to make to the MediaWiki/extensions/person.php file

and Creating Wiki Links to TNG pages which shows examples of creating links.

Brian's MediaWiki language extension will allow you to create a Return link to your TNG pages. For example on Grace Ryan wiki page, you would add the following syntax

Return to page on <tng i=1289>Grace Ryan</tng>

Share this post


Link to post
Share on other sites
BOFHMike

Quick question for anyone. I'm about to grab the latest TNG, and have already installed MediaWiki into it's own sub dir (URL/wiki) as I've had problems w/ MediaWiki installed in root not allowing the browser to hit other subdirectories. Is there a preferred location for TNG installation when combining the two? I would prefer to NOT* create a separate "home" page to provide links into the genealogy content, thus my preference would be to install TNG in the root.

Thoughts? Considerations?

Site being built - newfrancegenealogy.ca (nothing of function yet...)

Share this post


Link to post
Share on other sites
bsl20b50

Quick question for anyone. I'm about to grab the latest TNG, and have already installed MediaWiki into it's own sub dir (URL/wiki) as I've had problems w/ MediaWiki installed in root not allowing the browser to hit other subdirectories. Is there a preferred location for TNG installation when combining the two? I would prefer to NOT* create a separate "home" page to provide links into the genealogy content, thus my preference would be to install TNG in the root.

Thoughts? Considerations?

Site being built - newfrancegenealogy.ca (nothing of function yet...)

Having TNG in the root directory and mediawiki in a subdirectory works great. I have it running like that on a few domains.

The problem with having mediawiki in the root is that depending on your setup, everything below the mediawiki directory gets redirected making it a poor choice for root unless you are strictly a wiki. TNG does not do this, so root works just fine.

Regards,

Bryan

Share this post


Link to post
Share on other sites
BOFHMike

Having TNG in the root directory and mediawiki in a subdirectory works great. I have it running like that on a few domains.

The problem with having mediawiki in the root is that depending on your setup, everything below the mediawiki directory gets redirected making it a poor choice for root unless you are strictly a wiki. TNG does not do this, so root works just fine.

Regards,

Bryan

Thank you very much. Just uploaded tng 8.1.1 to my host site, going to see what disaster I can create. :)

-=mike=-

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×