Jump to content
TNG Community
Sign in to follow this  
Michel

Upgrade to 7.1.2 -Language problem with : Other events

Recommended Posts

Michel

Hi,

I just upgrade to 7.1.2 and I notice a little problem with the french accent, the problems shows only when you add a event (AKA Other events in the edit person)

There is an example on my site:

IPB Image

Look under : baptized (LDS) where I put a note saying: écriture de français àèéô

and then look under :profession: i put test écriture de français àèéô

you will see the accent are not well done,

Can you help?

Brgds..Michel Sabourin

Share this post


Link to post
Share on other sites
Ken Roy

Hi,

I just upgrade to 7.1.2 and I notice a little problem with the french accent, the problems shows only when you add a event (AKA Other events in the edit person)

There is an example on my site:

IPB Image

Look under : baptized (LDS) where I put a note saying: écriture de français àèéô

and then look under :profession: i put test écriture de français àèéô

you will see the accent are not well done,

Can you help?

Brgds..Michel Sabourin

Michel,

Your web page source shows your site as ISO-8859-1. Is your database setup as latin1_xxxxxxxx_ci? if not then that could be a problem. If your database is latin1 then you should probably report this directly to Darrin, there is likely a character translation occurring that should not. This looks like ANSI interpretation of UTF-8 characters or UTF-8 interpretation of ANSI characters.

In order not to have any accent display problems, the database, the gedcom, and TNG site must all be on the same character set, either all ISO-8859-1 (ANSI and latin1) or all UTF-8

Share this post


Link to post
Share on other sites
Michel

Michel,

Your web page source shows your site as ISO-8859-1. Is your database setup as latin1_xxxxxxxx_ci? if not then that could be a problem. If your database is latin1 then you should probably report this directly to Darrin, there is likely a character translation occurring that should not. This looks like ANSI interpretation of UTF-8 characters or UTF-8 interpretation of ANSI characters.

In order not to have any accent display problems, the database, the gedcom, and TNG site must all be on the same character set, either all ISO-8859-1 (ANSI and latin1) or all UTF-8

Thanks Ken for your response,

Where do I look for the database?

Under TNG, for language it is set at Latin_1

Under TNG , configuration it is set at: ISO-8859-1

under myphpadmin it is shows:

Interclassement pour la connexion MySQL: UTF8_unicode_ci.

Is it what you mean for the database?

If yes how can I change it? and is this will affect my database if I change it?

Last question, why it did that only under :other events and no where else?

Thanks... Michel

Share this post


Link to post
Share on other sites
Ken Roy

Thanks Ken for your response,

Where do I look for the database?

Under TNG, for language it is set at Latin_1

Under TNG , configuration it is set at: ISO-8859-1

under myphpadmin it is shows:

Interclassement pour la connexion MySQL: UTF8_unicode_ci.

Is it what you mean for the database?

If yes how can I change it? and is this will affect my database if I change it?

Last question, why it did that only under :other events and no where else?

Thanks... Michel

Michel,

In phpMyAdmin if you look at the structure of the database and it says UTF8_unicode_ci for all the table collation sequence, then you should change your TNG language and setup to be UTF-8 as shown in the Setup - Language and in the Admin >> Setup >> General Settings >> Language section.

You may have to switch languages a couple of times in order to get the changes to take effect. You may also have to redo your event that you added.

Also it has been my experience that I had to set the database to at least --_swedish_ci collation sequence for TNG to return both accented and non-accented names, for example Quebec and Québec when doing a place search.

Is the Other Events an item you added in TNG itself? Did you import an ANSI (latin1) generated gedcom into your UTF-8 database?

Share this post


Link to post
Share on other sites
Michel

Michel,

In phpMyAdmin if you look at the structure of the database and it says UTF8_unicode_ci for all the table collation sequence, then you should change your TNG language and setup to be UTF-8 as shown in the Setup - Language and in the Admin >> Setup >> General Settings >> Language section.

You may have to switch languages a couple of times in order to get the changes to take effect. You may also have to redo your event that you added.

Also it has been my experience that I had to set the database to at least --_swedish_ci collation sequence for TNG to return both accented and non-accented names, for example Quebec and Québec when doing a place search.

Is the Other Events an item you added in TNG itself? Did you import an ANSI (latin1) generated gedcom into your UTF-8 database?

Ken,

Thanks I will try that.

I always import Ansi, never UTF-8 and yes it is an item I add in TNG, not imported.

But I'm still curious to see why it does that only in the Other event ?

Rgds...

Share this post


Link to post
Share on other sites
Ken Roy

Ken,

Thanks I will try that.

I always import Ansi, never UTF-8 and yes it is an item I add in TNG, not imported.

But I'm still curious to see why it does that only in the Other event ?

Rgds...

Michel,

Have you determined whether your database is UTF-8?

I learned French before the age of computers, so I don't necessarily understand what Interclassement pour la connexion MySQL means.

Other than possibly having something to do with translating on connection.

From what I have been able to tell from reading about mySQL the underlying database for version 5 itself is UTF-8, but the default collation sequence on a database setup remained latin1_general_ci on most hosting service so there is some translation going on when retrieving and saving to the database if it is not setup with a UTF-8 collation sequence. However this works fine, if all elements are ISO-8859-1.

Does your desktop software have the capability of generating a UTF-8 gedcom?

As to your question on why you only see this in Other event only, my theory is that TNG translated the entered characters to UTF-8 before passing them to the database and they would have been translated a second time, but I have not looked at the code.

Last time I looked, TNG currently did not honor the CHAR statement on a gedcom import. This capability may have been added in the last couple of upgrades, since I did not look at the code. I know it did not when TNG 7.0 was released.

So that raises the question as to whether your database is really latin1 and not UTF-8? If so then there may be a bug when adding Other Events that contain accented characters.

Share this post


Link to post
Share on other sites
Michel

Michel,

Have you determined whether your database is UTF-8?

I learned French before the age of computers, so I don't necessarily understand what Interclassement pour la connexion MySQL means.

Other than possibly having something to do with translating on connection.

From what I have been able to tell from reading about mySQL the underlying database for version 5 itself is UTF-8, but the default collation sequence on a database setup remained latin1_general_ci on most hosting service so there is some translation going on when retrieving and saving to the database if it is not setup with a UTF-8 collation sequence. However this works fine, if all elements are ISO-8859-1.

Does your desktop software have the capability of generating a UTF-8 gedcom?

As to your question on why you only see this in Other event only, my theory is that TNG translated the entered characters to UTF-8 before passing them to the database and they would have been translated a second time, but I have not looked at the code.

Last time I looked, TNG currently did not honor the CHAR statement on a gedcom import. This capability may have been added in the last couple of upgrades, since I did not look at the code. I know it did not when TNG 7.0 was released.

So that raises the question as to whether your database is really latin1 and not UTF-8? If so then there may be a bug when adding Other Events that contain accented characters.

Hello Ken,

MySql : MySQL charset: UTF-8 Unicode (utf8) , so I guess my database is UTF-8.. it is curious that it works with everything except Other event...

I finally did what you recommend , and it works fine, menaing in other events

except now I loose all my accent in all my pages That I add,(incuding my menu) ???

Rgds...

Share this post


Link to post
Share on other sites
Ken Roy

Hello Ken,

MySql : MySQL charset: UTF-8 Unicode (utf8) , so I guess my database is UTF-8.. it is curious that it works with everything except Other event...

I finally did what you recommend , and it works fine, menaing in other events

except now I loose all my accent in all my pages That I add,(incuding my menu) ???

Rgds...

Michel,

You will need to use the UTF-8 version of the admintext.php, alltext.php, and text.php in the TNG Language folder for French-UTF8. That should fix the accents in the menu.

Do you import your data or do you maintain it in TNG only? Sounds like even though your database was UTF-8, the data inside of it was ANSI which would account for why an ANSI import would work.

If you import with a Replace All Data from your desktop, then you should export a new gedcom as UTF-8. If your desktop software only exports in ANSI, you will need to open the created gedcom file with Notepad++ and convert it to UTF-8 without BOM. This should fix your accents in your data.

You will also need to convert your cust_text.php from ANSI to UTF-8 without BOM using Notepad++

Share this post


Link to post
Share on other sites
Michel

Michel,

You will need to use the UTF-8 version of the admintext.php, alltext.php, and text.php in the TNG Language folder for French-UTF8. That should fix the accents in the menu.

Do you import your data or do you maintain it in TNG only? Sounds like even though your database was UTF-8, the data inside of it was ANSI which would account for why an ANSI import would work.

If you import with a Replace All Data from your desktop, then you should export a new gedcom as UTF-8. If your desktop software only exports in ANSI, you will need to open the created gedcom file with Notepad++ and convert it to UTF-8 without BOM. This should fix your accents in your data.

You will also need to convert your cust_text.php from ANSI to UTF-8 without BOM using Notepad++

Ken,

I did convert my cust_text.php from ANSI to UTF-8 without BOM using Notepad++ and since then I can not see my home page anymore ???

same for my Admin page ???

I try to re-install old files I have with no change....

Helppppp :-)

Michel

Share this post


Link to post
Share on other sites
Ken Roy

Ken,

I did convert my cust_text.php from ANSI to UTF-8 without BOM using Notepad++ and since then I can not see my home page anymore ???

same for my Admin page ???

I try to re-install old files I have with no change....

Helppppp :-)

Michel

Sounds like you have the UTF-8 byte order mark. Does  show on your pages. A URL link to your site might be helpfule.

If that is not the problem, then you either have information before the <?php or after the /> in one of the text.php files.

Edited - OK, your URL is in your signature, unfortunately that does not show when you are editing. My browser still shows your character encoding as ISO-8859-1 for the page but then there is nothing being returned in source that would allow the browser to see a charset specification.

Share this post


Link to post
Share on other sites
Michel

Sounds like you have the UTF-8 byte order mark. Does  show on your pages. A URL link to your site might be helpfule.

If that is not the problem, then you either have information before the <?php or after the /> in one of the text.php files.

Hi, my url is:

My Webpage

Share this post


Link to post
Share on other sites
Ken Roy

Hi, my url is:

My Webpage

You could try sending me your cust_text.php via PM if everything was working before you converted it to UTF-8.

Maybe attached the ANSI and UTF-8 versions.

Share this post


Link to post
Share on other sites
Michel

You could try sending me your cust_text.php via PM if everything was working before you converted it to UTF-8.

Maybe attached the ANSI and UTF-8 versions.

Ok, I re-install an older version of my cust_text.php and it works now...

thanks a lot Ken, your help is really appreciate...

Best regards...

Share this post


Link to post
Share on other sites
Ken Roy

Ok, I re-install an older version of my cust_text.php and it works now...

thanks a lot Ken, your help is really appreciate...

Best regards...

Michel,

When I looked at the source of your Home page, it still shows TNG using charset-ISO-8859-1. Should pursue this tomorrow since you are currently back up and running.

Share this post


Link to post
Share on other sites
Michel

Michel,

When I looked at the source of your Home page, it still shows TNG using charset-ISO-8859-1. Should pursue this tomorrow since you are currently back up and running.

good idea..

Good night....

Michel

Share this post


Link to post
Share on other sites
Michel

Ken,

I did all the changes this morning (including all my french pages :-)

Now everything seems to work fine,

Thanks again for your great help...

Brgds...

Share this post


Link to post
Share on other sites
Ken Roy

Ken,

I did all the changes this morning (including all my french pages :-)

Now everything seems to work fine,

Thanks again for your great help...

Brgds...

Glad I was able to help.

Share this post


Link to post
Share on other sites
Michel

Glad I was able to help.

Ken,

I'm always use firefox as a browser but someone mention to me that they see special caractere , so I went back to the site and with IE it is true that I don't see m y accent anymore

Any idea?

Rgds....

My Webpage

Share this post


Link to post
Share on other sites
Michel

Ken,

I'm always use firefox as a browser but someone mention to me that they see special caractere , so I went back to the site and with IE it is true that I don't see m y accent anymore

Any idea?

Rgds....

My Webpage

Ah, forget it,

I set IE to UTF-8 for view and it is ok, now I have to found out how to set this permanently, with IE.

Thanks Michel

Share this post


Link to post
Share on other sites
Ken Roy

Ah, forget it,

I set IE to UTF-8 for view and it is ok, now I have to found out how to set this permanently, with IE.

Thanks Michel

Michel,

I would think there would be an option that sets the display to the charset used by the web page. I am not sure since I use SeaMonkey most of the time.

Share this post


Link to post
Share on other sites
Michel

Ken,

The only way that I was able to fix my problem , ie firefox works fine and IE return funny code.

Manually I was able to set the encoding to UTF-8 with IE but I found this very painfull, specially for people that dont have computer knowledge.

There is how I fix my problem:

on our main page we have a file name .htaccess in this file I add this line:

AddDefaultCharset utf-8

Save it and load it in your root where yor TNG files are.

And it works fine now because the server forced to read it with UTF-8.

Brgds... Michel

Share this post


Link to post
Share on other sites
Ken Roy

Ken,

The only way that I was able to fix my problem , ie firefox works fine and IE return funny code.

Manually I was able to set the encoding to UTF-8 with IE but I found this very painfull, specially for people that dont have computer knowledge.

There is how I fix my problem:

on our main page we have a file name .htaccess in this file I add this line:

AddDefaultCharset utf-8

Save it and load it in your root where yor TNG files are.

And it works fine now because the server forced to read it with UTF-8.

Brgds... Michel

Michel,

Sounds like Microsoft IE is not recognizing and honoring the

<meta http-equiv="Content-type" content="text/html; charset=UTF-8" />

generated by TNG based on the charset settings.

Or is your meta line not showing UTF-8 prior to your .htaccess file change? In which case, you have to change the settings in your TNG Admin >> Setup >> General Settings >> Language and in each of the Admin >> Language entries to be UTF-8

Share this post


Link to post
Share on other sites
Michel

Michel,

Sounds like Microsoft IE is not recognizing and honoring the

<meta http-equiv="Content-type" content="text/html; charset=UTF-8" />

generated by TNG based on the charset settings.

Or is your meta line not showing UTF-8 prior to your .htaccess file change? In which case, you have to change the settings in your TNG Admin >> Setup >> General Settings >> Language and in each of the Admin >> Language entries to be UTF-8

Ken,

nothing simple, i tought I fix my problem, but I found this morning, with firefox, a problem, when I tried to add a picture, when I see the picture name in my folder, the accent are not there and replace with a code....grrrrrr

IPB Image

I think I will go back to ISO ...

There is my setting:

IPB Image

IPB Image

Thanks...Rgds...

Share this post


Link to post
Share on other sites
Ken Roy

Ken,

nothing simple, i tought I fix my problem, but I found this morning, with firefox, a problem, when I tried to add a picture, when I see the picture name in my folder, the accent are not there and replace with a code....grrrrrr

IPB Image

I think I will go back to ISO ...

Thanks...Rgds...

Michel,

You should not use any accents when naming files or folder names that will be used on a Linux Server. Probably not the answer you wanted to hear.

Share this post


Link to post
Share on other sites
Michel

Michel,

You should not use any accents when naming files or folder names that will be used on a Linux Server. Probably not the answer you wanted to hear.

Not really :-)

Ok, so to make a short story, I think I will go back to ISO format with Latin1, where I have less problem then with UTF-8.

Do you think I should bring my problems to Darrin? I never have problems before upgrading to 7.1.2 so I guess something goes wrong with this new version.

A little bit of history:

After I upgrade to 7.1.2 I realize that when I add something in other Event I loose the french accent.

- you found that my database is UTF-8 and my site was at ISO

- I change it in the Site to REflect UTF-8 and I convert all my file to UTF-8 without BOM

Under IE (version 7 and version 8 ) since then, my accent don't work and I have to forced manually encoding to UTF-8

I forced it with .htaccess and in this file I add this line: AddDefaultCharset utf-8

By doing this IE is now UTF-8 and looks ok to read all text I add in php pages but I see now a little sqare in place of accent in information that come form the database (such as other events or comments I add)

Under Firefox:

Every thing looks fine but when I try to add a picture this morning I realize that all my picture save with accent are not readable. And this was ok before I move to UTF -8.

Finally you said that when you look at the codin of the pages it still not showned the right things...

I'm lost hahahahhahaa

Rgds....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×