Jump to content
TNG Community
svoght

e107 v0.7.16 upgrade

Recommended Posts

svoght

Hi all,

About 24 hours ago there was finally a new stable update to the e107 code base, released as version 0.7.16. This is the first update in nearly nine months, and includes a massive number of bug and security fixes (see here for the full list, but don't expect to understand half of it!)

This upgrade is quite easy -- there are only two files that need further modification to maintain tngIL functionality, and they're the same two that you had to edit when you first installed tngIL -- class2.php and footer_default.php, and the instructions are identical as to when you did the edits the first time.

To make things even easier, I've attached a ZIP file containing the latest revised versions of both files, so you can simply download the appropriate e107 update for your system from here, unzip it, upload all of the files to your server (overwriting any old copies with the same name), and then upload the two revised files. There are no database updates or any other steps required to perform the upgrade, and it should take less than ten minutes on a broadband connection.

e107v0716_tngILupdates.zip

As usual, respond in this thread if you have any problems with the update process.

Share this post


Link to post
Share on other sites
John Paul

thanks for that update and staying on top of things. works like a champ, as usual. I hope to be updating my site here soon. I've been so busy at work lately. I work for a city municipality and we just moved to a new building, and since i'm the network guy I've been like nonstop the last several weeks. it seems like it's slowing back down to normal here for a change so I may get to start concentrating on the site more.

thanks for all your efforts with keeping up with all this.

Share this post


Link to post
Share on other sites
svoght

A minor security flaw was recently discovered in e107 v0.7.16, and a patch has been issued for it. The patch is quite small and only affects the latest version (which you should be running anyway, since that version fixes other, older bugs!), so if you've upgraded to e107 version 0.7.16 you should download this fix.

e107_0.16_mod_031109_tngIL.zip

I'm also working on creating updates so everyone can upgrade to TNG 7.1.2, although that might take a little longer because I'm going to create a TNG Mod Manager configuration file for e107 integration in order to make all of this much more automated and easier for us to upgrade in the future.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×