Jump to content
TNG Community
rdmorss

Setting up a server on your home computer (localhost)

Recommended Posts

Ken Roy

Did you define the app_gedcom folder in your Admin > Setup > Import Settings?

Share this post


Link to post
Share on other sites
tngrlkrz
1 hour ago, manofmull said:

This blog is so good that even I was able to get Wamp installed locally (Wamp was by far the easiest)

https://www.blog.tivel.org/wampserver-tng-and-wordpress-for-genealogists/

 

Michael

Looks to be excellent source, albeit a bit dated.

Thanks,

Ron 

Share this post


Link to post
Share on other sites
manofmull
1 hour ago, tngrlkrz said:

Looks to be excellent source, albeit a bit dated.

Thanks,

Ron 

Ron

Very true, but a bit like myself : I'm still happy using Windows XP ☺️

 

M

Share this post


Link to post
Share on other sites
Ellsinore
On 6/8/2018 at 6:37 AM, Ken Roy said:

Did you define the app_gedcom folder in your Admin > Setup > Import Settings?

Yes, and as the screenshot shows, that's the folder it's looking for, the folder is there, but there's an error message that it is NOT there.  

Share this post


Link to post
Share on other sites
Ken Roy

The screen shot you provided was not that of the Admin > Setup > Import Settings screen. 

You need to tell TNG what folder name you want to use for the GEDCOM import in the Import Settings > GEDCOM Folder (Import/Export):

Share this post


Link to post
Share on other sites
Ellsinore
15 minutes ago, Ken Roy said:

The screen shot you provided was not that of the Admin > Setup > Import Settings screen. 

You need to tell TNG what folder name you want to use for the GEDCOM import in the Import Settings > GEDCOM Folder (Import/Export):

I did tell TNG what folder name I wanted to use for the GEDCOM import in the Import Settings > GEDCOM Folder (Import/Export).  The screenshot I provided was showing the error that's occurring -- the folder has been set in the settings, as evidenced by the text in the red circle on the top that shows that is the folder it is looking for -- and telling me it can't find.  The next big red circle shows that the folder does, in fact, exist.  

 

Here's a screenshot of the Import Settings showing that I have, in fact, set that parameter.  

 

ss.jpg

Share this post


Link to post
Share on other sites
Ken Roy

When did you download your TNG v12 upgrade?  Was it before May 10th?  If so, go back to the download page and download the patch12 zip file and see if that fixes your problem.

If it does not, then report the problem directly to Darrin as he does not monitor the user-to-user support forum

Share this post


Link to post
Share on other sites
cralph1950

Roy,

I am not involved in this topic.

Share this post


Link to post
Share on other sites
Ken Roy

Well I cannot help it when users hijack a thread rather than start a new topic.

Besides I am not in the Army anymore when I was called Roy (my last name) all the time.

 

Share this post


Link to post
Share on other sites
cralph1950

sorry I rained on your parade! Don't be such a sour puss!

Share this post


Link to post
Share on other sites
Ellsinore
On 6/3/2018 at 3:29 PM, Ellsinore said:

I'm not a newbie to "localhost" but I'm pulling my hair out trying to get my GEDCOM imported.  Using XAMPP on Windows 7 TNG 10.

When I choose the GEDCOM file directly, I get "Could not upload file: tng.ged. Your 'gedcom' folder may have inadequate permissions (try 755 or 777)." and cannot seem to find the right security properties combinations for the folder, or get them to stick.  Since it's Windows and not UNIX, the suggested permissions are irrelevant, but I'm used to that.  So I've always just used "Select from GEDCOM" folder.

But now when I do that, I get "chdir(): No such file or directory".  The folder is on the list, but I can't select it.  Just for kicks, I tried to have TNG create the folder, but THEN it says it already exists.  :-D

Everything works fine on the production server but I want to test some changes locally before uploading them live.  

I don't know if I'm the "hijacker" or not, but thought I'd update that I figured out why TNG couldn't find my GEDCOM folder for import:  The root path in settings lacked a closing slash.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×