Jump to content
TNG Community
shajra

Moving Domain

Recommended Posts

shajra

I want to move my current site to a new domain. Any suggestion on what's the best way to go about migrating the database. 

I can import the GED file but it doesent port the notes or media.

Share this post


Link to post
Share on other sites
Chris Lloyd

Do a full back up of your DB - once you have a new host you can import the backed up DB

Share this post


Link to post
Share on other sites
Ken Roy

Note that you also need to be at the same TNG levels on both sites, otherwise you will encounter problems.

You also need to have a full copy of all your files on your existing domain since not everything is in the database

Share this post


Link to post
Share on other sites
Rune Aasgaard

I recently moved my TNG site from one domain (OLD) to another (NEW). It worked great, except some minor issues with graphics which I would appreciate pointers on. I used the following steps:

1) I took a full backup of the database on OLD and restored it on NEW

2) I downloaded full copy of the files on OLD and uploaded them to NEW

3) I manually updated config.php on NEW with new sitename, path, database identifier, etc.

The data is read and presented as before. The only problem is that some graphics suffered, specifically: Some icons in charts are "corrupted" and thumbnails / photos aren't displayed.

I have attached two screenshots as examples (OLD and NEW) showing the same short pedigree (my paternal grandfather and his parents), with red circles marking some of the missing/faulty graphics. You can also use these links:

OLD: http://www.prolego.net/slekt/pedigree.php?personID=I5036&tree=Anetre&parentset=0&display=standard&generations=2

NEW: http://www.provesten.no/slekt/pedigree.php?personID=I5036&tree=Anetre&parentset=0&display=standard&generations=2

Any tips or input (link to a wikipage I missed, rights I should check, config/setups that must be updated, ...) would be greatly appreciated.

 

PS: "Prolego" is the name of my personal company (it is greek and means "I predict"), "Provesten" ("Prøvesten") is the name of the farm my father was born on (it is Norwegian and means "Trial stone", the "piece of rock" where the first owner could test his mettle), "slekt" is the norwegian word for family/relations/genealogy

New site (provesten).png

Old site (prolego).png

Share this post


Link to post
Share on other sites
kappclark

FWIW - I recently had thumbnails go away (as it appears from your posting) ... logged into hosting site, and discovered that the root path was "/home2"  while before it had been "home1" ... they had done some 'upgrades' at the hosting service...

TNG could not find the proper path to the thumbnails. Once I changed the path in the TNG setup, all the thumbnails came back...

Share this post


Link to post
Share on other sites
Rune Aasgaard

@kappclark: Aaaargh! I had checked and rechecked all folder definitions numerous times, but I had made the changes directly in config.php and only spotted the error when I opened up the Settings page. Works now. Thanks!

EDIT: Since many other things (including graphic symbols) worked, the implication is that TNG uses a combination of absolute and relative path references.

Edited by Rune Aasgaard
Additional thought without creating a new post

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×