Jump to content
TNG Community
BobD

Installing wamp server and TNG

Recommended Posts

bhemph

Bob,
     In TNG 13.0.0 Darrin modified things so that the admin_main is not to be used anymore.  There was still one reference to it, but that has been removed in some later TNG 13 release.  I asked Darrin to remove the admin_main.php file from the distribution, since it was replaced and the reference was removed and it did for one version but after the beta the file was included in the distribution again.  You say that you are running TNG 13.1.2 on your localhost, but the screenshot is showing TNG 12.3.  If the localhost is doing the same thing, then it seems like somewhere there are files from different versions running that is causing the issue.

      To get the files in sync, first make a backup of your files (this is so the configuration files can be restored if accidentally overwritten).  Since you said you do not have any mods installed, then you should be able to replace all the files except config.php, customconfig.php, importconfig.php, logconfig.php, mapconfig.php, mmconfig.php, pedconfig.php, and subroot.php.  Then in order to make sure that whatever database updates have not been missed it would be a good idea to upload the readme10x-13x.html and upgrade .php files and run the readme and just do the database step.  I picked 10, but if 11 or 12 was the first TNG version that you had then one of those would be fine.  If the database is already changed, then it will just say that it is completed or done already and not change anything.  It might be kind of a scorched earth method of making sure that everything is clear and up to date, but should ensure that the correct versions of all the files are there without comparing every file in TNG one by one.

Brent

Share this post


Link to post
Share on other sites
Ken Roy

Brent,

Thanks for posting your reply

Bob,

I am sorry, I do not have the time to look at your production site to help straighten that out but Brent's recommendations should help you straighten out your environments

Share this post


Link to post
Share on other sites
theKiwi

I think that "admin_main.php" used to be the URL for the frame containing the Admin area BEFORE the whole make up of TNG Admin changed - i.e. the main URL to TNG Admin was always admin.php, but the frame that showed all the buttons was admin_main.php. No matter what part of TNG Admin you went to, the URL bar aways showed admin.php.

A few TNG updates ago - TNG 12 or TNG 11? the whole structure of TNG Admin changed, and so now when you go to a different part of TNG Admin, the URL bar shows that, like - like admin_modhandler.php or admin_reports.php.

On my site the file admin_main.php was last updated on 10/4/2020. It is not linked to any file in TNG 13.1 full download that I have

I think you can safely delete that file - or at the very least ignore it, and don't use it at all.

Roger

Share this post


Link to post
Share on other sites
BobD

Brent,

Thanks for the help. I'll give it a try.

Bob

Share this post


Link to post
Share on other sites
Krisamd

I have a similar problem

I have installed WampServer_(64bit)_v3.0.6 in my new notebook Windows 11 from backup

Copied TNG13 from backup and installed it in www

I tried to import my database and I got this response:

I have exported namkudum_charifamily.sql and tried to import into mySql

 

I get following error

 

Error

SQL query:

CREATE TABLE `book_auth` (

  `ID` smallint(5) NOT NULL,

  `username` varchar(60) NOT NULL DEFAULT '',

  `password` varchar(60) NOT NULL DEFAULT '',

  `session` varchar(32) NOT NULL DEFAULT '',

  `last_visit` int(11) NOT NULL

) ENGINE=InnoDB DEFAULT CHARSET=utf8

MySQL said: Documentation

#1046 - No database selected

I opted following solution

Copied from backup bin/mySql/mysql 5.7.14/data/charifamily folder
to the new bin/mySql/mysql 5.7.14/data/charifamily

Made necessary updates in MySql user as per TNG config.php

Browser opened “localhost/tng13/index.php

Verified administration>>Setup >> Configuration >> Template Settings as also Setup >> Diagnostics

Now I am unable to access to individual pages and get this message

Example

An error has occurred in the TNG software. What to do:

If you just installed an upgrade, you might have skipped part of the installation instructions. Go back to the upgrade readme page reread the instructions. Pay special attention to the database structure step.

If you just installed TNG for the first time, you might still need to create the database tables. Return to the readme.html page to find that step.

If you are the site owner, you may contact TNG support for further assistance with this problem. Please copy the query below and paste it into your message.



Query: SELECT tng_media.mediaID, medialinkID, alwayson, private, thumbpath, mediatypeID, usecollfolder, newwindow, tng_media.gedcom FROM (tng_media, tng_medialinks) WHERE personID = "I5" AND tng_medialinks.gedcom = "tree1" AND tng_media.mediaID = tng_medialinks.mediaID AND defphoto = '1'

Unknown column 'private' in 'field list'

Shall appreciate solutions

Thanks

Kris

Share this post


Link to post
Share on other sites
Krisamd

Ignore the entire problem

Namkudumbam.net in Simply Hosting is not in synthesis with Local Host setup.

Simply Hosting  have moved the database from MySql to Mariadb and I was informed the change.

in moving to Mariadb the eintire media has been duplicated with new media id and both old id and new id are not in synthesis.

Now I will be upgrading the local host setup  to wampserver3.2.6_x64 and the database from MySql 5.7.14 to Mariadb 10.3.34

This upgrade will wait for TNG upgrade from 13 to next leval.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×