Jump to content
TNG Community
Hanne B. Stegemüller

Solved: Documents have to be added manually

Recommended Posts

Hanne B. Stegemüller

Solved: Legacy was handled the wrong way.

Hi there experts

I am (still) helping @Steen Riis Thomsen with bist.dk. He needs to upload documents, where I have no experience myself.

I/we do this:

  1. Control in "Setup >> Configuration >> General Settings" that the name for the Document Folder has the default name "documents"
  2. Control in the GEDCOM file that there is a link to a document (specifically a .pdf but also tried with Word docs) on the correct individual
  3. Control that this .pdf (or Word doc) document is sent with FileZilla to /public_html/documents/
  4. Import the GEDCOM with check mark in Import media links.

The problem is: documents are not automatically linked to the individual. But exactly the same procedure automatically links images to the individual. He has to link documents to the individual manually.

TNG version is 13.1.1. Browser cache is cleared.

Am I missing something?

 

Share this post


Link to post
Share on other sites
Katryne

Good evening Hanne !

I have never uploaded documents and other medias via ftp. Always did from inside TNG with the top menu command Add media, in the editing page of a person or a family. And  recently, I  tried this way to add a document to a place.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller

Good day @Katryne

Oh yes I see what you mean! And I can see what he can do.

But I do understand, why it it does not happen automatically when the same process is done with photos and there the photos are automatically linked to the right individuals?

The logic should be the same?

Share this post


Link to post
Share on other sites
tngrlkrz
On 3/8/2022 at 9:08 AM, Hanne B. Stegemüller said:

The problem is: documents are not automatically linked to the individual. But exactly the same procedure automatically links images to the individual. He has to link documents to the individual manually.

When I import all media, whether documents, photos, headstones, etc.,the final step is the Admin:Media:Thumbnails the Create Thumbnails, and, in my case since thumbs are already there, with the other boxes unchecked.  . 

Edit Update:  Corrections.  See Roger's note below.  Linkage is there before the Create Thumbnail step.

Share this post


Link to post
Share on other sites
Ken Roy

 

6 hours ago, Hanne B. Stegemüller said:

The problem is: documents are not automatically linked to the individual. But exactly the same procedure automatically links images to the individual. He has to link documents to the individual manually.

I do not import media, so I might not be accurate in my assessment, but it sounds like your documents are not part of the genealogy program that you used to generate the GEDCOM file. 

Some desktop genealogy programs only know about photos (I think that is the case with RootsMagic)

6 hours ago, Hanne B. Stegemüller said:

Control in "Setup >> Configuration >> General Settings" that the name for the Document Folder has the default name "documents" 

TNG defines standard collections -- photos, documents, history, headstones, and other media but that does not mean that all genealogy programs associate media to those categories or collections.  TNG also allows you to create your own collections.

So the question are:

  • are the documents a recognized media category in your genealogy program used to generate the GEDCOM file? 
  • what media categories or collections does your genealogy program recognize?

Share this post


Link to post
Share on other sites
theKiwi
5 hours ago, tngrlkrz said:

When I import all media, whether documents, photos, headstones, etc.  I find that the linkage to people, (which must be in the gedcom records with links to people included by your genealogy software that creates the gedcom) occurs only the final step in Admin:Media:Thumbnails Generate button is clicked, and, in my case since thumbs are already there, with the other boxes unchecked.  Only after that, are media images properly linked to the persons. 

This is not my experience, and not sure how it makes any sense - media all show up after an import, before running the Create Thumbnails routines - they just get the generic default icons instead of thumbnails, until the thumbs are created - or in your case since they already exist linked to the media item.

Roger

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
8 hours ago, Ken Roy said:

 

I do not import media, so I might not be accurate in my assessment, but it sounds like your documents are not part of the genealogy program that you used to generate the GEDCOM file. 

Some desktop genealogy programs only know about photos (I think that is the case with RootsMagic)

TNG defines standard collections -- photos, documents, history, headstones, and other media but that does not mean that all genealogy programs associate media to those categories or collections.  TNG also allows you to create your own collections.

So the question are:

  • are the documents a recognized media category in your genealogy program used to generate the GEDCOM file? 
  • what media categories or collections does your genealogy program recognize?

Good morning @Ken Roy

  1. Yes. The documents show up in the GEDCOM. See citation example below
  2. I do not have an overview of what media categories or collections Legacy recognizes as I do not use them myself. But it is a lot; I think it is all the relevant ´types.

He uses Legacy just like I do my self. Legacy recognizes the documents (both Words .docx file and .pdf files) and on the individual we are testing at the GEDCOM object looks like this

Quote

2 OBJE
3 FORM mm
3 FILE C:\Users\SteenRiis\Documents\Legacy Family Tree\Media\FT 1870 Thomas Jensen glenstrup,nørhald,randers opslag 9.pdf
3 TITL FT 1870
3 _SCBK Y
3 _PRIM Y
3 _TYPE DOC

 

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
12 hours ago, tngrlkrz said:

When I import all media, whether documents, photos, headstones, etc.  I find that the linkage to people, (which must be in the gedcom records with links to people included by your genealogy software that creates the gedcom) occurs only the final step in Admin:Media:Thumbnails Generate button is clicked, and, in my case since thumbs are already there, with the other boxes unchecked.  Only after that, are media images properly linked to the persons. 

Hi @tngrlkrz

Yes of course the person must be in the GEDCOM and there must be links to the documents from the person in the GEDCOM. I do not know if I misunderstand what you write (language difficulties) but I think that is what I wrote in # 2 in my opening thread: 

Quote

Control in the GEDCOM file that there is a link to a document (specifically a .pdf but also tried with Word docs) on the correct individual

That was anyway my intention with # 2 :-)

We/he has this individual where we test:

Quote

0 @I98@ INDI
1 NAME Thomas /Jensen/
2 GIVN Thomas
2 SURN Jensen
1 SEX M
1 BIRT
2 DATE 11 Sep 1817
2 PLAC Glenstrup Sogn, Nørhald Herred, Randers Amt, Denmark
2 SOUR @S633@
3 QUAY 0
3 _VERI YES

The following OBJE is in the GEDCOM about @I98@ INDI Thomas Jensen

Quote

2 OBJE
3 FORM mm
3 FILE C:\Users\SteenRiis\Documents\Legacy Family Tree\Media\FT 1870 Thomas Jensen glenstrup,nørhald,randers opslag 9.pdf
3 TITL FT 1870
3 _SCBK Y
3 _PRIM Y
3 _TYPE DOC

I'll ask Steen Riis Thomsen to create thumbnails to see if that has any effect on documents - though it would not be very logic. Aren't thumbnails not only related to images? Or do they also has something to do with documents?

Share this post


Link to post
Share on other sites
Steen Riis Thomsen

Good morning everyone, thank you for your feedback. Today I will test the way I load word or pdf files in Legacy, to see if it might affect the GEDCOM file exported to TNG. As my mentor Hanne writes, all documents are copied to the HOST server via filezilla to public_html - Documents

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
24 minutes ago, Steen Riis Thomsen said:

Good morning everyone, thank you for your feedback. Today I will test the way I load word or pdf files in Legacy, to see if it might affect the GEDCOM file exported to TNG. As my mentor Hanne writes, all documents are copied to the HOST server via filezilla to public_html - Documents

Thanks @Steen Riis Thomsen  Now you will get a notification every time there is news. Will you try to "create thumbnails" like @tngrlkrz writes about?

Share this post


Link to post
Share on other sites
tngrlkrz
5 hours ago, Hanne B. Stegemüller said:

"create thumbnails"

As Roger notes, the if the gedcom has proper media records the media links should be there before the final step. Since I supply my own thumbnails, I leave the 'regenerate' boxes above unchecked.  If thumbnails are not uploaded, then they must be checked.  Also, I had used Legacy 7.5 for several years with TNG, and, with proper setup of 'master media paths', can export the 'links' of media to persons.  The only requirement to for TNG to match up folders is that part of the path match the TNG path setup in Admin:Setup:Media.  The gedcom file path can have additional path data preceding the TNG specified path which TNG will ignore during import.

An example gedcom media document record (from Family Historian).

1 FILE Media\documents\D18080403 Hartl,johannG b-PR.jpg

The path within TNG Admin:Setup >> Configuration >> Import Settings:

image.png

 

Ron

Share this post


Link to post
Share on other sites
tngrlkrz
13 hours ago, theKiwi said:

This is not my experience, and not sure how it makes any sense - media all show up after an import, before running the Create Thumbnails routines - they just get the generic default icons instead of thumbnails, until the thumbs are created - or in your case since they already exist linked to the media item.

Roger

Roger, you might be right, that the media is already linked after import   Maybe it was a past negative experience that 'burned' in my memory, but I just know that's the final step in my procedure when importing to be able to view media properly.  I will revisit and check before doing the 'create thumbnails' step to verify.

Edit Update:  

Roger is right, ...the media is already linked and the thumbnail step is not necessary to see the images without thumbs. The Create Thumbnail step is just the final step in the process however.  Sorry if I misled anyone with my previous (edited) post.

 

Share this post


Link to post
Share on other sites
tngrlkrz
7 hours ago, Hanne B. Stegemüller said:

Aren't thumbnails not only related to images? Or do they also has something to do with documents?

See my posts today asserting Roger is correct; if gedcom is properly constructed and paths match between gedcom and TNG import paths, then the media should already be linked before doing any thumbnail creation.  However, yes, thumbnails are relevant with any 'media' , i.e., photos, headstones, histories ..and documents.

Share this post


Link to post
Share on other sites
tngrlkrz
6 hours ago, Steen Riis Thomsen said:

Good morning everyone, thank you for your feedback. Today I will test the way I load word or pdf files in Legacy, to see if it might affect the GEDCOM file exported to TNG. As my mentor Hanne writes, all documents are copied to the HOST server via filezilla to public_html - Documents

The Documents folder should be a subfolder of the TNG Root folder, not at the same level as TNG.  Check your Admin:Setup:Import Settings for the paths.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller

Good morning everybody. Especially @tngrlkrz and @Steen Riis Thomsen

Sorry for the late reply! I was busy with other things yesterday.

I am confused: does Steen have to do the thumbnail step after importing a GEDCOM that holds new links to documents? Are thumbnail related to documents or only to images of persons/gravestones and so on. @tngrlkrz writes this: " thumbnails are relevant with any 'media' , i.e., photos, headstones, histories ..and documents".

The parths and folders are shown in the images below:

 

 

 

 

Billede-2.png

Billede-1.png

Share this post


Link to post
Share on other sites
tngrlkrz

Hanne,

6 hours ago, Hanne B. Stegemüller said:

does Steen have to do the thumbnail step after importing a GEDCOM that holds new links to documents?

When you quoted me regarding thumbnails, I was responding to your questioning thumbnails relevancy to documents,  indicating you can have thumbnails for all media including photos and documents.  The thumbnail process is optional, if you don't mind seeing only generic icons instead of a true thumbnail of the media. Also, is that snapshot of your setup or Steen's? What about the snapshot of the Admin:Setup:Import Settings?  

 

 

 

Share this post


Link to post
Share on other sites
Steen Riis Thomsen

Hi @tngrlkrz

I realized I made a mistake already in Legacy. I simply used the wrong icon to import the documents. When I use the correct icon, TNG can understand me :-) I am very satified, and thanks for all your inputs!

Kind regards,

Steen (and Hanne)
Denmark

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
52 minutes ago, tngrlkrz said:

Hanne,

When you quoted me regarding thumbnails, I was responding to your questioning thumbnails relevancy to documents,  indicating you can have thumbnails for all media including photos and documents.  The thumbnail process is optional, if you don't mind seeing only generic icons instead of a true thumbnail of the media. Also, is that snapshot of your setup or Steen's? What about the snapshot of the Admin:Setup:Import Settings?  

 

 

 

@tngrlkrz

Thanks for your reply!

  1. Okay. Now I see thumbnails are also related to documents. I have never worked with documents before - that is why. But it is great to learn something new.
  2. The snapshots are made by me as I have admin access to his TNG live page and his FTP account. So what you see is Steen's settings in TNG and FTP.
  3. We have found out what the problem is. Steen uses the wrong icon in Legacy when he adds the documents. When he uses the correct icon everything works like a charm - especially after also adding the import settings that you have showed in your screen shot from yesterday  01:44 PM . I am sorry I have never been aware of them, have never seen them before, as I have never worked with documents.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×