Jump to content
TNG Community
Rachael Williams

Okay. I am fed up.

Recommended Posts

Rachael Williams

What Desktop Genealogy Software do I need to buy?

I need TNG to import a GEDCOM file that will link to the images that I have uploaded to the server, and not just the file name of the images!

I will use the newly purchased desktop software, as an intermediary step, in order to import my FTM Gedcom and create a new Gedcom  that was processed through this new software so that I am able to have a working TNG website.

Share this post


Link to post
Share on other sites
Philip Roy

Hi fed up. First, you don't really need to post your entire post in bold...we get it, you are fed up. Also, that second sentence means I suspect you have some path settings wrong in TNG...but because you've provided no detail...it's hard to tell. Unless you've posted on this somewhere else and are expecting us to end that?

If you are wanting advice on software, you might want to start by telling us if you have a PC or a Mac...as it makes a difference.

Or, maybe start at the beginning and we'll see if we can help?

Share this post


Link to post
Share on other sites
Ken Roy
1 hour ago, Rachael Williams said:

in order to import my FTM Gedcom

You should be able to import a FTM GEDCOM but you might need to use a converter.  I do not use FTM.  What version are you using?  Have you looked at the TNG Wiki Desktop category.  There are quirks with all the different programs as indicated in the Desktop gotchas

Share this post


Link to post
Share on other sites
Rachael Williams

@Ken Roy I am using FTM2019. I have installed a converter gedcom_converter_v13.0.0.16.cfg &

I have also tried uploading a GEDCOM from Gramps and RootsMagic. But, as @Philip Roy pointed out, I strongly suspect that I have "some path settings wrong" at this point. I did try posting before with more detail, but I did not get much response... and made changes in rapid succession, until I got too frustrated an sent a BOLD forum cry for help.

I have a PC running Windows 10.

The original call for help is here:

But... it should be noted that I have shuffled things significantly in terms of the directory structure. I have also deleted and uploaded new trees in the interim.

I suspect that I moved folders to the wrong location, because some of the wiki pages said to place folders in pub_html/tng root directory, some said to place in the pub_html/tng/media directory, some said to create sub-directories in pub_html/tng/photos directory...

And now I don't know my arse from my elbows.

Share this post


Link to post
Share on other sites
Rachael Williams

I should also mention the I am using the TNG wordpress plugin --- https://lincolncemetery.org/soalsearch/

 

And my site is visible at, seemingly outside of wordpress at https://ancestors.lincolncemetery.org/

Share this post


Link to post
Share on other sites
Philip Roy
Quote

And now I don't know my arse from my elbows.

I’m not going to read any of your posts from now on whilst taking a sip of wine…I almost choked! I feel your pain but also don’t have the answers you need. But this caught my eye…

Quote

And my site is visible at, seemingly outside of wordpress at https://ancestors.lincolncemetery.org/

If you’re trying to embed TNG within a Wordpress site, I’m pretty sure this is a sure sign you’ve failed. Sorry, I don’t use WP at all, but if WP isn’t showing, then something is wrong.

Maybe take things in steps? Ken’s given some great advice and useful links to the wiki…especially about FTM (I’m on a Mac and don’t use it)…so I’d spend a great deal of time looking at that, before going any further. Baby steps…if something fails, stop and go back…otherwise you’ll just build error upon error…and then once you get to the point that the TNG version is running, you can start to look at Wordpress again?

Share this post


Link to post
Share on other sites
theKiwi

It seems like the WordPress part is working fine - those 2 URLs go to sites/pages that have the same content, but the first one is wrapped with another header and footer from WordPress, and the source code includes what the TNG plug-in inserts into a page.

The Media menu on both sites contains some "odd" items - why is there a Media collection called "Import".

image.png

And Cemetery?

I might be tempted to simply start over with an empty TNG database, and work to get the import of Media working. It certainly can be made to work as there are quite a number of TNG users who use Family Tree Maker - I'm not one of them, so don't understand the folder structure for media that Family Tree Maker keeps on your local computer that has to be somehow coerced into fitting into the folder structure that TNG is expecting.

Roger

Share this post


Link to post
Share on other sites
Rachael Williams

@Ken Roy Thanks! I have read the Desktop gotchas. That is what led me to the Gedcom Converter mod.

@theKiwi Should I recreate my tables through Admin Setup? And if I do that will I lose the information in my template?

 

Share this post


Link to post
Share on other sites
theKiwi
10 minutes ago, Rachael Williams said:

@theKiwi Should I recreate my tables through Admin Setup? And if I do that will I lose the information in my template

Yes, you'd lose that, and any other things you've saved like Users.

To prevent this you could:

1 - TNG Admin ------> Utilities - back up all the tables

2 - TNG Admin ------> Setup ------> Create Tables - this will delete them all and then recreate them

3 - TNG Admin ------> Utilities - Restore the Users and Templates tables. Also Restore Cemeteries if you've done anything with that, and the Countries and States

Then work through making sure that your Import Path settings for Media are correct for how FTM is presenting the media in the GEDCOM file

Then import the GEDCOM file again.

Roger

Share this post


Link to post
Share on other sites
Ken Roy

The other tables may also need  to be recovered from the Utilities > table > backup if you used TNG unique features

* Media Collections and image tagging
* Albums
* Branches
* Cemeteries
* DNA
* Languages
* Most Wanted
* Reports
* Timelines
* Trees
* Users

 

Share this post


Link to post
Share on other sites
Rachael Williams

@Ken Roy and @theKiwi

Thank you both for pointing this out! I did not try purging the database table yet... because I found something else that could have been causing the problem!  The image resizer I was using changed the file name on some of my freakin' images (over 2k of them)! So now I have some images linked!

image.png

Next, I just have to re-upload the re-resized images without any file name change!

But, Does anyone know why I have duplicate images that are unlinked to the individual?

image.png

 

I thought that the gedcom converter would have fixed this but it did not... or I'm doing something else wrong

(probably the later... but don't want to rush into getting my knickers in a bunch all over again! @Philip Roy sorry about the wine!)

Share this post


Link to post
Share on other sites
theKiwi

You have duplicate images probably because of all the imports you've done, so the same media has been imported over and over.

This is why I'm suggesting recreating the tables and starting over once you know you have the import settings set correctly for things to work.

Once you have this, you don't need to purge the tables any more as long as you don't change the Import settings for media folders - as long as that all stays the same in your TNG settings and GEDCOM then TNG will recognise any media it's already imported and skip over it.

Roger

Share this post


Link to post
Share on other sites
fluffy82

I didn't read all the comments yet, but as a reaction on the original post: I've been using FTM since almost 15 years as my "main tree", and have used it to successfully export gedcoms and upload them to my TNG website ever since I first started using it. I don't really see why you would want to have an intermediate application to go in between FTM and TNG? It works perfectly fine directly between both.

Share this post


Link to post
Share on other sites
Rachael Williams

@fluffy82 I think that my frustration stems from a lack of clearly understanding of the exact steps necessary to

  1. Get Media into the correct folder(s)
  2. The difference between albums and collections
  3. How to identify items in a collection (and do I move them into the correct directory on the server, or does TNG?)
  4. Most Importantly: A seemingly complete lack of understanding about what the Media Import function does

@theKiwi@Ken Roy---

So...I did the purge and recreated my database tables.  However, AFTER I did that I had to

On 3/2/2022 at 6:03 PM, Rachael Williams said:

Next, I just have to re-upload the re-resized images without any file name change!

And now I have tons of duplicates and triplicates the images! Again.

Counting media...

Photos: 19,338
Documents: 0 ... Disabled
Headstones: 0 ... Disabled
Histories: 0 ... Disabled
Recordings: 0 ... Disabled
Videos: 0 ... Disabled

image.png

I am DEFINITELY missing something about the way that the media import function works...

How am I getting so many duplicate images if they don't exist as duplicates on the server?

And why aren't any documents associated with the Events or People that they should be attached to? They aren't even showing up as attached to the source... and they certainly don't show up next to the event...? They are just floating unattached photos of documents. 😖

image.png

Share this post


Link to post
Share on other sites
theKiwi
30 minutes ago, Rachael Williams said:
  1. Most Importantly: A seemingly complete lack of understanding about what the Media Import function does

 

When you way "Media Import Function" - what exactly do you mean - what button are you clicking to implement this?

If you are clicking this button

 

image.png

 

That is your problem.

The Media get imported by the links in the GEDCOM file, and the actual items get uploaded by FTP from your computer to the appropriate folder(s) on the TNG site.

Empty out the tables again - or at least Delete ALL the Media items in TNG Admin ------> Media and then import the GEDCOM file again. Then look at the Media in TNG - does it show duplicates now?

Roger

Share this post


Link to post
Share on other sites
edglimited
44 minutes ago, Rachael Williams said:

 

  1. The difference between albums and collections.

 

Photos: 19,338
Documents: 0 ... Disabled
Headstones: 0 ... Disabled
Histories: 0 ... Disabled
Recordings: 0 ... Disabled
Videos: 0 ... Disabled

 

And why aren't any documents associated with the Events or People that they should be attached to?


Rather than confuse you with too much info, this is a simple breakdown.

The difference between Albums and Collections, is as follows. A Collection can consist of just one or all,  "Photos" "Documents" "Headstones" "Histories" "Recordings" and Videos".

An Album does not exist, until you create it. Once your'e Album is created, you can then add Media from the drop down menu in Collection, "Photos" for example. Or if the Media doesn't exsist yet, you can import it, to whatever part of your Collection. ie; to Photos, Documents etc.

Once imported into your Album, you 1st, need to link the item (photo or doc) to a Tree, then to a Family, Person, Source, Repository or Place. If you dont know who they are, you can search for them.

Drew..

Screenshot from 2022-03-06 10:35:46.png

Screenshot from 2022-03-06 10:36:17.png

Share this post


Link to post
Share on other sites
Rachael Williams

@theKiwi

Can I just delete the following?

Media Table 

Media Links

Media Types

Share this post


Link to post
Share on other sites
Rachael Williams
9 minutes ago, edglimited said:

if the Media doesn't exsist yet, you can import it, to whatever part of your Collection. ie; to Photos, Documents etc.

@edglimited Okay. All of my media is stored in the photos directory on the server.

If I import to a TNG Collection other then Photos (let's say Documents)

Does TNG know which media items (in the photos directory) are actual Photos and which are Documents (based on the gedcom)?

Or,

Does TNG import all of the media links as photos?

I ask because none of the documents that are linked to a record are associated with the corresponding Events, Sources, or Repositories. They are not even linked to the person! The only media that seems to be linked to a person is the person's profile picture.

 

@theKiwi That is why I keep trying to do multiple imports.

Share this post


Link to post
Share on other sites
edglimited
13 minutes ago, Rachael Williams said:

@edglimited Okay. All of my media is stored in the photos directory on the server.

If I import to a TNG Collection other then Photos (let's say Documents)

Does TNG know which media items (in the photos directory) are actual Photos and which are Documents (based on the gedcom)?

Or,

Does TNG import all of the media links as photos?

I ask because none of the documents that are linked to a record are associated with the corresponding Events, Sources, or Repositories. They are not even linked to the person! The only media that seems to be linked to a person is the person's profile picture.

 

@theKiwi That is why I keep trying to do multiple imports.Mdeia

Your'e reply is a bit confusing, you mention "other than photos", lets say documents, then revert to "in the photos directory".

As a "Rule of Thumb", for simplicity, Photo's, Pictures, Photo Scans etc, go in under Photos. Photos end with *.jpg, *.bmp, *.gif, *.tiff *.png etc.

Documents, Word, Pdf or scans of Doc's, Word Pdf etc, go in under Documents. Docs end with *.doc, *.wpd, *.pdf, even *.txt etc

I cant comment on FTM, as I have never used it, or even know how it works. However, having just looked at it, it scared the hell out of me. Ancestry for example wont export Photos / Docs, it will sometimes export links to a Gedcom, but not always. Sources are another matter, you only get half the info in your'e Gedcom. They like to keep everything in-house, or under their control.

TNG doesn't discriminate between a Photo and A Doc. If you upload it to the wrong folder, you wont get a warning message, saying "hold on", the item just wont show.

If you go to Admin >>> Media, then search under all trees, all collections, what shows in the "linked to" column.


 

Screenshot from 2022-03-06 11:34:29.png

Share this post


Link to post
Share on other sites
theKiwi
33 minutes ago, Rachael Williams said:

@theKiwi That is why I keep trying to do multiple imports.

I don't know what this means - did you empty out at least the media tables, and then import the GEDCOM file again?

Are there duplicates after you have done just this?

Separately - had you been using the Import button on Import ------> Media as I showed in the screen shot? If so, don't - just import the GEDCOM file and then see if there are any duplicates - after getting rid of all the Media first - the easiest way to do this is to set your TNG Admin ------> Setup ------> General Settings ------> Max Search Results to some hight number like 500 or 1000, then you can delete them from within TNG Admin by 500 or 1000 at a time.

Roger

Share this post


Link to post
Share on other sites
Philip Roy

Not sure if this will help or hinder Rachel, but I think the notion of 'importing media' is one that is a bit tricky in TNG....so maybe this will help.

The act of getting media files on to your site's server is usually done outside of TNG and can best be described as UPLOADING.

When you import a GEDCOM, you have to put in the paths into the settings within TNG, NOT because it's going to upload the images...it isn't...but because it helps TNG do some work for you. It reads the GEDCOM as it imports it and says "OK, the paths to the images on Rachel's PC are these in the GEDCOM...I now need to change that path to make it work within TNG on the server". That's all it is doing when you choose the option "import media links" when you import a GEDCOM. It basically imports and interprets the links. Again, it does NO UPLOADING.

@theKiwi is trying to get you to focus on that and fix it. If it doesn't work and you don't see images after you import the GEDCOM file (and select "import media links) as part of that process...let us know.

What we think you might be doing is (instead) heading off to the media section, saying "Oh, it didn't work" and clicking import there....which is probably creating the duplication.

As mentioned before, one step at a time...if it doesn't work...go back and try again...or post here.

Share this post


Link to post
Share on other sites
Rachael Williams

@theKiwi Okay, there appear to be no duplicates. But, the vast majority of the media is linked to nothing.

image.png

Share this post


Link to post
Share on other sites
Rachael Williams

@Philip Roy I can see the images on my TNG install https://lincolncemetery.org/soal/browsemedia.php

But, it doesn't seem like the majority of them are linking to anything.

This is the state after deleting all media and only re-importing the gedcom file.

I did not import anything through TNG Media Import or generate thumbnails.

Share this post


Link to post
Share on other sites
Philip Roy

OK...first question, did you then try and generate the thumbnails for the images? I've gone to the first 2 images on that page...there is no thumbnail, but there are images. Can you give us a specific link to an image that doesn't show?

Share this post


Link to post
Share on other sites
Philip Roy

Correction...the first is fine, the second isn't. Hold on and I'll look.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×