Jump to content
TNG Community
Hanne B. Stegemüller

SOLVED: GEDCOM tags are present but events are not shown

Recommended Posts

Hanne B. Stegemüller

Solved: Issue with missing date pr. cite/citation was an issue with export from Legacy 9.

I need a little bit of assistance with two topics:

I have not changed my "recipe" (I hereby mean settings 😎) of how to import GEDCOM-files, but something has changed anyway:

1. usually the date when I had last worked on an individual was shown beside each source in the lower part of an individuals page. I myself like to see if it is old data or recently found data, that I find, and of course I like to show this information to my visitors as well. But suddenly they have "disappeared".

I.e. this guy: Axel Simon Andersen Marienlund: https://tng.stegemueller.dk/getperson.php?personID=I402&tree=HBS has this information in the GEDCOM but it is not visible in TNG:
1 CHAN
2 DATE 16 Jan. 2022
3 TIME 21:02

Can anyone tell me what I do wrong?

2. The same person has these occupations in the GEDCOM, but they are not visible in TNG:

1 OCCU Kunstmaler
2 DATE Mar. 1915
2 PLAC Anna Sogn, Sokkelund Herred, Københavns Amt, Denmark
2 NOTE Ågade hører til enten Anna Sogn eller Brorsons Sogn i 1915
2 SOUR @S246@
3 PAGE København amt, Sokkelund, Vartov Hospitals Menighed, 1913-1
4 CONC 935, KM, Fødte, Konfirmerede, Viede, Døde - opslag: 79 af 1
4 CONC 64 opslag
3 QUAY 4
1 OCCU Tegnelærer og kunstmaler
2 DATE Apr. 1947
2 PLAC Johannes Døbers Sogn, Sokkelund Herred, Københavns Amt, Denmark
2 SOUR @S246@
3 PAGE København amt, Sokkelund, Johannes Døber, 1941-1961, KM, Dø
4 CONC de - opslag: 44 af 305 opslag
3 QUAY 4

I've tried to analyse what is going on about the occupations - and I'll show some examples, because I can't find the logic in this:

Myself: https://tng.stegemueller.dk/getperson.php?personID=I1&tree=HBS: No occupations in TNG. But GEDCOM has these:
1 OCCU Fuldmægtig
2 DATE Fra Jun. 1990 til 1995
1 OCCU Specialkonsulent, chefkonsulent, projektleder og souschef i staten
2 DATE Fra 1995 til 2013
2 PLAC København

My father: https://tng.stegemueller.dk/getperson.php?personID=I630&tree=HBS Occupation is shown in TNG, and GEDCOM has this:
1 OCCU Driftsleder i tekstilindustrien

My fathers father: https://tng.stegemueller.dk/getperson.php?personID=I851&tree=HBS No occupations in TNG. But GEDCOM has this:
1 OCCU Driftsleder hos a/s Chr. Juncher

Note: And just to make sure: all my eventtypes are marked with "Accept" "On import". And I've double checked in phpMyAdmin where the all have "1" in the "Keep"-field.

If any one can see which mistake(s) I make, I'll be glad. I'm pretty sure the issue(s) is not only related to these two tags - but I can't prove it.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller

Hi all

I wonder if I've done something wrong with this post (i.e. description to bad, language to bad), the question is very difficuelt or if there are other reasons why I get no answers. Normally answers run in quickly.

Kindest regards,
Hanne,
Denmark

Share this post


Link to post
Share on other sites
Philip Roy

Sorry, in a bit of a rush tonight...but for occupation...check that you have the custom event "occu" set to be displayed....

https://tng.lythgoes.net/wiki/index.php/TNG_Events_and_Event_Types

Here's my settings...

Screen Shot 2022-01-21 at 8.16.00 PM.png

When importing the GEDCOM file, take a look at this page and the section on custom events...

https://tng.lythgoes.net/wiki/index.php/Import_Data

My entire site is completely replaced each time I do a GEDCOM import (I'm the only person maintaining it and doing most of the work in Reunion...the site is basically just for family to view) so I always choose the setting "Accept data for all new Custom Event Types"

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller

Don't feel sorry Philip Roy. I am the one to apologize!

Thanks for your reply. I'll check your suggestions a bit later and return with a reply.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller

Something happend - my follow up-answer disappeared...

Edited by Hanne
Something happend - my follow up-answer disappeared...

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller

Hello everybody

I tried to replace all data as suggested by Philip Roy. It did not change anything at all.

Normally I only add new data and media, because else I have to geo place (with the wonderful MOD) 39 empty places with -1 again and again. But with this little exercise I learned a bit of SQL and I'm so proud of myself that I MUST tell you about this 😎 that works like a charm:

UPDATE   tng_places
SET   placelevel = '-1'
WHERE   longitude = ' '   AND latitude = ' '

 

Share this post


Link to post
Share on other sites
Philip Roy

Hold on...I think you're trying to do something quite different to what I thought you were asking. I was simply offering guidance on how to get a person's occupation displayed on their page.

But when I went to this page (like you suggested)...

https://tng.stegemueller.dk/getperson.php?personID=I1&tree=HBS

And searched for "Specialkonsulent"...the occupation is showing up on the map?

Is that what you want? And why? I'm confused.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
14 hours ago, Philip Roy said:

Hold on...I think you're trying to do something quite different to what I thought you were asking. I was simply offering guidance on how to get a person's occupation displayed on their page.

But when I went to this page (like you suggested)...

https://tng.stegemueller.dk/getperson.php?personID=I1&tree=HBS

And searched for "Specialkonsulent"...the occupation is showing up on the map?

Is that what you want? And why? I'm confused.

Hi Philip

It might be language problems and therefore I maybe misunderstood you. Sorry.

You are right the occupations are shown to right of the map when you look at this person (me); https://tng.stegemueller.dk/getperson.php?personID=I1&tree=HBS

But normally they should be displayed as a field in the upper part of an individual like it is here on my father: https://tng.stegemueller.dk/getperson.php?personID=I630&tree=HBS where this is shown "Occupation" "Driftsleder i tekstilindustrien" right below his graduation. And that is how I would like it displayed on all individuals.

And I can't figure out why it is correct on some individuals and wrong on other individuals.

My settings should be correct - see screenshot.

And when I import the GEDCOM-file, I always do like you do: "Accept data for all new Custom Event Types"

 

begivenhed-occu.png

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
  1. Hurray - now the occupations are shown! I think I had made a mistake with some MODs.
  2. Now I only have the problem with the date, that should be displayed with each source, so it can be seen, when I last edited that source.

Share this post


Link to post
Share on other sites
Philip Roy

1. Yay!
2. I can't answer...I don't do any editing in TNG...it's all in Reunion and then the entire GEDCOM is imported each time I want to update. But someone might be able to answer.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
12 hours ago, Philip Roy said:

2. I can't answer...I don't do any editing in TNG...it's all in Reunion and then the entire GEDCOM is imported each time I want to update. But someone might be able to answer.

Hi Philip

It is okay you can not answer. I hope somebody else passes by and see this post.

Just to clarify: I also don't edit in TNG. I base all data on imports from a GEDCOM-file created by Legacy, and Legacy has the date for when changes to a source were made (each transcription), and this date used to be displayed in TNG.

Share this post


Link to post
Share on other sites
RickM

Hi Hanne,

I'm a bit confused myself.. I have just been and checked the two links you gave in your initial post.

I see both Occupations AND Date last modified..

I might have missed something in translation as well <smile>

Hanne-1.jpg

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller

Hi Rick

I do agree what your arrows show!

What I miss is the date that was shown beside each source. I am sorry I am not good a drawing with GIMP, but the date used to be displayed in connection with/right after Reliability.

Edited January 24th, 11:37 AM: It should be called "shown beside each cite/citation" (I don't know the correct English term.)

This told visitors when I have last been editing this transcription or whatever it is. I hope the image can explain what I have not been able to explain with words:

 

souces-no-dates.png

Edited by Hanne
Clearifing: Not "beside sources", but "beside citations"

Share this post


Link to post
Share on other sites
RickM

This is something I have not noticed at all myself.. I don't have a lot of sources.. Bit lazy really.. I know I should and will have to start sorting them out.. I will see if i can find someone who I have added sources etc to and check if I see a date beside it..

Having had a look, I don't see a date for last made changes..

 

Edited by RickM
Added some extra

Share this post


Link to post
Share on other sites
theKiwi
1 hour ago, Hanne said:

This told visitors when I have last been editing this transcription or whatever it is. I hope the image can explain what I have not been able to explain with words:

 

I think you should contact Darrin about this - send him a Legacy created GEDCOM file, and the drawing above with your description.

I don't see this on my site because Reunion doesn't export a a date/time stamp on sources - just a date stamp on individuals and families.

Roger

Share this post


Link to post
Share on other sites
Philip Roy

I'm not sure TNG even does this? I just tried adding a fake source to my test TNG site and there is no display of any time/date for when it was modified....so this does sound like an enhancement you are after.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
12 hours ago, Philip Roy said:

I'm not sure TNG even does this? I just tried adding a fake source to my test TNG site and there is no display of any time/date for when it was modified....so this does sound like an enhancement you are after.

 

14 hours ago, theKiwi said:

I think you should contact Darrin about this - send him a Legacy created GEDCOM file, and the drawing above with your description.

I don't see this on my site because Reunion doesn't export a a date/time stamp on sources - just a date stamp on individuals and families.

Roger

 

15 hours ago, RickM said:

This is something I have not noticed at all myself.. I don't have a lot of sources.. Bit lazy really.. I know I should and will have to start sorting them out.. I will see if i can find someone who I have added sources etc to and check if I see a date beside it..

Having had a look, I don't see a date for last made changes..

 

Good morning (here it is 11:02 am). Sorry for the late reply, but I was busy with the panic about blank page, mods, sleep and so on...

Finally I learned how to multi quote 😎

RickM: I have sources on 95 percent of my data.

Philip Roy: I am 150 % sure that this information was shown in that place. I don't think I "invented" something. And the text was nicely present in both English, Danish and German. I wish I could prove it.

I have checked in Legacy that I do not suddenly exclude data, that could be the missing data. I use the same list of codes with every export.

On the other hand I can only find the GEDCOM-code "CHAN" i Legacy, and when I search the latest GEDCOM-file, I only find CHAN once per individual, and that is not in connection with sources.

But here it finally comes: When I check in phpMyAdmin in the table "tng_citations" there are fields called "citedate" and "citedatetr" (for timestamp)

All "citedate" are all empty, and then TNG has nothing to show - of course; but I think that should convince you, it has been there.  Really strange. This must all together mean Legacy does not export them (any more).

Strange. But logic must be: I make some mistake in Legacy? Do you agree?

 

Share this post


Link to post
Share on other sites
Philip Roy

You’ll have to contact Darrin, but I suspect you are confusing two different things. For citations, dates are important…

https://www.familysearch.org/wiki/en/Cite_Your_Sources_(Source_Footnotes)

..and in my quick test, I was able to add a date to a citation added in TNG…but it didn’t show up on a persons page…it only showed up when you went and had a look at the citation.

I think you are thinking that this date field for a citation is like a “Last update on” field…and I’ve convinced myself, that’s not how those date fields work.

For example, I added the citation with the date 2000…and it displayed it. I think you are expecting it to automatically refer to when you added or update the citation (24 Jan 2022 as I type)…and I don’t think it does that. If those fields are empty, I suspect you aren’t adding a citation date in Legacy…you are expecting it to be automatic…and that’s actually bad practice re a citation.

Thats my guess…Again, I think Darrin is the best person to ask next.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
3 minutes ago, Philip Roy said:

You’ll have to contact Darrin, but I suspect you are confusing two different things. For citations, dates are important…

https://www.familysearch.org/wiki/en/Cite_Your_Sources_(Source_Footnotes)

..and in my quick test, I was able to add a date to a citation added in TNG…but it didn’t show up on a persons page…it only showed up when you went and had a look at the citation.

I think you are thinking that this date field for a citation is like a “Last update on” field…and I’ve convinced myself, that’s not how those date fields work.

For example, I added the citation with the date 2000…and it displayed it. I think you are expecting it to automatically refer to when you added or update the citation (24 Jan 2022 as I type)…and I don’t think it does that. If those fields are empty, I suspect you aren’t adding a citation date in Legacy…you are expecting it to be automatic…and that’s actually bad practice re a citation.

Thats my guess…Again, I think Darrin is the best person to ask next.

Thank you Philip, I'll contact Darrin in this matter.

But try to see this screen shot. The Danish term "Udarb. dato" followed by a date, (I've tried to underline it) is what Legacy adds automatically each time I change/make a citation. "Udarb dato" in Danish is what you mention "Last update" refering to the citation.

../Hanne

Udklip.JPG

Share this post


Link to post
Share on other sites
tngrlkrz
2 hours ago, Hanne said:

Legacy does not export them (any more).

Strange. But logic must be: I make some mistake in Legacy?

Hanne,  Have you looked at your gedcom from Legacy to see if the dates are there or not?  It would isolate the issue to Legacy or TNG.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
6 minutes ago, tngrlkrz said:

Hanne,  Have you looked at your gedcom from Legacy to see if the dates are there or not?  It would isolate the issue to Legacy or TNG.

I have checked in Legacy that I do not suddenly exclude data, that could be the missing data. I use the same list of codes with every export.

On the other hand I can only find the GEDCOM-code "CHAN" i Legacy, and when I search the latest GEDCOM-file, I only find CHAN once per individual, and that is not in connection with citations.

I think this is a Legacy issue so I've written to the Danish Legacy expert, which GEDCOM-code ought to create this date/data.

Edited by Hanne
changed "source" to "citation"

Share this post


Link to post
Share on other sites
tngrlkrz
3 minutes ago, Hanne said:

think this is a Legacy issue

Did you do any Legacy update recently?  Do you have an older gedcom you could look at to see if/when the issue presented itself in the Legacy export. I keep older gedcoms for my export from Family Historian for just that reason : to verify which software is causing an issue, my desktop software or TNG.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller
1 minute ago, tngrlkrz said:

Did you do any Legacy update recently?  Do you have an older gedcom you could look at to see if/when the issue presented itself in the Legacy import. I keep older gedcoms for my export from Family Historian for just that reason : to verify which software is causing an issue, my desktop software or TNG.

  1. No I think it is a long time since Legacy was updated. I do not remember when but I think maybe one year ago
  2. It is a splendid idea to look in old GEDCOMs - I also keep them. I have 53 at the moment. 😎 I am so afraid of loosing data. The oldest is from 2021-06-13. I'll take a look at that.
  3. Thanks for your reply.

Share this post


Link to post
Share on other sites
Hanne B. Stegemüller

I am happy. My dates pr. cite/citation are back! It was not something I dreamt (about).

I think it is a Legacy enhancement and not a GEDCOM-code, because in Legacy the are two export steps:

  1. Select export to GEDCOM 5.5.
  2. Select export as a Legacy-file (I assume it should be interpreted: "GEDCOM coming from Legacy").

I include two screenshots showing the dates:

Thanks for all your kind help and inspiration!

 

citation-DATE.JPG

 

citation-DATE.JPG

Share this post


Link to post
Share on other sites
RickM
4 hours ago, Hanne said:

I am happy. My dates pr. cite/citation are back! It was not something I dreamt (about).

Yayayayayaayayayayayayayay

Well done you!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×