Jump to content
TNG Community
Jan van den Heuvel

How do I get rid of stange characters? -SOLVED

Recommended Posts

Jan van den Heuvel

I have an issue with strange characters, how do I get rid of them? The Spanish ñ is not displayed correctly, the same for other exotic characters (see picture)

tekens.JPG

Share this post


Link to post
Share on other sites
Rob Severijns

Jan,

What collation do you use for your database tables?

I use utf8_general_ci   and have no problems.

You can change this via  phpMyAdmin

If you don't know how to you can ask your ISP to do it for you.

Rob

Share this post


Link to post
Share on other sites
Rob Severijns

Jan,

If you search the forum wit the word collation you will find more info on this.

Rob

Share this post


Link to post
Share on other sites
Jan van den Heuvel
6 minutes ago, Rob Severijns said:

Jan,

What collation do you use for your database tables?

I use utf8_general_ci   and have no problems.

You can change this via  phpMyAdmin

If you don't know how to you can ask your ISP to do it for you.

Rob

Have changed this but I see no changes. I have following settings on my DB

tekens2.JPG

Share this post


Link to post
Share on other sites
bhemph

Jan,
     It means there is a mismatch, either in the language setup or between the language and the database.  What do you have as the definition for your language?  And then also what is the collation in the database?  It needs to be made sure that the language is set up correctly and that it matches the collation.

Brent

Share this post


Link to post
Share on other sites
Jan van den Heuvel
5 minutes ago, bhemph said:

Jan,
     It means there is a mismatch, either in the language setup or between the language and the database.  What do you have as the definition for your language?  And then also what is the collation in the database?  It needs to be made sure that the language is set up correctly and that it matches the collation.

Brent

Where can I find that? Found this but don't know if this is what you mean.....

tekens3.JPG

tekens2.JPG

Share this post


Link to post
Share on other sites
bhemph

Jan,
    Yes, if you go into each of the languages (Edit).  Does each one have the folder saying {language}-UTF8?  Any that do not will need to be updated to that folder.  Spanish and German are the ones that are most likely to cause the strange characters issue due to the accent marks, but all should have the UTF8 folder to match your Tekenset UTF-8.

Brent

Share this post


Link to post
Share on other sites
Jan van den Heuvel
32 minutes ago, bhemph said:

Jan,
    Yes, if you go into each of the languages (Edit).  Does each one have the folder saying {language}-UTF8?  Any that do not will need to be updated to that folder.  Spanish and German are the ones that are most likely to cause the strange characters issue due to the accent marks, but all should have the UTF8 folder to match your Tekenset UTF-8.

Brent

This is the folder structure of my languages subdir...

tekens4.JPG

Share this post


Link to post
Share on other sites
bhemph

Jan,
     No, I was saying if you click the green edit button for each language it brings up the page:

image.png

and does each language have the -UTF8 on the end of the folder name, like mine?  If not, you will need to change what is picked in the drop down menu to the -UTF8 folder.

Brent

Share this post


Link to post
Share on other sites
Jan van den Heuvel
30 minutes ago, bhemph said:

Jan,
     No, I was saying if you click the green edit button for each language it brings up the page:

image.png

and does each language have the -UTF8 on the end of the folder name, like mine?  If not, you will need to change what is picked in the drop down menu to the -UTF8 folder.

Brent

Tried this with Spanish, changed it into Spanish-UTF8. I then choose language Spanish and I get a blanco page. Nothing is displayed. I am using Firefox. I then have to clear everything (browser cache, cookies) and then my webpage is being displayed in Dutch again, when I choose Spanish I again get the blanco page.....

Share this post


Link to post
Share on other sites
Ken Roy

Jan,

If you are getting a blank page, then you likely have a syntax error in your Spanis-UTF8 cust_text.php  see Blank Page in the TNG Wiki Troubeshooting category.   The PHP Syntax Check  might help you find your error

In regards TNG language settings, you should read the Setup - Language  in the TNG Getting Started Guide  category

 

Share this post


Link to post
Share on other sites
theKiwi
2 hours ago, Jan van den Heuvel said:

tekens2.JPG

This is the wrong place to look. You have to look on the left column, find the name of your database, and then click on that, then on the main column, click on Structure to see a listing of all the tables in the database, and what their collation is set to. Then see what is in the column "collation" for each of the tables

image.png

Roger

Share this post


Link to post
Share on other sites
Jan van den Heuvel
30 minutes ago, theKiwi said:

This is the wrong place to look. You have to look on the left column, find the name of your database, and then click on that, then on the main column, click on Structure to see a listing of all the tables in the database, and what their collation is set to. Then see what is in the column "collation" for each of the tables

image.png

Roger

Mine looks like this. How do I change it when my Collation-settings are not ok?

database.JPG

Share this post


Link to post
Share on other sites
theKiwi
1 hour ago, Jan van den Heuvel said:

Mine looks like this. How do I change it when my Collation-settings are not ok?

database.JPG

Click on the tab called "Operations" and there you can select all the tables and convert them all to the desired collation.

Is this what you did, or something else?

Roger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×