Jump to content
TNG Community
Hanne B. Stegem├╝ller

SOLVED Issue installing 13.1 from 13.0.4

Recommended Posts

Hanne B. Stegem├╝ller

Hi there

I need a bit of help

I carefully followed the instructions in file: "readme1304-13x.html". Everything went well. I started on my test-site "better safe than sorry"┬á­čśÄ . I have backup of everything (all files plus full database).

Especially for the database step, I get the message quoted below, so everything has worked fine as this is written in "upgrade_db1304-131.php"

Quote

Because this upgrade is compatible with several incremental versions, there may be some commands that have already been done, so don't
    be alarmed if some lines say "failed or done previously":

Quote

 

\n"; $rval = true; } else $rval = false; //else { // echo "failed or done previously
\n"; // $rval = false; //} return $rval; } ?>

TNG 13.x Database Structure Update

\n"; ?>
The Next Generation database has now been updated to v13.x specs.

 

The problem is: I can not upload my GEDCOM file to the test-site. I have tried many times. Absolutely nothing happens.

This page: https://test-tng.stegemueller.dk/admin_gedimport.php returns this message:

SELECT filename, icount, ioffset, fcount, foffset, scount, soffset, mcount, pcount, ncount, noffset, roffset, fileoffset, ucaselast, norecalc, neweronly, allevents, media, branch, delvar from tng_saveimport WHERE gedcom = ""

Unknown column 'fileoffset' in 'field list'

Can anyone tell me how I can handle this issue on the test-site?

To me it looks like something has gone wrong in updating the database, when there is an unknown column.

Kind regards,
Hanne B. Stegem├╝ller

 

 

Share this post


Link to post
Share on other sites
theKiwi

Your quote about updating the database indicates that you had the ReadMe13-13x.html file open by double clicking it, rather than loading it as a webpage by entering its web address into your browser.

So load it again from your browser using http://localhost/TNG/readmexxxxx

and run the database update again.

Roger

Share this post


Link to post
Share on other sites
Hanne B. Stegem├╝ller

Hi Roger

Thank you very, very much. You are perfectly right. Now the import starts, runs and display results!

(I have updated at least 20 times over the years. I ought to know).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×