Jump to content
TNG Community
Sign in to follow this  
Cueyelink

Openstreet Map error

Recommended Posts

Cueyelink

Hello,

I have a problem with OSM after installation,
Open-street Map is not working in TNG v.13.0.4 (Dutch)
TNG - Wordpress (without the WP-plugin) running on Xampp / Localhost
OSM Automatic Geo coding: Version 13.0.0.3c
Installation OSM in Mod manager: ok
Map key: OSM
Problem: The map shows for a split second and then results in a error message (in Dutch).
The same error message as some other mentioned (see attachment).
Used several different browsers and also ran TNG, as test,  separated from WordPress.
The solution offered by Ken Roy did not solve the problem.
Hope that someone can help me out with this one.
Thanks in advance,

error_message_tng_osm.JPG

Share this post


Link to post
Share on other sites
Cueyelink

Hi Rob,

It doesn’t concern to ‘Google Maps’ but to ‘Open-Street Map’.
Thanks for the reply.

Share this post


Link to post
Share on other sites
Rob Severijns

Hi,

I know but to some extend there is info in there that might be useful to you too.

And if you look at your own screenshot it says "Google Maps is niet correct geladen....."

Rob

Share this post


Link to post
Share on other sites
Rob Severijns

I myself had a comparable problem in the past.

It turned out that my laptop (an MSI Gaming laptop) was loading drivers that handled the bandwith priorities while playing online games.

After I disabled those drivers the problems loading my site were solved.

Rob

Share this post


Link to post
Share on other sites
theKiwi
1 hour ago, Cueyelink said:

Hi Rob,

It doesn’t concern to ‘Google Maps’ but to ‘Open-Street Map’.
Thanks for the reply.

But the error message refers to an error coming from Google maps, not from Open Street Map.

So if you have installed Open Street Map there must be some part of the setup that you haven't done since your site is trying to load Google maps, not Open Street Map.

Check the documentation about what you are meant to enter into the Map Key field in TNG Admin ------> Setup ------> Map Settings.

Roger

Share this post


Link to post
Share on other sites
Katryne

Hi !

With open StreetMap, you should enter OSM in the general config, tap Map config, first field. It's mentionned there as a comment " Start the Map Key with 'OSM' (without quotes)
to enable Open Street Maps. "

Share this post


Link to post
Share on other sites
Ken Roy

For OpenStreetMap to work, you need to

* first install the OpenStreetMap mod since OpenStreetMap is not part of TNG

* after installation, you need to set the Map Key to OSM to activate the OpenStreetMap mod

If you are getting an error from Google Maps platform, that means you are calling Google Maps with a key of OSM which it does not recognize.

If you are switching back and forth between Google Maps and OpenStreetMap, which I do quite often, you need to remove the OSM from the TNG Map Key field if you  concatenated OSM in front of your Google Maps key. 

I find it easier to have a private mod that replaces the Map Key with OSM when I want to use the OpenStreetMap and then uninstall that mod when I want to return to Google Maps, otherwise you get an error from the Google Maps platform.    I use a private mod that contains

%target:mapconfig.php%

//  Set map key
%location:<span style="background-color:#E0FFFF;color:black">Set Google Map API key <strong>OSM for OpenStreetmap</strong></span>%
$map['key'] = "My Google Map API key goes here";
%end:%
%trimreplace:%
$map['key'] = "OSM";
%end:%

Note that if you only updated the Admin > Setup > Map Settings > Map Key, then OpenStreetMap is not install and you will also get that same error from the Google Maps platform

Share this post


Link to post
Share on other sites
Cueyelink
Thanks for all the responses. 
I don't understand it at all myself. 
I do not use Google Maps, nor have I entered a map key, but I do get a 'Google' error message. 
I only use the OSM mod with its settings. 
Confused...

error_message_tng_osm_ad1.JPG

error_message_tng_osm_ad2.JPG

Share this post


Link to post
Share on other sites
Ken Roy
4 hours ago, Cueyelink said:

I do not use Google Maps, nor have I entered a map key, but I do get a 'Google' error message. I only use the OSM mod with its settings.

Did you Install the OpenStreetMap using the Mod Manager?

Using a Map Key = OSM does not install the mod.  It only activates it instead of Google Maps.  EDITED - after you install the mod in Mod Manager

13 hours ago, Cueyelink said:

OSM Automatic Geo coding: Version 13.0.0.3c

The OSM Automatice Geocoding mod is NOT the OSM mod.  It is an add-on to do mass geocoding.

4 hours ago, Cueyelink said:

nor have I entered a map key

You sure did enter a Map Key based on your screen shot.  If you did not copy the OpenStreetMap mod cfg file and its subfolder to the mods folder and use the Mod Manager to install it then TNG is doing the call to Google Maps and thus the error you are seeing

Edited by Ken Roy
correct information

Share this post


Link to post
Share on other sites
Cueyelink

Ken,

'The OSM Automatice Geocoding mod is NOT the OSM mod.  It is an add-on to do mass geocoding '

A big shame on me!
Of course i had not download and install the right MOD.
Thank you and others to help me out finding the solution of this prob!
After downloading and installing the right mod everything is working as it should be.

Again Thanks!

Regards,

Share this post


Link to post
Share on other sites
Ken Roy

Glad you got it working.  Nothing to feel shame for.   The note in the mod cfg file is also a source of confusion for new users.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×