Jump to content
TNG Community
jhculbert

Feature Photos Display Has Changed

Recommended Posts

jhculbert

I am using TNG v. 13.0.3 on my home computer and have also chosen to use Template 6, which prominently displays a random "Feature Photo" in the center of the home page.  I recently decided to add additional Trees to my database, and then decided to reorganize my media folders to correspond to those new Trees by setting the "Separate media in tree folders:" option on the Setup >> Configuration >> General Settings admin. page to "Yes" and then clicking the "Convert" button.   After doing the conversion, I checked my media folders, and found that most, but not all, of my media were transferred successfully.  I then proceeded to move the remaining media appropriately.  However, one change that I did not anticipate is that the the "Feature Photos" oftentimes, but not always, now display the full image size, which is way too big for my home page, rather than the former display of just the thumbnails.  I checked a few of these too large images that were being displayed, and the thumbnails are still located in the same new folders with their primary images.  My questions to the TNG Community are, what controls the display of the Feature Photos, and is there anything I can do to have the "Feature Photos" only display the thumbnails once again?  Thanks!

Share this post


Link to post
Share on other sites
Rob Severijns

Hi,

Maybe a link to your site will help for others to look into this.

BTW I don't think the image you see is the actual thumbnail but rather the actual picture downsized (rendered) to a certain size.

Not sure where the code for this is.

Rob

Share this post


Link to post
Share on other sites
jhculbert

Thanks, Rob.  I cannot provide a link to TNG on my home computer.  It is not set up as a server.

Share this post


Link to post
Share on other sites
Ken Roy
On 9/5/2021 at 10:24 AM, jhculbert said:

However, one change that I did not anticipate is that the the "Feature Photos" oftentimes, but not always, now display the full image size, which is way too big for my home page,

The random photo never displayed the thumbnail but as Rob indicated above downsized version.

Since you made several changes:

  • add additional Trees to my database
  • Separate media in tree folders

You might have introduced the problem your are seeing. 

You would need to check the code in Template 6 index.php to see what controls the size of the display.  It is also possible that you now have images that are too big for the php software to resize dynamically. 

Just some things you should check.  It is always difficult to trouble shoot issues on local computers

 

Share this post


Link to post
Share on other sites
jhculbert

Thanks, Ken.  Undoubtedly, my media reorganization has caused this.  It just makes NO sense that moving media has now caused this issue, which as far as I can tell has heretofore never been described as an issue in the TNG Community.  I have not changed the size of any of the media in my media folders.  It is their display on the home page that has changed!

I appreciate your suggestion to check the index.php code for template 6, but I'm not sure I will understand what I am looking at there.  I can agree on principle, without doing specific checks, that some of my media may be too large for dynamic resizing on the home page.  The question then remains - why has that not been an issue previously?

Share this post


Link to post
Share on other sites
Ken Roy

Ask the question on the TNG user2list.  Assigning media by tree is a fairly new capability in TNG

The fact that your problem is occurring on your local computer and not on an Internet accessible site does not help, since we can only guess as to what might be the problem, unless of course we have encountered the problem.

Share this post


Link to post
Share on other sites
jhculbert

Thanks, Ken.  How do I find the TNG user2list?

Share this post


Link to post
Share on other sites
Ken Roy

In the TNG Admin screen, click the Getting Started help screen link.  At the bottom of the bottom of the help screen it tells you how to  subscript to the 2 TNG lists.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×