Jump to content
TNG Community
Sign in to follow this  
OttawaBullock

Changing tree names

Recommended Posts

OttawaBullock

I'm using TNG 13 and am attempting to add a link to an ancestral chart. On my MAMP local website, the code for the chart is:

verticalchart.php?personID=I21&tree=tree1&parentset=0&display=vertical&generations=5

 

On my actual website, the chart uses the following URL

verticalchart.php?personID=I21&tree=1&parentset=0&display=vertical&generations=5

 

The difficulty appears to be in the name of the tree from which the chart is taken. One calls it tree=tree1 and the other tree=1. The discrepancy makes it difficult to send code between the two sites. The trees on both my MAMP site and actual website should be the same. How do I go about correcting the name of the tree on my website to match that of the tree on my MAMP website? .

Thanks,

Bob

 

 

Share this post


Link to post
Share on other sites
OttawaBullock

Problem solved.

I defined a new tree on my website and titled it tree1. Then I deleted the tree titled 1. The links are now the same.

Thanks,

Bob

Share this post


Link to post
Share on other sites
Ken Roy

Bob,

Glad you solved it.  The field you are referring to is not the treename but the treeID which is the record for the tree in the tng_trees table, so your solution might be one of the only ways to solve this type of problem.

Share this post


Link to post
Share on other sites
OttawaBullock

Hi Ken,

I hope you’re feeling well after your surgery  

This is another minor problem when you finally figure out how to solve it. I have slowly been rebuilding my TNG 11 website on a new TNG 13 test site. It has been a slow and tedious process but I’m almost there. 

Thank you for your interest. 

Bob

Share this post


Link to post
Share on other sites
Ken Roy

Hi Bob,

My cataract surgery went well.   Still not spending too much time on the computer.

3 hours ago, OttawaBullock said:

This is another minor problem when you finally figure out how to solve it

What problem are you referring to?    I thought you indicated

4 hours ago, OttawaBullock said:

Problem solved.

while I was replying.

Share this post


Link to post
Share on other sites
OttawaBullock

Hi Ken,

Hi Ken. I did solve the problem of changing the tree name. I simply meant that once it has been solved, you realize in retrospect that it was fairly straight-forward. 

i did post another issue dealing with the size of the fonts in the ancestral and descendant charts.

Bob

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×