Jump to content
TNG Community
Fokko

Hide Google links mod refused

Recommended Posts

Fokko

Tried to install mod for hiding Google links in V1303 and almost succeeded.  The third change candidate in the mod was not accepted. I think

the syntax of the statement looked for had been changed since V12. Is it possible to have another version of this mod, please? ūüėÄ

Regards,

Fokko 

Mod mngr.PNG

Genlib.PNG

Mod config.PNG

Share this post


Link to post
Share on other sites
Rob Severijns

Fokko,

I have the mod installed too and it installs just fine.

Rob

EDIT:

You have the right version. My mistake.

 

Share this post


Link to post
Share on other sites
Rob Severijns

Fokko,

You could try and install the Hide Google Search Buttons before the Public Access Control Mod.

Rob

Share this post


Link to post
Share on other sites
Fokko

Rob,
Please have look at attachment two. The search argument at 59 differs with that in attachment three, blue row. I am not sure what kind of comparison the Mod monitor uses, but the arguments are supposed to match in my opinion to qualify for a replacement. If not, no success. Secondly it seems that this particular set of instructions with the blue row in the middle are outside the flow P.A.C.
Does the set of $menu[ ] statements in your Genlip.php looks the same? Of course with the "Google" modification in your coding.

Fokko

Share this post


Link to post
Share on other sites
Rob Severijns

Fokko,

I don't use the mod Public Access Control myself and sorry, but I don't know any code writing.

You need to wait for someone else to answer.

Rob

EDIT: My lines in genlib.php

/* Hide Google Buttons Mod - Michel Kirsch
  $menu[] = tngddrow(getURL( "searchsite", 0 ), "searchsite-icon", "", "searchsitemenu");
// Hide Google Buttons Mod - Michel Kirsch*/
Line two $Menu[] is disabled. Don't know why but maybe due to another Mod..
Enableling it generates an error.

Share this post


Link to post
Share on other sites
Brett
7 hours ago, Fokko said:

Does the set of $menu[ ] statements in your Genlip.php looks the same?

Fokko

If you are confident, try changing Line 60 in the Mod .cfg file.

The mod is looking for     $menu .= tngddrow(getURL( "searchsite", 0 ), "searchsite-icon", "", "searchsitemenu");

however genlib.php shows     $menu = tngddrow(getURL( "searchsite", 0 ), "searchsite-icon", "", "searchsitemenu");

on a clean install. Note the full stop after $menu

Share this post


Link to post
Share on other sites
Fokko
11 hours ago, Rob Severijns said:

Fokko,

I don't use the mod Public Access Control myself and sorry, but I don't know any code writing.

You need to wait for someone else to answer.

Rob

EDIT: My lines in genlib.php


/* Hide Google Buttons Mod - Michel Kirsch
  $menu[] = tngddrow(getURL( "searchsite", 0 ), "searchsite-icon", "", "searchsitemenu");
// Hide Google Buttons Mod - Michel Kirsch*/
Line two $Menu[] is disabled. Don't know why but maybe due to another Mod..
Enableling it generates an error.

Rob,

Thank you for your source item, it supported me in the belief that my source item was the original one and the mod one the old source version.

Fokko

Share this post


Link to post
Share on other sites
Fokko

Brett.

I saw the full stop, but it is not in my source. Mine must be later release (download 5/5/2021).

Used my source item as a search term and it worked as expected. Mod installed! You gave me the confidence to give it a shot¬†ūüôā

I did not change the version number of the Mod. Reinstall with V13.03.1? What do you do in a case like this?

Fokko

Result.PNG

Result.PNG

Share this post


Link to post
Share on other sites
Michel KIRSCH
14 hours ago, Fokko said:

did not change the version number of the Mod. Reinstall with V13.03.1

Hi Fokko, Brett,

my fault. it exists a version for TNG v13.0.1 but It was deleted from the wiki.

Because i'm writing another mod to hide the menu(s) you want everywhere in TNG... But it is long to tune with all the templates...

This is the TNG 13 version of the Mod.

And the Show_Hide_menu Mod in its actual state (not documented)

Note : the 2 Mods are NOT compatible !

Michel

hide_google_buttons_v13.0.0.1.zip

hide_menus_v13.0.1.beta5.zip

Share this post


Link to post
Share on other sites
Katryne

I understand there is an option for hiding Google buttons in this mod Hide_Menus ?

Share this post


Link to post
Share on other sites
Michel KIRSCH

Yes Katryne.

Install then Edit >> Easy Edit >> Menu Find >> set the "Search site" to "no".

The Google disappear from your drop-down "Search" and from people/families advanced search.

ATTENTION ! This Mod is a beta version, searching for user's suggestions/ideas.

If a menu disappear from your home page (by example)

you can not be happy with the result. Actually only template 13 is fully taking in account.

Michel

goggle search-no.JPG

Share this post


Link to post
Share on other sites
Rob Severijns

Hi Michel,

I installed your Beta5 and will do some experimenting.

Will share my findings via a PM.

Will you be starting a new thread for this?

Rob

Share this post


Link to post
Share on other sites
Michel KIRSCH

This is a heavy to developp Mod... I'm not ready again to continue with it.

Send me your findings and the template you use  by PM and I will do the code for your template.

Little by little, the Mod wil be ready to experiments with all users...

Michel

 

Share this post


Link to post
Share on other sites
Katryne

That's perfect ! And this is my lucky day : I use Template 13. Just look here (in template 13 the menu is at the bottom of the home page) https://genealogie.revestou.fr/

I was able to hide some menu items such as branches, sources ... and the google search is no more available in the menu and on the detailed search page.

I understand it must be a long work, since the home page and its menu depend on the template and should be coded differently according to each template.

Share this post


Link to post
Share on other sites
Rob Severijns

Hhmmmm,

Lucky number 13¬†ūüėČ

Haven't heard that one before¬†ūüėĄ

Rob

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×