Jump to content
TNG Community
Paul Barrett

SOLVED: WordPress/TNG integration issues

Recommended Posts

Paul Barrett

I solved this issue but thought I'd leave this thread up in case others encountered similar issues

Hi everyone.

I have been running TNG in native format on my Synology NAS for years and I'm in the process of implementing it at Berkshire Family History Society, using the Kloosterman method without the plugin

I have a native installation at:


It works, although it requires login so you'll have to take my word for that 😀

I have a working installation of WordPress using the OceanWP theme AND an entirely separate TNG installation in a "genealogy" folder in WordPress, as recommended.  The two TNG installations are in separate tables from each other, and the one that's integrated with WordPress is in the same table as WordPress - again as recommended - but the integration of WordPress with the second is causing some issues, probably self-inflicted.


First, the TNG pages don't display in the WordPress wrapper.  There's no TNG template defined so they just present on a plain page.

Second, any attempt to access any of the TNG Admin > Setup > Configuration screens returns an Error 403  This is in the integrated instance - the native one works fine


The 403 error was an issue of some kind in the WP installation.  In the end I dropped all the tables, deleted the folder contents and started over.  Problem solved.

WPTNG-meta.php was causing the problems with the page menu displays.  Possibly a conflict with the theme?  I have returned to the standard metaphp for now.

It's not a permissions issue and the files are all present.  I had played around with this setup so much in an attempt to fix it that, in the end, I decided to drop the TNG tables, delete the contents of the genealogy folder and start the TNG piece from scratch.  I get the same result

I'm sure this must be operator error but, as I'm figuring all this out as I go, I don't have the wider knowledge to diagnose the error.

I'd appreciate any help you can give, please?




Edited by Paul Barrett
Problem solved - solutions included

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now