Jump to content
TNG Community
ebelew

Template 19 'More' button

Recommended Posts

ebelew

In this template on the home page I have content in the "Feature" area. I have no link in the Feature 1 link: (and others) but the "More" button still shows up. When you click on it, it simply comes back to the home page. Is there a way to NOT have that button appear if there is no link entered?

Template 19
TNG v13.0.3
pfeiffergenealogy.org

Thanks
Eddy

Share this post


Link to post
Share on other sites
ebelew

When we have a template problem that couldn't be answered here, should we contact Darrin directly?

Share this post


Link to post
Share on other sites
JPB

Hello Eddy,

the only way to remove a "More" button is to remove the code. To do this, open the file templates/template19/index.php.

In this file, find the button you want to remove (there are five buttons) and remove the whole line. (Search for: $text['more'])

For example, the line where the last "More" button is (= line 206) looks like this:

<p class="right"><a class="btn-detail" href="<?php echo $tmp['t19_featurelink6']; ?>"><?php echo $text['more']; ?></a></p>

But be careful! Only you know whether you can trust yourself with this procedure. Ideally, you make your own Mod for these changes.

Before the operation, be sure to save the file index.php (template 19)!

Jürgen

 

 

Share this post


Link to post
Share on other sites
Rob Severijns

Hello Eddy and Jürgen,

I'm not able to write code but isn't it better to put // in front of the line to disable it from showing?

A backup of the index.php is, as Jürgen stated, wise to do.

Rob

Share this post


Link to post
Share on other sites
Rob Severijns

By the way Eddy,

You might need to change your signiture. 

It says you're using TNG 12.0

Kind regards,

Rob

Share this post


Link to post
Share on other sites
JPB
vor 4 Minuten schrieb Rob Severijns:

I'm not able to write code but isn't it better to put // in front of the line to disable it from showing?

You're right Rob, that's a simpler way to do it.

I prefer to delete the line and I allways do it through a Mod.

@ Eddy: If you need help, such a Mod is made quickly, then contact me via my website (contact form).

Jürgen

Share this post


Link to post
Share on other sites
ebelew

Ok, thanks guys, I'll try the code using the //
Yep I need to change signature to 13 and up 😉

JPB contact form message sent

Share this post


Link to post
Share on other sites
ebelew

Ok I got rid of the but not with //

I enclosed the line within the <!--     --> and they disappeared.

Thanks guys

E

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×