Jump to content
TNG Community

default banner problem, wrong login link when not logged in

Recommended Posts


I have just successfully upgraded from v11 to v 13, as usual excellent and precise instructions.

I am currently using template 11, but tried also template 3 which had the same problem.

In most of the non-admin pages (except the home page), there is a narrow top banner with useful links:

home    search    logout       followed by menus: 'find' 'info' and 'media' m

When a user is logged in, the corresponding links are correct, like



and http://honeymooney.com/genealogy/logout.php?session=PHPSESSID

so everything is fine. I have chosen to allow display of 'deceased' items to users who are not logged in, like for example this link to one of my Danish great-grandfathers, search for Christian Pedersen and pick the one born in 1848 at the same place as me:


and very conveniently the top banner changes dynamically to this banner:

home   search  login ...etc

and now the links are as follows:

http://honeymooney.com/genealogy/index.php  (which is correct, unchanged...)

http://honeymooney.com/genealogy/searchform.php  (which is correct, unchanged...)

and http://honeymooney.com/genealogy/getperson.php?personID=I1116&tree=sortkaerheron#

 (which is NOT correct and furthermore makes the site hang; should have been  http://honeymooney.com/genealogy/login.php )

Tried to switch to another template like #3, but the problem persisted.

 I had in fact the same problem under v11, (using template 3) and had hoped the upgrade would 'fix' the problem.

Any help or suggestion to fix it much appreciated, thanks.


Share this post

Link to post
Share on other sites

The link to log in is correct - the # at the end of the URL means it's going to open an overlay window on top of the page that you can enter your userID and password in to.


That said, however, it is not working on either of my sites - the overlay window comes up, I enter my name and password and then either the page stalls, or I get a blank page called processlogin.php.

On your site, the overlay doesn't appear, so something is wrong that's stopping that showing. The console shows some errors for items Not Found, and Forbidden


The not found genstyle.css should be looking in the css folder, not the genealogy folder

The last line of the errors about litbox.js is the code that would draw the overlay.

You should probably write to Darrin about this.



Share this post

Link to post
Share on other sites
Chris Lloyd

could be that the browser is blocking popups?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now