Jump to content
TNG Community
rfj1001

Gedcom Import doesn't get past "Opening"

Recommended Posts

rfj1001

I've just upgraded to rhe latest version of TNG and am taking the opportunity to upload and update my gedcom file and images since I last did a similar update about a year ago.

My main family history program is Family Historian and I used a pluig-in to create a gedcom file in utf8 format with specific settings for TNG. That I uploaded to my website by ftp.  (The file comprises about 15,000 individual records and is about 19M in size.)

On the gedcom import screen, I can select the required file, it is imported into the main tree and I have the Replace option set to Matching Records only.

As soon as I click on the Import Data Button, I get the message 'Opening' followed by the expected filename. I've fila attached a screenshot.

There's no progress bar showing, all there is is a spinning circle.   .. and it will be like that 2 hours later.

I'm assuming that's not correct.

Would be grateful for any assistance in getting the import working

Many thanks.

Rob

 

 

 

1.jpg

Share this post


Link to post
Share on other sites
KevyNC

have your imported files of this size before on this server? also are you importing from a file on the server or are you uploading a local file?

Share this post


Link to post
Share on other sites
Brett

I have this problem on occasions depending on the PHP/Apache version. What are you using?

Share this post


Link to post
Share on other sites
rfj1001

Brett/KevyNC

Thanks for the replies.

I'm running PHP 7.4.16, no version number for Apache. The setup/diagnositcs screen is showing all greens (acceptable)  in relation to the website environment checks done by TNG.

The gedcom file is on the webserver in the directory structure of the TNG installation. I've imported from this directory previously.

In terms of file size, I can't be sure whether I've done it before. I definitely had to split the gedcom file into smaller sections with a text editor but I can't remember whether that was to get around an ftp problem or a TNG import issue. I've checked all my archived tng emails around the date I split the gedcom file and I drewa blank on finding anything relevant.

 

Share this post


Link to post
Share on other sites
Ken Roy

You could try clicking the Stop link at the point you only see the spinning icon and then clicking the resume link once it indicates the import is stopped.  Sometimes that works.

On my hosting service the PHP Settings allows selecting FPM with OPcache as the PHP Handler.   When I use that selection, then the import screen shows no progress bar nor the counts if you select to import using the old style import by checking the box for Old style import (no progress bar)  on the Import screen

While my hosting service cPanel, shows

Quote

FPM with OPcache (recommended): FPM significantly speeds up PHP execution by maintaining workers that handle PHP requests. FPM is paired with OPcache - a caching system that keeps precompiled script bytecode in the server memory, which further improves PHP performance.
 

I have to change the PHP Handler to CGI in order to do Imports.  

Share this post


Link to post
Share on other sites
theKiwi

You could try checking the Rootpath setting in TNG Admin ------> Setup ------> Paths and Folders...

Set it to blank/empty and save the settings. (You could copy it first and paste it into a text document to save it)

Then open the Paths and Folders settings again and TNG will have filled in below that box what it thinks it should be - you can copy that and paste it into the box and save again, and then paste it into the same text document as previously and compare - were they the same or different?

Try the import again.

Roger

Share this post


Link to post
Share on other sites
rfj1001

Ken Roy/theKiwi,

Many thanks for the suggestions :

I tried Stop/Resume after which I got the message 'Reopening Maintree'. There's no spinning icon so I've no idea if anything is happening. After ten minutes I did another stop and resume and got the same message. If I stop/start the whole import I get the message in the original screenshot.

I also deleted the Root Path info and reopened the page as suggested. Below the box was identical information which has been copied back in.

The only php setting I can change in my control panel is the php version number. (choice of 7.3, 7.4 (recommended, and 8.0)

Share this post


Link to post
Share on other sites
theKiwi

Is the GEDCOM file correctly formatted as UTF-8 without BOM, and not set as Multibyte?

Roger

Share this post


Link to post
Share on other sites
bhemph

Try renaming the GEDCOM file to not have spaces, replacing them with _ underscores or just deleting them altogether.

Share this post


Link to post
Share on other sites
rfj1001

Thanks everyone for the advice - particularly bhemph.

I renamed the file as behmph suggested and the import worked :)

It was slightly disconcerting as the Progress Bar came up immediately but after about 5 minutes, it was still showing nil progress.

I just left it and after about 10 minutes in total the import was shown as complete. A quick check has shown the correct number of records imported.

Once again thanks to everyone

Share this post


Link to post
Share on other sites
Ken Roy

Sounds like OPcache is running on your site, because that is the way it behaves - just dumps the completed statistics at the end.  No progress bar, nor counts if you try to use the old style import.

I am lucky in that my hosting service allows me to switch to the CGI PHP handler when I want to do imports from the FPM with OPcache that can run for everything else.

Share this post


Link to post
Share on other sites
tngrlkrz
27 minutes ago, Ken Roy said:

switch to the CGI PHP handler

So Ken, is there noticeably better response/thruput  or other benefits to switch in OPcache when not doing imports?  We are both on ICDSoft, so I am able to do so as well.

Share this post


Link to post
Share on other sites
Ken Roy

Ron,

Sorry, I do not really know and do not dare ask them because I am continually exceeding MySQL execution time.  Import was the only part of TNG that appears impacted by using FPM with OPcache as the PHP Handler on their site.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×