Jump to content
TNG Community
Hanne

I would like to have two languages

Recommended Posts

Hanne

Hi there,

SOLVED

Maybe I have completely misunderstood everything about languages...

I have template 209, which supports more languages, and I have installed Danish-UTF8 and English-UTF8. I can change between the languages. That part works fine.

Q 1) After kind advise and inspiration from Rob, I have decided to have my front page translated into English by someone who is better at English, than I am. Where (in which file) do I place the English version?

Edited: okay maybe I have solved Q 1 my self: It as simple as 'choosing 'Create copy in' in template 209?

Q 2) Where do I change the fields/labels? What I don't understand is, that there is only one database - but the fields/labels must be stored somewhere?

I had i.e.. this issue: Even though I chose Danish, I got the label 'Census', but I Danish it should be 'Folketælling', so I translated them directly in the database table: tng_sources fields 'title' and 'shorttitle'. So now it is correct, when I choose Danish in the frontend, but (of course) it is wrong when I choose English.

Can one of you advise me the central link to the explanation about how I should handle the languages?

Best regards,
Hanne,
Denmark

Share this post


Link to post
Share on other sites
Hanne

Hello again

Don't waste your time on me! I have found out. It is really simple.

Have a nice evening.

Share this post


Link to post
Share on other sites
Rob Severijns

Good morning Hanne,

Nice to see you got the English Translation

Did you solve Q2 yet?

Here you can read about Text variables and translations

The way you made the translations now will likely end up in the translations being lost in the next version of TNG.

 

Another thing I noticed is that when I try to take a look at your website I get the following message:

Error: TNG is not communicating with your database. Please check your database settings and try again. Settings can be found under Admin/Setup/General Settings/Database, or at the top of your config.php file.

Kind regards,

Rob

Share this post


Link to post
Share on other sites
Hanne

Hi Rob

Thank you for your reply. This time I got a notice!

Yes I have solved Q 2 as well, as I realized that under 'Events' there is a possibility to enter more labels/values under 'Languages', so i.e. OCCU comes to look like this in the database: 'Danish-UTF8|Erhverv|English-UTF8|Occupation'. I don't know, why I have not seen this a long time (years) ago. It is a really ideal and simple opportunity. I had a great evening with Google Translate and the events 😎

Darrin is so very kind to look into the problem that the TNG-site is suddenly not accessible at the moment. The error message is, that I should have changed some credentials from config.php. I definitely haven't, and I have checked that file 100 times. My web host support can access the database with the credentials, I use. So the error message does not make sense. Unfortunately it is not possible to set TNG in debug mode. Before that error showed up, the following happened, which is what I wrote to Darrin:

"My GEDCOM folder was not present (it is empty, as I for security reasons always delete the file after import). I got the message, that the the folder gedcom_hanne was missing. I tried to re-establish it by entering 'gedcom_hanne' in the empty field just below where the root path is defined. I thought that was the correct way to re-establish the folder. I do not a gedcom-folder in the list of default folders below.

I have NOT changed anything with the database settings, and I have checked in config.php at the top that I still have the correct informations."

Kind regards,
Hanne

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×