Jump to content
TNG Community
Carswell

Google maps not loading

Recommended Posts

Carswell

I've had Google maps for about four years on my site. Yesterday, when looking at  individual, pages  the map appears briefly then disappearsagain. the message read "This page didn't load Google Maps correctly. See the javascript console for technical details"

I'm not sure what the javascript console is. The API key is installed and is current

 

Screenshot attached

 

Screenshot 2021-03-16 at 14.03.34.png

Share this post


Link to post
Share on other sites
theKiwi

This is almost certainly due to you not have your Google account set up properly with a credit card attached to it for charging.

They will almost certainly never charge you, but they need to know that they can if need be. Take a look at this page

https://tng.lythgoes.net/wiki/index.php?title=Google_Maps_-_Getting_Started

If that's not the problem, then post a URL to a page on your site that shows this problem

Roger

Share this post


Link to post
Share on other sites
Carswell

Thanks very much for your reply and the link. It turned out that the two APIs, Geocoding and Maps Javascript were not enabled, although it had been working up to a few days ago. Payment method was up to date. Bit of a mystery but all sorted now. 

Share this post


Link to post
Share on other sites
shajra

I am having the same problem... I have them enabled but I am still getting the same error. Any ideas on how to fix it?

Share this post


Link to post
Share on other sites
Rob Severijns

Shajra,

Has it previously worked?

Could you post a link to your website too so we can have a look and see what might be wrong.

I guess you did read the Google Maps - Getting Started ? 😉

Rob

Share this post


Link to post
Share on other sites
shajra

Not sure why it's throwing this error because I had set it to this earlier: *.shajraenasab.com/* 

but just added /getperson.php too

image.png

Share this post


Link to post
Share on other sites
DeniseP

I am having the same issue. I had taken down my website 2 years ago. I downloaded the most current version of TNG and followed the instructions for the Google Cloud Console, API, etc. I am using an API created in 2018. Everything seems enabled; I have the billing account set up; payment information available but I get the same "blink" of the map, then the error above. HELP!

 

https://barrett-radfordgenealogy.com/placesearch.php?psearch=Alhambra%2C+Alberta%2C+Canada&tree=BarrettRadford

Share this post


Link to post
Share on other sites
bhemph

Denise,
     You are getting a console error RefererNotAllowedMapError your site https://barrett-radfordgenealoty.com needs to be authorized.  I tried changing the address to https://www.barrett-radfordgenealogy.com to see if that made any difference and I received the same message about it not being authorized.  You need to make sure that you have both ways listed in your allowed sites list in Google, since sometimes the * can be confusing as to exactly what is the right usage.  Also make sure that you have https and not the old http, since that is seen as a different address.  You can always post a screenshot like shajra did of the site list from the Google Cloud Console.

Brent

Share this post


Link to post
Share on other sites
DeniseP

Hi Brent,

I was just coming online to say I had added the * and the issue seems to be resolved. I will go back and add the other address forms.

Thanks!

Denise

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×