Jump to content
TNG Community
bouigas

OpenStreetMap simple installation procedure

Recommended Posts

bouigas

Hello 

This is my problem
1 I am not very used to handling the English language
2 I do not have a solid computer training
3 I really like working with TNG and have been doing so for years since v9 today I am at v13.0.1
4 I would like to find a simple procedure to apply to be able to use an Openstreetmap geolocation

Is it possible?

Regards

 

Share this post


Link to post
Share on other sites
XerxX

Hi bouigas,

 

If you want to know how to geolocate single places in OSM, I think it's quite clearly explained in the Wiki:

https://tng.lythgoes.net/wiki/index.php?title=OpenStreetMap#Geocoding_.28Add_and_Edit_place.29

If you have specific questions about that, you can ask them here. I will watch this thread.

If you want to batch geolocate places, you can use the mod OSM Automatic Geocoding by Michel Kirch:

https://tng.lythgoes.net/wiki/index.php?title=OSM_Automatic_Geocoding

 

Best regards,

Erik

Share this post


Link to post
Share on other sites
stores

bouigas,

Another option is the Geocode Assist Mod https://tng.lythgoes.net/wiki/index.php?title=Geocode_Assistant this mod places a globe image next to places that have not been geocoded when you are looking at a persons page. Clicking the globe, next to the place, takes you to the GeoCode page and after you GeoCode the place, it returns you to the persons page.

Share this post


Link to post
Share on other sites
Michel KIRSCH
1 hour ago, stores said:

Another option is the Geocode Assist

I wrote the OSM Automatic Geocoding Mod ... And always uses the Geocode Assist Mod :-)

The difference is that Geocode Assist shows you which places are not geocoded. OSM Automatic do it for you "on the fly" each time a new place is added. Or in batch if there are many places to geocode. Be sure your Setup/General Settings/Miscellaneous/ Geocode all new places:  option is set to Yes

Michel

Share this post


Link to post
Share on other sites
bouigas
Sur 10/03/2021 at 09:10 , XerxX said:

Thank you Erik 

I am a beginner on this place Mod is unknown land for I.

Help me at least  once time afterwards I could do alone

This my situation now  on my website https://www.pasquin.org/ in TNG V13.0.1

and on the below file cfg  I have noted too "OSM" in configuration

Where is my error?

Regards

%name:openstreetmap%

%version:v13.0.0.7b%

%description:<p style='color:red; background-color:yellow;'><br/>

% target: /getperson.php?personID=I14&tree=tree1 %
 %location:51.442479488418556 , 31.464157104492188 %
 %finir:%
 

 

Hi bouigas,

 

If you want to know how to geolocate single places in OSM, I think it's quite clearly explained in the Wiki:

https://tng.lythgoes.net/wiki/index.php?title=OpenStreetMap#Geocoding_.28Add_and_Edit_place.29

If you have specific questions about that, you can ask them here. I will watch this thread.

If you want to batch geolocate places, you can use the mod OSM Automatic Geocoding by Michel Kirch:

https://tng.lythgoes.net/wiki/index.php?title=OSM_Automatic_Geocoding

 

Best regards,

Erik

 

Share this post


Link to post
Share on other sites
XerxX

Hi bouigas,

If what you copied above is the beginning of your file openstreetmap_v13.0.0.7b.cfg something is very wrong.

The beginning shall look like this:

Quote

This is a TNG mod directive file
%name:OpenStreetMap%
%version:v13.0.0.7b%
%description:<p style='color:red; background-color:yellow;'><b>In a change from previous version of OpenStreetMap, you must start your map key with "OSM" to get TNG to use OSM.</b><br/>
You can leave your google key in the map key field <i>after</i> "OSM". <i>(Do not use quotes)</i>
</p><p>

The %target: line for getperson.php shall be way further down and look like this

Quote

%target:getperson.php%

Nothing more (no slash and no person ID/tree...)

And this, that you copied:

37 minutes ago, bouigas said:

%location:51.442479488418556 , 31.464157104492188 %
 %finir:%

I have absolutely no idea where it comes from.

When I go to your site, I get the feeling that the mod is not installed. Correct?

If it's not installed AND the above was copied from the file openstreetmap_v13.0.0.7b.cfg , I suggest that you replace it by the attached file.

Or maybe I misunerstand something?

/Erik

openstreetmap_v13.0.0.7b.cfg

Share this post


Link to post
Share on other sites
bouigas
Il y a 4 heures , XerxX said:
Il y a 4 heures , XerxX said:

Hi bouigas,

If what you copied above is the beginning of your file openstreetmap_v13.0.0.7b.cfg something is very wrong.

The beginning shall look like this:

The %target: line for getperson.php shall be way further down and look like this

Nothing more (no slash and no person ID/tree...)

And this, that you copied:

I have absolutely no idea where it comes from.

When I go to your site, I get the feeling that the mod is not installed. Correct?

If it's not installed AND the above was copied from the file openstreetmap_v13.0.0.7b.cfg , I suggest that you replace it by the attached file.

Or maybe I misunerstand something?

/Erik

openstreetmap_v13.0.0.7b.cfg

 

Il y a 4 heures , XerxX said:

Hi bouigas,

If what you copied above is the beginning of your file openstreetmap_v13.0.0.7b.cfg something is very wrong.

The beginning shall look like this:

The %target: line for getperson.php shall be way further down and look like this

Nothing more (no slash and no person ID/tree...)

And this, that you copied:

I have absolutely no idea where it comes from.

When I go to your site, I get the feeling that the mod is not installed. Correct?

If it's not installed AND the above was copied from the file openstreetmap_v13.0.0.7b.cfg , I suggest that you replace it by the attached file.

Or maybe I misunerstand something?

/Erik

openstreetmap_v13.0.0.7b.cfg

 

 

Il y a 4 heures , XerxX said:

If what you copied above is the beginning of your file openstreetmap_v13.0.0.7b.cfg something is very wrong.

The beginning shall look like this:

The %target: line for getperson.php shall be way further down and look like this

Nothing more (no slash and no person ID/tree...)

And this, that you copied:

I have absolutely no idea where it comes from.

When I go to your site, I get the feeling that the mod is not installed. Correct?

If it's not installed AND the above was copied from the file openstreetmap_v13.0.0.7b.cfg , I suggest that you replace it by the attached file.

Or maybe I misunerstand something?

/Erik

openstreetmap_v13.0.0.7b.cfg

 

Share this post


Link to post
Share on other sites
XerxX

What? I don't understand: You copied my reply three times but wrote nothing...

When you mark something someone has written and click "Quote" it's copied to the input box.

Then click outside the quote but still inside the input box and you can enter text separate from the quote.

/Erik

Share this post


Link to post
Share on other sites
bouigas

Sorry Erik
I am not yet aware of your practices;

I can't move forward, however much I put your cfg file.
Could you not give me an example file so that I finally understand this type of programming.
Can I see an example on a site
You should know that I do not handle the English language in the text too.

I have attached 2 screenshots and the file cfg  

Location Laseyne is my city of birth 

Regards

 

 

2021-03-11_10-12-12.jpg

2021-03-11_19-46-46.jpg

file-cfg.txt

Share this post


Link to post
Share on other sites
XerxX

Hi bouigas,

Do like this: Go to Administration

Click Gestionnaire Mods:

ModManager.jpg

Click row OpenStreetMap:

OSM1.jpg

Click Installer:

Install.jpg

All done!

OSM2.jpg

 

I hope this helps.

It's 2:20 AM here now so I have to sleep. See you later!

Erik

 

Share this post


Link to post
Share on other sites
Ken Roy

you should not need to understand the programming.  In order to use the Mod Manager to install mods to TNG, you need to save the .cfg file and any associated folders that are part of the mod zip file in the TNG mods folder name as defined in your Admin > Setup > General Settings for the mods folder path name in the Paths and Folder section

The mod should then show as OK to Install when you go to the Admin > Mod Manager screen which defaults to the Mod List tab.  If the status of the mod does not show OK to Install then you need to expand the status column for that mod and find the error that prevents the mod from installing, which could be a Bad Target if you have a conflict situation or you are trying to install the wrong version of the mod, or Source Missing which most often means you copied the mod folder content to the mods folder rather than copying the folder to the mods folder as a subfolder.

The OSM key is only required in the Maps Settings once the mod is installed, not before

Share this post


Link to post
Share on other sites
Ken Roy

see Erik's reply with screen captures

Share this post


Link to post
Share on other sites
XerxX

Ken, It looks from his screenshot that the file and the directory is placed in /mods/ and "OSM" is entered in the map settings.

So I think it's a simple install. As I describe.

'nite!

Erik

Share this post


Link to post
Share on other sites
Ken Roy

Good night Erik,

I agree.  I think users are getting confused that OSM is required to install the mod when it is only required to use the OpenStreetMap once the mod is installed.  I use both Google Maps and OpenStreetMap so I have to change the Google Maps key to OSM or OSM+Google API key when I want to use your mod. 

Share this post


Link to post
Share on other sites
XerxX

bouigas, you must NOT change anything in the file openstreetmap_v13.0.0.7b.cfg that I attached above! NOTHING!

Just put the file in the mods folder as it is and then follow my instructions.

/Erik

Share this post


Link to post
Share on other sites
XerxX

Ken, I suspect it may be worse than that. I looked back and his screenshot shows that the .cfg is 1K - should be 40.

I suspect he has tried to enter coordinates into the .cfg..?

/Erik

Share this post


Link to post
Share on other sites
bouigas

Thank you at all together 

My problem is solved now. It was an upgrade mod managers problem

Regards

 

Share this post


Link to post
Share on other sites
Michel KIRSCH
13 hours ago, XerxX said:

I suspect he has tried to enter coordinates into the .cfg..?

may be.. And delete all the cfg contents after the %description:% statement (See his file_cfg.txt file above...)

Ange, tu peux toujours t'exprimer en français si tu as plus facile, mais veille toujours à fournir en même temps la traduction anglaise sur le forum.
Je te recommande d'utiliser DeepL traductions en ligne.

Ange, you can always express yourself in French if it's easier for you, but always make sure to provide the English translation on the forum at the same time.
I recommend you to use DeepL, online translations on DeepL

Michel

Share this post


Link to post
Share on other sites
XerxX

@bouigas

58 minutes ago, bouigas said:

My problem is solved now.

Great!

46 minutes ago, Michel KIRSCH said:

Ange, tu peux toujours t'exprimer en français si tu as plus facile, mais veille toujours à fournir en même temps la traduction anglaise sur le forum.
Je te recommande d'utiliser DeepL traductions en ligne.

What Michel said ;-)

 

@Michel KIRSCH

47 minutes ago, Michel KIRSCH said:

(See his file_cfg.txt file above...)

Yes,  that's what I (finally) did because the screenshot showing the /mods/ dir, showed that the .cfg was only 1K instead of like 40K. Hence my "...you must NOT..." post above.

 

Best regards,

Erik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×