Jump to content
TNG Community
jodrexel

SOSA mod, SOSA number display at wrong position

Recommended Posts

jodrexel

On my persons pages the SOSA number appears between birth and baptism date and not after the name. Does anyone know how to change this.

My Mods:

image.png

Share this post


Link to post
Share on other sites
Michel KIRSCH

Guten tag Joachim,

the code of sosa must be placed just after the Name field on the  "getperson.php" page

Probably one of your mod is installed after sosa and takes 'its' place...

uninstall sosa and reinstall it. It will take its place after the Name field.

Michel.

PS : If you continue to use Sosa, don't forget to fill in the fields on the wiki page
 https://tng.lythgoes.net/wiki/index.php?title=Sosa#Sites_using_this_mod

Thanks

 

 

Share this post


Link to post
Share on other sites
jodrexel

Hello Michel,
I have reinstalled the mod, unfortunately with the same result.
I attach my getperson.php, maybe that will help you.

getperson.php

Share this post


Link to post
Share on other sites
Michel KIRSCH

Very very curious...

Assume that your getperson.php page is with the Sosa Mod installed?

I change the location of the sosa code...

getperson.php

Share this post


Link to post
Share on other sites
jodrexel

Hello Michel,
first of all thank you very much for your quick help. The SOSA number is where it should be.
However, the wrong entry is also still there.🙁

image.png

Share this post


Link to post
Share on other sites
Michel KIRSCH

Ah OK ! I understand now ! It's a double installation....

1. uninstall all your mods.

2. copy a frech version of your getperson.php file from your  TNG files

3. reinstall your Mods

OR ... uninstall sosa and make a manual cleaning of all sosa code snippets... If you can (?)

OR ... uninstall sosa THEN send me your getperson.php file

Michel

Share this post


Link to post
Share on other sites
jodrexel

Hello Michel,
I did steps 1 - 3, the SOSA number was again between birth and baptism date.
I have now uninstalled SOSA, the getperson.php is attached.

getperson.php

Share this post


Link to post
Share on other sites
Michel KIRSCH

Joachim,

I replace my getperson.php file with yours.

I've installed Sosa : no problem...

Try this to determine which Mod is causing the trouble :

1. uninstall all your Mods

2. install Sosa alone - Check the getperson page.

3. reinstall your mods one by one and check getperson after each install.

When Sosa is misplaced : this is the Mod....

Say me which Mod it is.

Michel

Share this post


Link to post
Share on other sites
jodrexel

Hello Michel,
I have uninstalled all mods, then installed sosa and the error occurs

Share this post


Link to post
Share on other sites
Michel KIRSCH

I look and see on your site...

OK. I don't understand at all what's going wrong... I'm going to call the team!
Send me your getperson.php file with ONLY the Sosa Mod installed.
In the meantime, I will send you back your file with the Sosa code in the right place.
Michel



 
  •  

Share this post


Link to post
Share on other sites
Michel KIRSCH

Can you send me a temporary Administrator account on your site?

Mail it to : genealogie AT mkirsch.be

Michel

Share this post


Link to post
Share on other sites
jodrexel

Hello Michel,
first of all thank you for your efforts. attached the getperson.php

getperson.php

Share this post


Link to post
Share on other sites
Michel KIRSCH

This is your file...

I recontact you when I have news...

Michel

getperson.php

Share this post


Link to post
Share on other sites
jodrexel

thank you, administrator account is on its way

Share this post


Link to post
Share on other sites
Michel KIRSCH

OK Thanks.

I will check that tomorrow...

Michel

 

Share this post


Link to post
Share on other sites
jodrexel

Addendum


Hello Michel,
I installed the returned getperson.php and then all the mods and now everything is correct. 👍😀

Share this post


Link to post
Share on other sites
Michel KIRSCH

Yes, but don't uninstall / Reinstall Sosa...

Will check for a solution for you in the next upgrade...

I maybe do some tests on your site tomorrow...

Gute nacht !

Michel

Share this post


Link to post
Share on other sites
Michel KIRSCH

For information there is an option to show/hide the sosa number in the fields of getperson.php

Share this post


Link to post
Share on other sites
Michel KIRSCH

Joachim,

last try :

1) uninstall sosa (you can make a copy of your getperson.php file before...)

2) in your mods folder, replace the "sosa_mod_v13.0.1.7d.cfg" file by the "sosa_mod_v13.0.1.7e.cfg" attached below.

Then reinstall sosa.

Michel

sosa_mod_v13.0.1.7e.cfg

Share this post


Link to post
Share on other sites
Michel KIRSCH

Joachim,

I see that you've deleted your mods/sosa7d folder !

I sent you a complete version of sosa 7e (with sosa7d folder) to your mail (joachim@drexelxxxx)

Michel

Share this post


Link to post
Share on other sites
jodrexel

Hello Michel,

I have installed the ....7e.cfg and everything works as it should. Thanks again for your support.

Share this post


Link to post
Share on other sites
Michel KIRSCH

You're welcome.

This modif will be integrated in the next version of sosa.

Michel

Share this post


Link to post
Share on other sites
MichaelM

Hi Michel,

may be, i have the same phenomen, but, i do not care about it.

The Soso-No.  is shown after the birth date.

No Problem for me.

image.png

Share this post


Link to post
Share on other sites
Michel KIRSCH

Hi Michael,

Very wierd. Do you have others Mods installed?

Is it the same if  Sosa is the only installed Mod?

Michel

Share this post


Link to post
Share on other sites
Michel KIRSCH

maybe a problem in upgrade.

Michael, Joachim,

Which version of TNG do you use?

From which version do you upgrade to the actual version.

Can you send a screenshot of your files concerning the Mod handler (like this one, with "blue" files)

Michel

 

mod handler files.JPG

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×