Jump to content
TNG Community
^maikl11

Unicode Hex Character Code

Recommended Posts

^maikl11

I am using TNG 13.0.3, template 12!
under Setup >> Configuration >> Template Settings
I enter the following in "Left image caption":

....<center> Family Landgraf and Eckart from Hawaii in 1905
<br> <hr> <hr> <div class = "header"> Info </div> <br> </center> <hr>
<! - Start Log In button (Language Switching) ->
</p> <div class = "mybutton smallbutton"> <a href="login.php"> &#x1f512; Login </a> </div> <! - End Log In button–>
<! - Start Register button (Language Switching) ->
<div class = "mybutton smallbutton"> <a href="newacctform.php"> &#9998; Register </a> </div> <! - End Register button–> </center> <! - Start suppress login and registration chapter once user logged in–>.....

So far so good!
If I now go to save, the index page is completely shifted!
I know it has to do with these characters (& # x1f512; and & # 9998;, (because as soon as I leave it out, everything is saved))
How can I elegantly solve this so that these symbols remain ???
I would be grateful for a solution! Thank you!

Share this post


Link to post
Share on other sites
RickM

Your page appears to load correctly in Firefox (Windows 10 environment). I see what looks like some extra text per snippet attached.

landgraf.jpg

 

Your comments are not correct per html standard and there are a couple of tags that are closed without an open one </p> and one </center>. I have taken the liberty and cleaned your code up as below.

<center> Family Landgraf and Eckart from Hawaii in 1905
<br> <hr> <hr> <div class = "header"> Info </div> <br> <hr>
<!-- Start Log In button (Language Switching) -->
<div class = "mybutton smallbutton"> <a href="login.php"> &#x1f512; Login </a> </div> <!-- End Log In button -–>
<!-- Start Register button (Language Switching) -->
<div class = "mybutton smallbutton"> <a href="newacctform.php"> &#9998; Register </a> <!--End Register button --></div></center>
<!-- Start suppress login and registration chapter once user logged in -–>

If there is further code maybe recheck it for correct syntax etc..

 

Share this post


Link to post
Share on other sites
^maikl11

Thank you ... I have now downloaded Microsoft Expression Web and it showed me even more errors!
I removed the hex code and replaced it with a picture!

This is what the code looks like now and it is stable!

<div class="mybutton smallbutton">
    <a href="login.php">
    <img alt="" height="20" src="img/schloss.png" width="15" />  Anmelden </a></div>
<div class="mybutton smallbutton">
    <a href="newacctform.php">
    <img alt="" height="17" src="img/account.png" width="20" />  Neues Benutzerkonto 
    </a></div>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×