Jump to content
TNG Community
mahesh

Revert to media-4_tooltip mod

Recommended Posts

mahesh
20 hours ago, Ken Roy said:

The Convert Selected To is supposed to move the media files.

Just a quick note to say that the above only seems to work if the media was not converted during install - upgrade. It looks like each image has to be, manually, adjusted by removing the new map and pasting the original.

I will try this tomorrow.

Share this post


Link to post
Share on other sites
Ken Roy
41 minutes ago, mahesh said:

Just a quick note to say that the above only seems to work if the media was not converted during install - upgrade. It looks like each image has to be, manually, adjusted by removing the new map and pasting the original.

Mahesh,

If the image maps have been converted, then you likely need to do steps 8 and 9 in

 

Share this post


Link to post
Share on other sites
mahesh
7 minutes ago, Ken Roy said:

Mahesh,

If the image maps have been converted, then you likely need to do steps 8 and 9.

 

Yep, worked that out.  Procedure below,  works for me.

If the  image maps already converted,

1 - Convert Image to the photo group.
2 - Move / copy the image from photos to the new group. ( I copy, just to be safe, I will delete later)
3 - Go to edit media and selct the image as it will still be pointing to photos directory.
4 - Save and stay on the page.
5 - The image will now show. Go to image tag and do step 9.
6 - Media topoltip should now display.

Two observations.

1 - There seems to be an issue with 13.0.2. If the image maps are already converted, Convert Selected to updates the database but does not move the image(s) to new folder
2 - Personally, I really prefer the tooltip display of tags - Clean 😊
 

 

 

Share this post


Link to post
Share on other sites
mahesh
On 3/5/2021 at 5:39 PM, mahesh said:

Yep, worked that out.  Procedure below,  works for me.

If the  image maps already converted,

1 - Convert Image to the photo group.
2 - Move / copy the image from photos to the new group. ( I copy, just to be safe, I will delete later)
3 - Go to edit media and selct the image as it will still be pointing to photos directory.
4 - Save and stay on the page.
5 - The image will now show. Go to image tag and do step 9.
6 - Media topoltip should now display.

Two observations.

1 - There seems to be an issue with 13.0.2. If the image maps are already converted, Convert Selected to updates the database but does not move the image(s) to new folder
2 - Personally, I really prefer the tooltip display of tags - Clean 😊

 

Adding my final observations to the above:

I carried out the above procesure on my live, production, site where the images were converted during upgrade to V13.0.2.
The database had been backeded up using admin>utilities before upgrade.

1 - Looking at the database, 'map' information was erased from the media table. I checked the backup file and 'map' details were there.

2 - Time stamp for DB change for  tng_media were same as timestamp for tng_image_tags.

3 - Restore DB from admin>utilities worked fine.

4 - I had only about 35 images to convert and that worked fine.

5 - Images had to be physically moved to new collection.

6 - Moral: Always backup 

7 - My sincere thanks to Ken for guiding me through this procedure.

 

Share this post


Link to post
Share on other sites
Ken Roy

Thanks Mahesh,

I still have not had a chance to create the TNG Wiki article.

everyone should take a look at the TNG Wiki Data Protection category  There are several articles worth reading, including software backup

Share this post


Link to post
Share on other sites
Ken Roy

Mahesh,

I finally got around to creating the TNG Wiki article on Reverting Image Tags back to Image Maps with image captures as I was rebuilding my WampServer environment.

Please verify that I did not overlook something.

Thanks

Share this post


Link to post
Share on other sites
mahesh
19 hours ago, Ken Roy said:

Mahesh,

I finally got around to creating the TNG Wiki article on Reverting Image Tags back to Image Maps with image captures as I was rebuilding my WampServer environment.

Please verify that I did not overlook something.

Thanks

Thank you, Ken.

That is great and very well illustrated.

This is not really necessary but as I tend to forget and make mistakes, as belt-n-braces method, I copied all the image tags (I only had 35 ) in a text file, before I started: just in case.

Share this post


Link to post
Share on other sites
Ken Roy

Mahesh,

Feel free to update the TNG Wiki article.

One note of caution is assigning the local path to the group collection.  Darrin talks about escaping \ (backslashes) in the path name.   I created the path using / (forward slash).  I ran into an issue where the path name is not being passed to the Export process.  I cannot verify whether it works with forward slashes on import since I do not import media and my attempt to export my TNG media links to import into another program did not work.

I will update the screen captures when I know the correct answer to get the export to work correctly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×