Jump to content
TNG Community
theKiwi

Search for Connections Mod

Recommended Posts

klooster

This is how it looks on my website, with my integration method of course, I tweaked the css colors, background etc.

Kloosterman example

Looks oké to me.

953FBC0F-9F8F-47CB-A3F7-DF931673C221.png

953FBC0F-9F8F-47CB-A3F7-DF931673C221.png

Share this post


Link to post
Share on other sites
mjaro
6 minutes ago, klooster said:

Looks oké to me.

Looks great, even better than in my own site  🤔 

(Sorry for the previous advice, it didn't make much sense.)

Congrats!

Michał

 

 

Share this post


Link to post
Share on other sites
theKiwi
1 hour ago, tngrlkrz said:

Have any of the other folks on this thread set error logging for warnings and able to confirm what Ken and I see?

 

I just turned on E_ALL and to load my testing page generated 6,203 errors like this

[Tue Feb 23 13:08:24 2021] [error] [client 96.42.131.218] PHP Stack trace:
[Tue Feb 23 13:08:24 2021] [error] [client 96.42.131.218] PHP   1. {main}() /Library/WebServer/Documents/TNG_WordPress/tng_13.0/connections.php:0
[Tue Feb 23 13:08:24 2021] [error] [client 96.42.131.218] PHP   2. include() /Library/WebServer/Documents/TNG_WordPress/tng_13.0/connections.php:27
[Tue Feb 23 13:08:24 2021] [error] [client 96.42.131.218] PHP Warning:  Invalid argument supplied for foreach() in /Library/WebServer/Documents/TNG_WordPress/tng_13.0/connections-graph.php on line 79

i.e. a block of lines like this 6,203 times.

Roger

Share this post


Link to post
Share on other sites
Ken Roy
4 hours ago, mjaro said:

Ken, I believe this can occur only if there is an inconsistency in the database Maybe someone started adding a family and the session was broken? Maybe there is a family of 0 persons (containing neither a pair nor a single) ?

I you uncomment line 82 and run the program (i.e., enter Connections tab) you will see a looong text showing "parent-child" pairs, and in one place you will see the warning you mentioned. Maybe you can then detect which family ID is suspected (see previous and next parentID).

Or you could export gedcom and send it to me? 

No better idea so far :( 

Michał

Michal,

If you implement the change that Michel Kirsch recommended above in

It eliminates the warning errors that I am seeing.   As Michel indicated not all families have children. 

Michel's fix was tested in your v4 connections-graph.php

Share this post


Link to post
Share on other sites
mjaro

Michel, Ken, Roger, Ron, and Kare.

You are all right (especially Michel, of course)

For the next mod sub-version I'll include the corrected file. I've made also some additional internal checkings to avoid wornings.

Imagine, I couldn't see any warnings because my hoster doesn't allow me to change server settings. Fortunately, Kare sent me a more detailed log of warnings, and tested corrected file version.

Thank you all and I'm sorry it took so long.

Michał

Share this post


Link to post
Share on other sites
Ken Roy

Michal,

You should take a look at the following 2 mods

  • Prolog mod which has an Edit Option that llows you to change the error reporting level
  • Show PHP Error Log I often change the mod to point to the Apache error log on my WampServer environment

I use both mods.  There is a link in the second mod on instructions on how to setup your php.ini overrides to capture the PHP error log

The mods are necessary when you do not have access to your server PHP error log

Edited by Ken Roy
fix senternce

Share this post


Link to post
Share on other sites
Michel KIRSCH

Michal,

I've followed Ken's advice some months ago : The Prolog Mod has changed my life !

Michel

Share this post


Link to post
Share on other sites
mjaro

Ken, Michel,

I'm now apprentice on both mods. I feel better and better... but the "learning curve" is going to be looong ;)  (as Ron commented some time ago).

Thank you for advice, the results will be visible ...after time!

Michał

Share this post


Link to post
Share on other sites
mjaro

The next mod update is almost ready.

Some modifications I made:

  • mod option for diplaying gender icons in boxes;
  • legend for bullets;
  • parameters saved for the session time;
  • Wordpress compatibility improved: gender icons in boxes, no PHP warnings, summary message format

Some languages need 3 additional sentences (Dutch, French, German)

I attach zip file. I'll be grateful if someone could look if it works not only on my site. I believe it should work OK, but I know it is a rare case...

Michał

Connections_v13.0.3.4a.zip

Share this post


Link to post
Share on other sites
fluffy82
59 minutes ago, mjaro said:

I'll be grateful if someone could look if it works not only on my site.

It works fine here 😄

The new file with the extra lines in attachment.

I have one tiny weird thing...

The two people who are to be compared. The first one says: "born day month year". The second one just says "day MONTH year" (without the word "born", and with the month in capital letters). Shouldn't that format be the same? It's not because of my database, it is the same with whatever person I use.

Dutch-UTF8_custtext_NEW_20210224.php

persoon.PNG

Share this post


Link to post
Share on other sites
ton van lil

Everything works.

 Only the gender symbols are streched.

image.png

 

image.png

Share this post


Link to post
Share on other sites
theKiwi
1 hour ago, mjaro said:

I attach zip file. I'll be grateful if someone could look if it works not only on my site. I believe it should work OK, but I know it is a rare case...

Here it is on my testing site, with my over-rides for font and colours and the star instead of bullet

image.png

http://tngwp.lisaandroger.com/genealogy/connections.php?altprimarypersonID=&savedpersonID=&secondpersonID=I1&maxR=99&showTxt=true&showPic=true&sortpathsby=length&maxL=33&showGend=true&primarypersonID=I16&tree=Roger&s=

This is the WordPress site and it's working fine there.

Cheers

Roger

Share this post


Link to post
Share on other sites
fluffy82
5 minutes ago, ton van lil said:

Only the gender symbols are streched

Must be something from your side, they look fine here...

icons.PNG

Share this post


Link to post
Share on other sites
theKiwi
11 minutes ago, ton van lil said:

 Only the gender symbols are streched.

 

Clear your cache, or force reload the page a couple of times should fix that - the css isn't right.

Roger

Share this post


Link to post
Share on other sites
mjaro
8 minutes ago, theKiwi said:

This is the WordPress site and it's working fine there.

Great! Thanks for testing and translation.

I know the reason of the differences you noticed: for the primaryperson there is different TNG function used then for remaining persons (this is the way Relationship tab uses and I followed). I'll make it identical, good idea!

Michał

Share this post


Link to post
Share on other sites
theKiwi

I did notice on my site that it doesn't seem to respect the setting for showing the thumbnail - if I set that option to false , it still shows the thumb image?

Roger

Share this post


Link to post
Share on other sites
Michel KIRSCH

Same as Roger for me. (after refresh the cache too)

Michel

(Bed time : good night everybody !!)

 

Share this post


Link to post
Share on other sites
mjaro
2 minutes ago, Michel KIRSCH said:

French translations in attach

Thanks Michel - and have you run the mod? Is it working for you?

Share this post


Link to post
Share on other sites
mjaro
3 minutes ago, Michel KIRSCH said:

Same as Roger for me. (after refresh the cache too)

Michel

(Bed time : good night everybody !!)

 

You are right, again ;)  Good night!

Share this post


Link to post
Share on other sites
tngrlkrz
2 hours ago, ton van lil said:

Only the gender symbols are streched

They will look like that until you refresh and clear your cache.

2 hours ago, theKiwi said:

it doesn't seem to respect the setting for showing the thumbnail

Thumb option is working for me OK,....

But when I choose no gender icons, icons are removed, but  getting 3 'x's after all person names except start person, with or without the gender icons.  In connections.php, looks like some sort of place filler is not getting replaced, since 'xxx' literal is in several code lines.  Is there something I missed doing?  Cache cleared after install, and after any change to edit options.

image.png

image.png

Lastly, seeing a shadowed vertical bar where the person has no image, and thus no thumb to display.

image.png

All testing without any private changes. TNG 13.03.  Happens on all templates I tried.

Share this post


Link to post
Share on other sites
theKiwi
3 hours ago, Michel KIRSCH said:

Same as Roger for me. (after refresh the cache too)

OK I figured out what's happening - the showPic=true is part of the URL, and if you change the setting and refresh the page it won't pick up the change in the setting because the setting is in the URL. But if you change the setting and then enter the page again from a new search, then it the setting is respected.

Roger

Share this post


Link to post
Share on other sites
tngrlkrz
50 minutes ago, theKiwi said:

enter the page again from a new search

Ahh.  I guess that's what I have done early on in testing, after I noticed it didn't take the settings with a reload, is to click the connection tab again.   I mistakenly thought you were saying the thumb setting to false in Edit Options wasn't working.

Have you tried removing the gender icons in Edit Options?  That's when I get the 'xxx's.  Though I plan to always have them.

Share this post


Link to post
Share on other sites
theKiwi
31 minutes ago, tngrlkrz said:

Have you tried removing the gender icons in Edit Options?  That's when I get the 'xxx's.  Though I plan to always have them.

Yes I get the same thing  - the starting person's box is OK, but all the rest have the xxx

image.png

Roger

Share this post


Link to post
Share on other sites
mjaro

Apologies to everyone for the stupid "xxx" - an intermediate edition had replaced the final one 😞. (thamks to Ron for detecting!)

Other anomalies need more investigations...

Michał

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×