Jump to content
TNG Community
theKiwi

Search for Connections Mod

Recommended Posts

mjaro

Ron, and Roger,

forgive me, please, my nomenclature imperfectness. I've even checked the wikipedia and know that TNG "sprite" is what is commonly used for such construct. BTW my mod is adding one sprite at the very end:

If you accept the way I'm displaying gender symbols or give me directions, I'll finish the feature tomorrow (there is midnight here) - so have a good night.

Michał

tng_small_icon_sprites.gif

Share this post


Link to post
Share on other sites
theKiwi
11 minutes ago, mjaro said:

If you accept the way I'm displaying gender symbols or give me directions, I'll finish the feature tomorrow (there is midnight here) - so have a good night.

 

My suggestion would be to use the same two icons that TNG uses - img/tng_male.gif and img/tng_female.gif

Roger

Share this post


Link to post
Share on other sites
tngrlkrz
13 hours ago, mjaro said:

Ron, please check if it is what you expect. (just copy the file to the root and replace the previously copied by the mod).

I will add proper colors, and maybe make the symbold more "bold"? I wonder how to deal with no-man no-women: use neutral gender symbol, or leave it empty (I see there are more and more people getting it into account...)

connections.php

Yes,  Michal, those look good.  But as Roger suggests, the TNG gifs are there and are already colored and accessed with the  'function getGenderIcon($gender, $valign)'  within globallib.php, but for some reason the size came out wrong when I tried the other day.  I don't see any bolding of the gif.

 

Share this post


Link to post
Share on other sites
mjaro
13 hours ago, tngrlkrz said:

colored

Ron, OK, they are colored now - please find attached connection.php.

I've decided to not to use TNG function (BTW it is extremely simple) because it makes trouble (for me) to play with 2 images, and I use my own function (equally simple) which selects proper character (symbol) and makes it coloured. Probably a long-term solution could be to use the whole graphical TNG boxes but it results in a general recoding of the paths display

I'm ready to increase a bit the vertical space between boxes. Increasing it by 2-3 px seems to me should satisfy you. If you want to play with it please change in genstyle.css (possibly with your private mod):

#pathlist .paths {   then several lines down:

    border-spacing: 0 7px;   ----- here you can increase 7px to eg. 9px

Look only on the spacing! If you tell me your favourite spacing, then I'll change dependencies (this is too tricky to explain here).

Michał

P.S. I've also made whole boxes clickable - please check it.

connections.php

Share this post


Link to post
Share on other sites
tngrlkrz

Michal,

Left to Right in snapshot below.

1.Left ,Your gender colors and 7px spacing

2.Next instead tried color:#3333ff and color:#ff3300,  red a bit more visible. Difficult with the default background because quite dark, this I would privately change to match templates and the gender icons would stand out more.

3.Next vertical spacing 10px

4.Right vertical spacing 9px

I think 10px spacing looks best.

 

2021-02-21_8-25-36.jpg

 

With lighter background, this is TNG's look: (11px*11px) size.

image.png

Share this post


Link to post
Share on other sites
mjaro
6 minutes ago, tngrlkrz said:

the gender icons would stand out more.

I've initially tried to set simply "blue" and "red" but they seemed to me too distinctive...

I'll now trim css to 10px v-spacing. 

Share this post


Link to post
Share on other sites
tngrlkrz

IMO,  the 'blue' and 'red' look fine.

image.png

Share this post


Link to post
Share on other sites
mjaro
33 minutes ago, tngrlkrz said:

'blue' and 'red' look fine

Ron, then I'll use them and 10px in the next cfg.

Now I'm testing an option for not diplaying thumbs in boxes. I think it could be put in forms in place of "Max path length" which is hardly understandable for users... (maxL will still stay as the mod option, but not per-search as now). I'll send the updated files when finished.

Did you notice that boxes are clickable, and not only names inside? There were only a few jQuery words needed, it's power is fantastic!

Michał

Share this post


Link to post
Share on other sites
tngrlkrz

Yes!  I forgot to mention...that indeed is a nice feature, being able to click anywhere in the box.  An option for no thumbs or a compact chart would be great, as I mentioned early on.

Share this post


Link to post
Share on other sites
Ken Roy

Michal,

What changed that the small photos are no longer shown?

Edited - Disregard - I did not have my Default Photo Path mod installed, so it was not finding the photos

Edited by Ken Roy
answer my own quest

Share this post


Link to post
Share on other sites
fluffy82

I just installed the version that was uploaded today. Great job :)

Three remarks, however:

  • I see you didn't include the Dutch text file I sent last night yet; not a problem for me at all, but be aware that I made some corrections/improvements so what is online now is not entirely correct
  • for some reason, the gender icons are displaying in a weird way (see attachment)...
  • also something I could do myself, but it might be useful for others too so you might consider adding it to the main file: the text below the graphics ("longest path checked" etc) now consists out of 3 separate <p> blocks, without any distinction; on my personal website they are not displaying correctly, and there is no easy way to edit their location as changing any css for <p> will break it on other pages... --> It would be great if those <p>'s would be within their own distinguishable div (just like the ul of the graphic part is distinguishable from other ul's through the pathlist id and class)

Regards,
Tom

icons.PNG

Share this post


Link to post
Share on other sites
tngrlkrz

Michal,

With version 13.0.2.4,  I am not seeing what Tom is, but realize, for me, WP is not in the mix. The gender icons are displaying correctly with one exception (pictured).  The bolded subject person box, it drops down to the next text line.  I suspect its because of the bolding, and the slightly larger thumbnail perhaps. Otherwise the new option to display or not display the thumbs functions fine.  

The vertical spacing between boxes is nice, and the connector lines from top boxes extended properly as well.

I will try to submit Czech translations sometime this week.  German looks good!  And the bullet circle on the primary person is more visible, and the box click works too.

Nice job!

image.png

 

image.png

Share this post


Link to post
Share on other sites
theKiwi

@mjaro - here's mine - I've added a legend to it, and use a nice star for the starting person

 

This is version 13.0.2.4 from the Wiki

image.png

Roger

Share this post


Link to post
Share on other sites
fluffy82
16 minutes ago, tngrlkrz said:

I am not seeing what Tom is, but realize, for me, WP is not in the mix. The gender icons are displaying correctly with one exception (pictured).

It is probably a browser thing... I tried on Firefox, Chrome and Edge, and it gave me the same weird result every time. But on the Samsung browser they show like yours (no box and after the name in stead of in front).

On top of that, while Firefox doesn't display any thumbnails if there aren't any, Chrome displays a "missing file" image...

icons 2.PNG

icons 3.PNG

Share this post


Link to post
Share on other sites
tngrlkrz
2 minutes ago, theKiwi said:

use a nice star for the starting person

Roger,

The bullet is better, but your star is best!   I may use that.

Share this post


Link to post
Share on other sites
theKiwi

This is my site with WordPress involved (the above was the TNG site)

image.png

 

The gender icons are now all out of order in the text display, and as Tom showed, the icon now precedes the name, not come after it.

I haven't had a chance yet to look and see what is causing this.

Roger

Share this post


Link to post
Share on other sites
tngrlkrz
3 minutes ago, fluffy82 said:

It is probably a browser thing

Don't think it is browser related, the latest Chrome and Firefox work fine for me.

Share this post


Link to post
Share on other sites
fluffy82
1 minute ago, theKiwi said:

The gender icons are now all out of order in the text display, and as Tom showed, the icon now precedes the name, not come after it.

In my case, they show there because #pathlist img is set to "float: left". Disabling that puts the icons in the right spot, but messes up the thumbnail position.

icons 5.PNG

Share this post


Link to post
Share on other sites
fluffy82
2 minutes ago, fluffy82 said:

In my case, they show there because #pathlist img is set to "float: left". Disabling that puts the icons in the right spot, but messes up the thumbnail position. 

Setting img.emoji to float right and other img to float left resolves the thumbnail problem, but not the text problem.

icons 6.PNG

Share this post


Link to post
Share on other sites
theKiwi

I've revised to my private Mod which changes the colours, fonts, star, to now also remove the gender icon - that's tidied it up

image.png

 

Roger

Share this post


Link to post
Share on other sites
mjaro
2 hours ago, fluffy82 said:

I just installed the version that was uploaded today

Tom, it must be a mistake: I've never shared such a version that is using TNG gender icons!

I guess the mod was not uninstalled clean after your earlier experiments, and then old files couldn't be replaced by the ModManager. (also some other changes)

The cleanest way to go to proper versions of files:

1. Uninstal the mod again, and then "Delete" with ModManager

2. make sure that the old files don't remain at the TNG root level (connections.php and connections-form.php !)

3. make sure that the old mod directory is also deleted (either mods/connections_3a and/or mods/connections_4)

4. It is also possible that genstyle.css has not been cleaned by ModManger. If you can look at the end of it, make sure that connections' styles do'n't stay there, and possibly delete them.

5. Now you can copy the mod files and install.

When start using TNG after these steps, please clear browser cache!

Michał

Share this post


Link to post
Share on other sites
tngrlkrz

Michal,

I don't believe those icons/symbols are from TNG.  The ones from TNG look like the ones you're using.  I think those icons (and those in Rogers earlier snapshot) are from WordPress.

 

Share this post


Link to post
Share on other sites
mjaro
1 hour ago, theKiwi said:

I've revised to my private

Looks fine! I think there are more users might also want to apply your mod !

It's also a great idea to give a explanation of bullets/symbols: I'll do the same for the next mod version!

The only thing i don't undertand is why the diagram isn't as Clipboard01.jpgcompact as in my clean installation:

Michał

 

Share this post


Link to post
Share on other sites
mjaro
6 minutes ago, tngrlkrz said:

Michal,

I don't believe those icons/symbols are from TNG.  The ones from TNG look like the ones you're using.  I think those icons (and those in Rogers earlier snapshot) are from WordPress.

 

Is it possible that WordPress can replace text characters with graphics??

If so, the the strange look is the result, as there is a css style for <img> tags which keeps them flushed left. This was the reason I decided to not to use TNG gifs...

Share this post


Link to post
Share on other sites
tngrlkrz

Here's a look without containers in a couple templates (and I prefer all names bolded).

 

 

2021-02-22_10-37-57.jpg

image.png

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×