Jump to content
TNG Community
brummie23

Error! No internet connection?

Recommended Posts

brummie23

HI I am having a problem with OpenStreetMap.

Whenever I try to locate a new address in Places>>Edit Existing Place and click on the "show/hide clickable map" icon. I go to the Magnifying glass icon, click and a search box opens, I add the new address and get the same answer, "Error! No Internet connection?"  (This is with simple addresses like London, England). 

It is connected, as I can zoom the map, which is set to my home address, out and then move the maps to the other side of the world and zoom in on the exact location, (which I have had to find on google maps, that I have to have open in another window.)

This is very time consuming and only noticed it happening on the last two or three gedcom uploads. Obviously that is the only time I do bulk place updates and as I have just done one I am wondering if anyone has any ideas as to what may be wrong?

Thanks 

 Matt.

Share this post


Link to post
Share on other sites
XerxX

Hi Matt,

Are you using the latest update from Dec 9?

That version works for me.

HTH,

Erik

Edited by XerxX
Wrong date

Share this post


Link to post
Share on other sites
brummie23

Hi Erik, sorry for taking so long to get back for some reason your reply went into the junk mail.

Any I am using TNG 12.3 and OSM v12.3.0.6a I just had a look on the tng.lythgoes.net OSM page and saw that for TNG 12.3.0 there is now an OSM v12.3.0.6b.zip

I presume that that is the 9th Dec update you are referring to?  Only problem is I can't download it.

I click on it and a page opens and says, You must be logged into TNG Wiki to download this mod! If you do not have a user ID, use the Request Account or Register links to get a TNG Wiki username. 

I try every single TNG Username and PW that I have and none of them work, I am beginning to wonder how I got OSM 12.3.0.6a in the first place.  

So I go back to the previous page to RHS Request Account, Click and get Database locked.  Okay back to previous page LHS 5 item down Register, Click and get Database locked.

Am I in the correct area and any ideas as to how to get the file?

Thanks

Matt.

Share this post


Link to post
Share on other sites
bhemph

Matt,
     The TNG Wiki is locked for an upgrade until Saturday in the US.  Ken posted that the downloads and logins may not work until the upgrade is completed.

Brent

Share this post


Link to post
Share on other sites
brummie23

Brent,

Thanks, I thought I was losing it.

Matt.

Share this post


Link to post
Share on other sites
XerxX

Matt, I will PM you a copy in a second.

/Erik

Edited by XerxX
Wrong name!

Share this post


Link to post
Share on other sites
brummie23

Thanks Erik just opened it and will start working on it shortly.

Matt.

 

Share this post


Link to post
Share on other sites
brummie23

Okay, I have put it in and received various error messages. I have tried to follow as much as possible the Mod Manager - Installing Config Files tutorial, which because of the ongoing upgrade only has text instructions.

So I put the OpenStreetMad 6b file and its (16) contents along with the openstreetmap_v12.3.0.6b.cfg into the public_html>mods folder.

I went to the Mod Manager and the old version was there 12.3.0.6a showing installed and the new one had been added and it stated partially installed and had given itself the version number 12.3.0.6ba .

As per the instructions I opened the arrow on the new 6ba and saw a load of errors and the Clean up option which I pressed, it made a few changes and really didn't resolve anything.

So I was getting ready to take a screen shot of the errors and then every thing changed again. the new 6ba went from partially installed to a pink colour and is now "Cannot install" and the original 6a which was fully installed has now gone to "Partially Installed". 

The tutorial has the uninstall at the end and as I haven't finished the install yet I am reluctant to uninstall the old one.

I have attached two copies of the error logs for both the NEW 6b and the OLD 6a versions. I know there is an option in the old 6a one to Clean Up, but in light of what happened to the new 6b one when it went from partially installed to cannot install I thought I might wait until some one with more knowledge could guide me on from here.

Thanks

Matt.

NEW_openstreetmap_v12.3.0.6b.cfg.png

OLD_openstreetmap_v12.3.0.6a.cfg.png

Share this post


Link to post
Share on other sites
XerxX

Hi Matt,

First of all: The "6ba" is my fault. Should be "6b" but as it's only for the version display in Modmanager it is of no real importance. I have checked and it's the only "6ba" in the file - everything else is "6b" as it should be, so it's of no real importance.

Now: If I read your post corrcetly, you did NOT UN-install v6a first of all? Correct?

1 hour ago, brummie23 said:

The tutorial has the uninstall at the end and as I haven't finished the install yet I am reluctant to uninstall the old one.

By "The tutorial" I suppose you mean the Wiki page. But you actually HAVE finished the install of the OLD version and the instruction is at the end because it's the last thing you do with that version.

When the currently installed version is UN-installed and maybe removed, you install the new version. Install - Uninstall/Remove - Install - Uninstal/Remove ...

Then, if I understand you, you used the CleanUp button for the NEW mod instead of UN-installing the old? Correct?

I'm afraid that it now may be a real mess and needs a lot of work to resolve. To be able to help you at all: PM me a user name and password for an Admin so I can see Modmanager to begin with. I also need your URL of course. As I'm going away soon (it's 10:30AM here now) I can't help you for a couple of hours - maybe not until the evening depending on when I'm back.

/Erik

Share this post


Link to post
Share on other sites
brummie23

No I did not UN-install v6a first.

Yes I followed the Wiki page https://tng.lythgoes.net/wiki/index.php?title=Mod_Manager_-_Installing_Config_Files

Yes I used the CleanUp button on the NEW mod instead of UN-installing the old as the tutorial has the Un-install at the end and I was concerned that if I did the UN-install with out having an operational new version I may have lost files or history.

Okay I will send you an Admin user name and PW plus my URL on the PM. I will keep checking back but it is 6.30pm here now and if you are looking towards the evening your time it may be that I would expect a reply in the morning my time.

Thanks

Matt. 

Share this post


Link to post
Share on other sites
XerxX
17 minutes ago, brummie23 said:

Yes I followed the Wiki page

The Wiki page says:

First Remove previous (there are instructions for this a bit down the page), then Install new...

You are correct: I will be gone in two minutes so my reply will reach you by yours tomorrow.

/Erik

Share this post


Link to post
Share on other sites
brummie23

Hi Erik

I just noticed those instructions on the top, I had started at the Config File Install steps. Oops.

So I have removed the old version, (It took forever to get rid of the .cfg file)

I tried to Install the new one using Mod Manager and still get the same answer Cannot Install.

I did delete the whole lot a couple of times and tried it again from new but it still comes up with the same answer. the only other file in the mods file is and index.html file. 

Matt.

Share this post


Link to post
Share on other sites
XerxX

To Anyone Interested:

I have just now PMd Matt to replace all 14 files that the OSM mod modifies because the previous version was never uninstalled before everything he describes above happened. That's the only solution, I think. And there were no other mods.

When that copy is done the mod should be OK to install. I hope ;-)

Erik

Share this post


Link to post
Share on other sites
Ken Roy
8 hours ago, brummie23 said:

Hi Erik

I just noticed those instructions on the top, I had started at the Config File Install steps. Oops.

So I have removed the old version, (It took forever to get rid of the .cfg file)

I tried to Install the new one using Mod Manager and still get the same answer Cannot Install.

I did delete the whole lot a couple of times and tried it again from new but it still comes up with the same answer. the only other file in the mods file is and index.html file. 

Matt.

Delete does NOT uninstall a mod.  It simply deletes the .cfg file from the mods folder. 

The TNG Upgrade readme files all tell the users to Uninstall all mods prior to upgrading.   Users must Uninstall all Installed mods and Clean Up all partially installed mods prior to upgrading TNG.

Share this post


Link to post
Share on other sites
brummie23

HI Erik, I replaced the 14 files and fortunately OSM was then able to be installed correctly and is now working.

The installation of this version has also fixed the original Search problem in the post the "No internet connection". That does not appear now, instead I get directed straight to the town along with the benefit of more place options that in the old version.

Thanks very much for all your time and help.

 

Hi Ken, I think I found out working through this that the Delete does not uninstall a mod and even though deletes the .cfg file. But with the .cfg file on Transmit which is my FTP client, it still kept showing even after it was supposed to have been deleted. I couldn't delete it, though I kept getting a file 144 error, telling me it wasn't there. In the end I worked out that if I logged out and then logged back in it may disappear, which it did and that was my work around to get rid of it.

I think the message from this though is to read the instructions properly before starting out.

Thanks

Matt.      

Share this post


Link to post
Share on other sites
XerxX

I'm glad it worked out for you Matt.

6 hours ago, brummie23 said:

this version has also fixed the original Search problem in the post the "No internet connection". That does not appear now,

That was the purpose of the mod update. A parameter for the place-database call was changed.

Enjoy!

Erik

Share this post


Link to post
Share on other sites
Arborist

I seem to have broken my Mods.
Before trying to install admin_media_thumbnails_v13.0.0.5a I uninstalled v12.0.0.4a and then deleted it. After uploading v13 to my mod directory, both versions show up in mod manager with mod names missing and with a "cannot install" status.
What did I do wrong, and what do I do to fix it?
thanks

UPDATE:  I thought I had successfully moved my tree last January, but the config was still pointing pointing at the old tree.  I gave up and am doing a clean install.  I am not finished yet, but the Mods are installed.

Screen Shot.png

Edited by Arborist
I figured it out.

Share this post


Link to post
Share on other sites
tngrlkrz

Very unusual to see cfg files found, but not mod names, which themselves are in the cfg file.  Check the contents of your /mods folder (or whatever you have called it) to see what files are there, and verify their contents.  Also, are you sure you had a successful uninstall ?  If so, you should be able to clear the folder copy the mods into the mods folder again, unless you have further corruption in TNG files left over by failed mod uninstallation.

I believe all 3 mods are Robin Richmond's.  Some of his mod's require the 'mod settings' mod as well.  Not sure if that's involved.

Share this post


Link to post
Share on other sites
Arborist
On 2/10/2021 at 10:37 PM, tngrlkrz said:

I believe all 3 mods are Robin Richmond's.  Some of his mod's require the 'mod settings' mod as well.  Not sure if that's involved.

Thank you.  And apparently, V13 does require the Mods Settings Blocks mod.
Larry

Share this post


Link to post
Share on other sites
Ken Roy

Maybe Robin's Mod Settings block is breaking the mods.  I have seen mods with no names before when mods had changes to the TNG config files and the mod was not updated when the TNG Setup dialogs were updated.

Share this post


Link to post
Share on other sites
Michel KIRSCH
4 hours ago, Arborist said:

And apparently, V13 does require the Mods Settings Blocks

TNG v13 doesn't require the Mods Settings Blocks.

Some Robin's mods require it.

Michel

Share this post


Link to post
Share on other sites
tngrlkrz
1 minute ago, Michel KIRSCH said:

TNG v13 doesn't require the Mods Settings Blocks

Yes, but I think he may have been referring to v13 of the admin_media thumbnails mod.

Share this post


Link to post
Share on other sites
Arborist

Sorry, I wasn't clear. I was talking about admin_media thumbnails V13 needing the Mod Settings Block.

Share this post


Link to post
Share on other sites
Michel KIRSCH

:-)

No problem Larry.

I don't always understand all the subtleties of English.
And I always post too fast...
I try to correct my flaws, but they are deeply rooted...

Michel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×