Jump to content
TNG Community
Sign in to follow this  
tngrlkrz

TNG Import and Admin Setting for Person ID Prefix

Recommended Posts

tngrlkrz

This has  been discussed before but shall revisit the subject.  Why does TNG's import gedcom process not use the Admin:General Settings:Prefixes and Suffixes when importing?  Since I use 'P', and regularly import all data to TNG from Family Historian, I must remember to edit the gedcom beforehand to change all incoming gedcom individual/person records from 'I' to  'P' even though I have the aforementioned Admin setting as 'P'?   Is there some internal reason this cannot be done by TNG?  Today that TNG setting only impacts data entered directly into TNG via online screens.

 

 

Share this post


Link to post
Share on other sites
Ken Roy

Ron,

That would be a question for Darrin who does not monitor this forum.  So you either need to ask this question directly to Darrin or post it on the TNG user2list with Darrin also being in the TO list

Share this post


Link to post
Share on other sites
Fritz Loseries

Ken, sorry, where to find the TNG user2list ?

I get similar problems as Ron have. Only my problem is GEDCOM import where externel INDI IDs contain a '-' e.g. @I1-1 and @I1-2 will be converted to @I1

Is there a rule, that only numbers are valid ?

 

 

 

Share this post


Link to post
Share on other sites
tngrlkrz

Hi Ken,

Yes, that was going to be my next step, I had planned to use both avenues, starting here first. I was curious to know the thoughts and experiences  of forum users as well.

 

Share this post


Link to post
Share on other sites
Ken Roy
21 minutes ago, Fritz Loseries said:

where to find the TNG user2list

Go to your TNG Admin screen - the Getting started link in the top line of that screen will display a help screen that tells you how to subscribe to the 2 different lists

23 minutes ago, Fritz Loseries said:

Is there a rule, that only numbers are valid ?

Not sure I understand that part of your question. 

Share this post


Link to post
Share on other sites
tngrlkrz

Somehow I missed this in the TNG 13 changes list:

Import: For individuals, the "P" prefix will now be swapped for an "I" if configured.

Darrin confirmed this option was added to  Admin: Settings:Import Settings:

Change incoming prefixes to match TNG settings: (no or yes)

Will test this today.

Edit Update:

The new TNG 13 option indeed works!  Yay!  I no longer need modify the gedcom from Family Historian before import.  Don't know how I missed this in the change list.

Edit Update2:

Corrected option reference.

Share this post


Link to post
Share on other sites
tngrlkrz
9 hours ago, Ken Roy said:

Not sure I understand that part of your question

I could be wrong, but I think Fritz is asking if , outside of the required 1-character alpha prefix, does the rest of the person ID have to be numeric. And I would answer 'Yes', AFIK.

Share this post


Link to post
Share on other sites
Fritz Loseries

Ron and Ken,

On 1/6/2021 at 4:07 PM, tngrlkrz said:

Darrin confirmed this option was added to  Admin:General Settings:Prefixes and Suffixes:

Change incoming prefixes to match TNG settings: (no or yes)

I could not find in TNG13 this option. This seems to match my interests.

On 1/6/2021 at 3:45 PM, Ken Roy said:
On 1/6/2021 at 3:24 PM, Fritz Loseries said:

Is there a rule, that only numbers are valid ?

Not sure I understand that part of your question. 

What I mean is following:

If you have following _ID's : I1-1, I1-2, I1_1 in import ged file, they will all be converted to I1- and only one person is created. All others are ignored or overwritten.

I have made a quick example (sorry, there are a lot of other people in there).

If you import this in a test tree, "accept all new Custom Events" and Replace (all 4 tested), you will find only one people (person) with ID "I1-" name " Friedrich August Rudolph"

This person has now 27 Families. All other person with ID I1-XX in the ged file are ignored.

 

Regards, Fritz

Share this post


Link to post
Share on other sites
tngrlkrz
11 minutes ago, Fritz Loseries said:

I could not find in TNG13 this option. This seems to match my interests.

Sorry, that was my option reference mistake in hasty note.  It is in the Admin:Setup:Import Settings.  I corrected my original post.

image.png

Share this post


Link to post
Share on other sites
tngrlkrz

Fritz,

TNG is not expecting  the '-' dash within the personID.  The TNG Help for Adding New People indicates (in part):

Quote

The Person ID must be unique within the selected Tree and should consist of an upper case I followed by a number (no more than 21 digits). 

Furthermore, the prefix can be other than an 'I' if set differently in Admin:Setup:General Setup:Prefixes and Suffixes. 

 

Share this post


Link to post
Share on other sites
tngrlkrz

Fritz,

Could you perhaps modify with an Editor like Notepad++, the "@I-"  to something like "@I0" , replacing the "-" with a number?  I did that and your test gedcom imports fine. Of course that has ramifications for your adding new PersonID's in TNG.  But the test imports OK if you convert to numeric:

image.png

Ron

Share this post


Link to post
Share on other sites
Fritz Loseries

Ron,

17 minutes ago, tngrlkrz said:

TNG is not expecting  the '-' dash within the personID.  The TNG Help for Adding New People indicates (in part):

Quote

The Person ID must be unique within the selected Tree and should consist of an upper case I followed by a number (no more than 21 digits). 

Furthermore, the prefix can be other than an 'I' if set differently in Admin:Setup:General Setup:Prefixes and Suffixes. 

This is problematic for the exchange of data between different genealogy programs. I'm not sure, if the convention for ID's is saying that only one alpha sign in front and then only digits are valid or standard.

And I had a look to the import settings. I have marked "No" for changing incoming prefix to TNG settings. And this works as can be seen in the test ged file for person, family and notice ID. And for Notices all notices are accepted although there are IDs named @NF1-...

Regards, Fritz

Share this post


Link to post
Share on other sites
Fritz Loseries

Ron,

2 minutes ago, tngrlkrz said:

Could you perhaps modify with an Editor like Notepad++, the "@I-"  to something like "@I0" , replacing the "-" with a number?  I did that and your test gedcom imports fine. 

This is not a good solution. Because importing it again in a year, I would not remember to do this. And also I cannot get back the correct ID's to the other genealogy program.

I just checked another TNG 12 implementation with other data. There e.g. an ID ID_134364 is valid and correctly supported. Does this mean, that after a digit no other signs except digits are valid ? Probably this is a direct question to Darrin.

Regards, Fritz

Share this post


Link to post
Share on other sites
tngrlkrz
39 minutes ago, Fritz Loseries said:

Probably this is a direct question to Darrin.

Yes,  post your question on the tng users list, which Darrin follows at tngusers2@lythgoes.net

Quote

This is not a good solution. 

Yes, it was just a test to show the personID's import fine with non-numeric characters removed.

Ron

Share this post


Link to post
Share on other sites
theKiwi
On 1/6/2021 at 9:24 AM, Fritz Loseries said:

I get similar problems as Ron have. Only my problem is GEDCOM import where externel INDI IDs contain a '-' e.g. @I1-1 and @I1-2 will be converted to @I1

Where are you getting a GEDCOM file that uses a - in the ID numbers?

On 1/6/2021 at 9:24 AM, Fritz Loseries said:

 Is there a rule, that only numbers are valid ?

I'm not sure it's a "rule", but it's certainly the convention (i.e. normal use).

Roger

Share this post


Link to post
Share on other sites
tngrlkrz

To be fair, the help snippet I quoted from Add New People  does note 'should' rather than 'must' be numeric after the prefix.  So I guess TNG will accept otherwise, but with likely unfavorable results, as you have found.  But, a question to Darrin is appropriate at this point.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×