Jump to content
TNG Community
KathieR

SSL and importing Gedcom

Recommended Posts

KathieR

I recently added SSL to my Wordpress site.  

I have TNG running under the site.  I used the Kloosterman method for TNG integration.

Everything is working except the import.  When I try to import a gedcom file it just hangs, so I know that I need to change something, but I don't know what.

Any help would be appreciated.

Kathie

Share this post


Link to post
Share on other sites
Philip Roy

In the admin section....

Setup —> General —> Site design and Definition

...have you changed your URL to start with https and not http ?

Not sure if that will fix it but it’s an easy first check.

Phil

Share this post


Link to post
Share on other sites
KathieR

Yes Phil, thanks,

That’s was the first thing I did as I found that info on the wiki.

So, now I’m looking for next steps.

Kathie

Share this post


Link to post
Share on other sites
fluffy82

Are you importing from your desktop or straight from the gedcom folder?

The former has never worked for me - probably due to file size. Try using an ftp like Filezilla to upload your gedcom into the gedcom folder, and then import it by choosing it from the list.

Share this post


Link to post
Share on other sites
tngrlkrz

My experience is the same as fluffy82.  Always using FTP to upload the gedcom to the host gedcom folder, then pulling the file from there for the import.  I do it that way for local and remote host, ..has never failed.  Then SSL is taken out of picture.

Share this post


Link to post
Share on other sites
Ken Roy

Since TNG can extract the .ged file from a .zip file, you can also zip your .ged file before FTPing to your host.  Might not make that much of a difference if you have the bandwidth but a 10MB ged file compresses to 2MB and therefore uploads quicker if you do not have the bandwidth.  Mine is currently 1/4th of what I had 6 years ago in Texas

Share this post


Link to post
Share on other sites
KathieR

Sigh,

Thanks guys, but I have tried both uploading from the desktop and transferring it using FTP first.  Both get the same result - spinning wheel and it doesn't get past the first step.  So it must be something in the first piece of the puzzle.

BTW, I upload updates monthly, sometimes weekly, so I know everything was working fine on 24 Nov, before SSL installation, but not working now, after SSL installation. 

Is it maybe something I need to do in one of my wordpress files or settings?

Kathie

Edited by KathieR

Share this post


Link to post
Share on other sites
fluffy82

Another thing you can try: importing a gedcom always takes quite a long time, especially if it adds people to an existing (large) database. What I have been doing recently, is to empty the "people" and "children" tables in the database through phpMyAdmin before every import. This has reduced the import time from very long - sometimes freezing - to only between 60 and 90 seconds.

Share this post


Link to post
Share on other sites
Ken Roy
3 hours ago, KathieR said:

BTW, I upload updates monthly, sometimes weekly, so I know everything was working fine on 24 Nov, before SSL installation, but not working now, after SSL installation

Kathie,

Is it possible your version of PHP changed within the last month?  or the PHP handler?  I know that during TNG 13 beta testing, I discovered that if I enabled PHP 7.4 using the FPM with OPcache that the import no longer showed any progress bar and just dumped the completed progress bar to the screen when it was done.  Changing it to use the old style counts would not help either since none of the Import Secondary process display progress counts.

On my hosting service I can select the PHP Handler, so if I change the PHP Handler to use the CGI handler then I can see the progress.  I am not Unix system expert since my expertise was the IBM z/OS operating system before I retired 16 years ago.

 

Share this post


Link to post
Share on other sites
KathieR

Fluffy82,

Tried that.  It didn't import.  But it did restore from backup.  So that's probably tells me something.

Ken:

Yes, my version of PHP did change to 7.4.

From your post, I thought - great, I am just being impatient.  So I left it for 10 minutes.  That did not help, unfortunately, still no joy.

My hosting service does not allow me to change the PHP handler.

Kathe

Share this post


Link to post
Share on other sites
Robin Richmond

How big is your database (# of people)? How big is your Gedcom file?

Is the import giving your an error?  Have you tried the "Old Import" option?  It might have the same output caching problem, but it produces so much output that I would expect it to fill the buffers and display at least some of the progress report.

Does it add any content to the database?

 

Share this post


Link to post
Share on other sites
Robin Richmond
5 hours ago, fluffy82 said:

What I have been doing recently, is to empty the "people" and "children" tables in the database through phpMyAdmin before every import. This has reduced the import time from very long - sometimes freezing - to only between 60 and 90 seconds.

That's great, but ... (With me, there's always a "but", isn't there?) ... it's also curious, because, when you launch a full tree Gedcom Import, the Gedcom Import starts by clearing the tree's people, children, families, events, citations, sources, and repositories (that may be it). It shouldn't take TNG much more time to do that than phpMyAdmin takes, but, hey, if it helps, that's great.  I just wish that I understood why.

- Robin

 

Share this post


Link to post
Share on other sites
KathieR

Robin,

I have 8,974 people in my online tree and 8,972 in my gedcom.  I cleared the tree, checked that there were no people, attempted the upload using the "old import".  After 10 minutes, I killed it and checked the tree - zero people.  So I restored from backup. 

So, it is not importing any content, and it is not giving me any errors.

Kathie

Share this post


Link to post
Share on other sites
Ken Roy

Kathie,

Please check with your hosting service if they are using FPM with OPcache as the PHP handler.  If they are ask them if there is a way to revert back to using CGI as the handler

Share this post


Link to post
Share on other sites
KathieR

Ken,

They are using the Litespeed web server with lsphp.  They did tell me how to turn off OPcashe on the PHP handler and I did that. 

It did not, however, make any difference to the import, unfortunately.

Kathie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×