Jump to content
TNG Community
Sign in to follow this  

Birth/death dates not showing / incorrectly marked as private?

Recommended Posts


Good day.

For the profile at
the birth and death dates don't show unless I've selected "Allow to view information for private individuals" is selected.

I was contacted by a user who was unable to see the dates, even though she was signed in. Since the person in the profile is deceased, this shouldn't even be necessary, since our site only restricts details about living individuals to signed-in members.

I thought that it was a browser problem, so created a test account with the same rights and tested it in Edge, Chrome and Firefox. Same problem. Only once I gave the permission to view information for private individuals did it show.

My problem is that I cannot see where this person might be marked as individual. I use Rootsmagic as my main family tree software, then upload the tree to TNG weekly. I am used to marking events as private in Rootsmagic (which then don't show on TNG), but a) nothing about the specific profile is marked as private in Rootsmagic and b) I haven't marked her as private on TNG, or rather, I can't see anywhere there is an option to do that.

Website: https://vandykregister.com
Problematic profile: https://vandykregister.com/getperson.php?personID=I26487&tree=vandyk
Test login credentials: Anrie-Toets; Anrie-Toets (currently set to "allow to view information for private individuals")
TNG version: v. 11.1.2
Problem summary: profile supposedly set to private, despite my not knowing how that is possible or where the specific setting is

Any advice would be appreciated.



Share this post

Link to post
Share on other sites
Ken Roy

What do you have in the Admin > Setup > Import Settings for

Assume private if not dead this many years:

I believe TNG defaults to 10 (years) so persons who died in the last 10 years would be marked Private. 

You can update your users who have the allowed privilege to View Living information to also View Private information or you can change the parameter in the Import Settings

Share this post

Link to post
Share on other sites

Ken, you are a star, thank you so much. I never would've thought to look there. I kept trying to check the person's profile itself, rather than consider that it might be a general setting.

Very much appreciated.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this