Jump to content
TNG Community
christineH

Google Map API

Recommended Posts

christineH

Rookie question #2.

I thought I was following the instructions to install the Google Maps API.  I don't know what I've done wrong. 

When I open a map this is what I get

Capture.JPG

Any suggestions about what I need to tweek?

Thanks

Chris

 

Share this post


Link to post
Share on other sites
theKiwi

That screen shot is too small to read - what does the pop up say exactly?

What is a URL to a page on your site that should show a map but shows this error - seeing the underlying source code will be very helpful.

Roger

Share this post


Link to post
Share on other sites
Rob Severijns

Chris,

 

Has it worked before?

I checked you site and at first I got the message that the map could not be loaded.

After I checked my own  Setup --> Map Settings and viewed my own API key your map suddenly worked fine. (see screenshot)

image.png

Are you sure your API key is correctly copied into  Setup --> Map Settings  and are you sure the API key is linked correctly to your website?

Make sure your key is linked to  http://14359.members.fhwa.org.au/*

you need the following API's:   Maps JavaScript API and the Geocoding API

If everything is correct it should work.

You might also want to try and clear your browser cache and reload the page.

 

Rob

Share this post


Link to post
Share on other sites
theKiwi

Here's the problem...

image.png

You must enable Billing on the Google Cloud Project at https://console.cloud.google.com/project/_/billing/enable Learn more at https://developers.google.com/maps/gmp-get-started

So, go to this link

https://console.cloud.google.com/project/_/billing/enable

and sort it out there. You have to have billing enabled with Google, but for almost every user of Google with TNG there will never be a charge - the free allowance of usage you get is way more than you'll need.

Roger

Share this post


Link to post
Share on other sites
kappclark

It seems complicated at first - but the enable billing did it for me -- now all the maps render correctly, and the geo-coding appears to be working

 

Thank you for the guidance on this great feature..

Share this post


Link to post
Share on other sites
theKiwi
5 hours ago, kappclark said:

It seems complicated at first - but the enable billing did it for me -- now all the maps render correctly, and the geo-coding appears to be working

 

Thank you for the guidance on this great feature..

Did something break again? I just tried the link you posted above and still get the same problem showing

Roger.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×