Jump to content
TNG Community
fluffy82

Cemetery Burials Table

Recommended Posts

fluffy82

I just installed the Cemetery Burials Table mod, and have some questions. @Robin Richmond

  1. there is a button appearing, with value="" (so nothing is written on it) and clicking it doesn't do anything; the inspector says onclick="return rrSetMainCemeteryImageSize('px','px')" but this cemetery has no images... Am I doing something wrong, or is there a mistake in the mod?
  2. even though I have selected to always show the full place name and to not give that choice to the user, there is still a working button to change that... It doesn't really bother me, but the settings are apparently not working as they should be, so maybe worth looking into.
  3. there is the weird text All burials in the cemetery's Associated Place: followed by the name of the cemetery. Wouldn't it be better to just say "All burials in [cemetery name]"? Just trying to understand where that phrase comes from, what's its use, and how to change it... Even if it's in case people have a city associated with it rather than a cemetery, it would still be better to show "All burials in [city]" rather than "All burials in the cemetery's Associated Place: [city]".

cemeteries.PNG

Share this post


Link to post
Share on other sites
fluffy82

I just saw that I can easily change n¬į3 myself by changing the custtext file.

But... My site is in Dutch, TNG is in Dutch, and there is a Dutch text file. Why does it still show the English one? ūü§Ē

Share this post


Link to post
Share on other sites
Robin Richmond

1. The empty button is tied to attempt to show a cemetery map photo when none exists.  I have not encountered it in my testing, but, clearly, there must be a circumstance under which it appears. Do you see it for all cemeteries?

2. You're right. That's a bug.  I have fixed it, and hope to release the new version today or tomorrow.

3. Someone else pointed out the awkwardness of that phrasing not long ago, and I thought that I'd fixed it, but it still showed up under some circumstances. I have  eliminated it completely in the version I'll post today or tomorrow..

4. The language problem... Another bug. When I renamed the mod and changed the language subscripts to stay tied to the mod name, I didn't do so everywhere, so the program wasn't recognizing any mod-specific Dutch strings. Again that's fixed.

So I'm just hoping to figure out the empty button problem, and will go ahead and post the new version even if I havent' figured it out yet.

BTW, the mod had a Dutch, but not a Dutch-UTF8 translation.  My general practice is to define the UTF8 version of a language, and then either conver the character for the ISO version of the language, or, as in Dutch, where no accented characters are being use, just use the PHP Include command to pull the Dutch-UTF8 translation into the Dutch file.   Again, I've fixed that, and it will be out today or tomorrow.

Further, the English strings for the two buttons that you can now suppress were not defined in Dutch. In English, they are

$text['rrcbt-fullplacenames'] = "Full Placenames";
$text['rrcbt-abbreviated'] = "Abbreviated Placenames";

If you could send me Dutch translations of these string, I would appreciate it.

- Robin

 

 

Share this post


Link to post
Share on other sites
fluffy82

Very weird... I was going through all my cemeteries to see if the button shows up on every page, and it is on several pages but not on all... It seems to be totally random though.
You should be able to see them without logging in on my site. New Southgate and West Norwood have the button, but Zele, Chingford, Utrecht, St Annes and Kensington don't.

 

For the Dutch translation, I'd be happy to help:

$text['rrcbt-fullplacenames'] = "Volledige Plaatsnamen";
$text['rrcbt-abbreviated'] = "Afgekorte Plaatsnamen";

Share this post


Link to post
Share on other sites
Robin Richmond

Thanks for the strings.

The link to your cemeteries page redirected to the login page.  I tried going to showmap.php and guessing at cemeteryIDs with no success.

It might be good to email me directly- Robin

Share this post


Link to post
Share on other sites
Robin Richmond

(I'm also sending this message to the gmail address I have for you. I'd appreciate if you would reply to it or to my support form at  https://www.robinrichmond.com/family/mod_support.php.  I've explained why in the email message.

FWIW, I was somewhat confused by two signs that you might not be using TNGv13 - the folder name "tng_11" in your URLs, and a mention of TNG12 in your foots.  But I suspect that both are legacies of WordPress, so I'll assume that you really are using TNGv13. :-)  
 
More to the point -

In each cemetery with the empty button,  the page appears to be trying to load a missing image, as illustrated in the attached screenshot from New Southgate Cemetery in London, showing the <img> tag in the Google Chrome HTML inpector. It shows that the page is looking for the image file "huygensv_headstones/New_Southgate_Map.png".  I'm not seeing that problem when I define a missing image for a cemetery, but I'm (probably) running newer versions of the mods.  

I said "mods" rather than "mod" because, a few few days ago, I eliminated conflicts between Cemetery Burials Table and a couple of other mods by breaking it into two mods:

  1. Cemetery Burials Table v17a focuses on deals with the "All Burials" table and the rarely-used table of cemetery images.
  2. The new Cemetery Map And Image  mod (v1a)  deals makes miscellaneous tweaks to showmap.php, including the handling of the large cemetery map images.

If you don't have the latest versions of both mods, please try them.  Well, if you aren't interested in Cemetery Map And Image, you don't have to install it, but if you would give it a test to see if it fixes the image and button problem, I'd appreciate it. In any case, please let me know what you find.

- Robin

p.s. Perhaps by the time you visit the wiki articles above, one or both of them will distinguish between the "table of cemetery images" and "large cemetery map images".  If they don't and you want clarification, just let me know.

cemeteryerror.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×