Jump to content
TNG Community
Bill Herndon

Suppressing Icons In TNG's Drop-down and Main Menus

Recommended Posts

cfj

tng-near-dawn2.png

3 hours ago, Bill Herndon said:

it's used to move the [print], [bookmark], and [share]

Forgot the icons, since I don't use it.

 

Edited by cfj
Forgot Bookmark

Share this post


Link to post
Share on other sites
Paul Barrett

Hi everyone

I'm late to this party and I'm trying to apply the techniques to eliminate the dropdown menu icons in Template 19 on https://familytree.berksfhs.org/index.php

The CSS is this, correct:

.headericon, .menu-icon {

display: none;

}

... and it goes in mytngstyle.css for the template?

 I have done that and it has no effect, even if I insert !important

Am I missing something from this long thread?  I'd prefer not to mess with functions

Share this post


Link to post
Share on other sites
RickM
6 hours ago, Paul Barrett said:

Am I missing something from this long thread?  I'd prefer not to mess with functions

Had a quick look at your site, and I think you have not copied the full class line .headericon, .menu-icon to your mytngstyle.css file..

Pic -1 shows your current

iconhide-1.jpg

Pic -2 shows with the addition of .headericon, AND removal of !important tag (try hard NOT to use this <smile>).

iconhide-2.jpg

Edited by RickM
Missed the obvious

Share this post


Link to post
Share on other sites
RickM
On 10/14/2020 at 4:55 AM, tngrlkrz said:

Cathrin,

I would be curious to see the solution as well, if you could PM me.

@cfj I am even later to this convo, although have been helping Paul out with a very similar thing, both for his WP / TNG install (I think) and for his template 19 native TNG install..

Would you be able to supply the solution you supplied to Ron (or a later version if there is one) please??

Happy if you PM it to me or send via my email rick@alineofmalkins.com

Share this post


Link to post
Share on other sites
Paul Barrett

I only did the dropdown menu items because the main menu already had them suppressed.

I had cleared cache so many times I don't know why they were showing (I always use Ctrl+F5, never F5 on its own) but now they are gone.  Weird but good

I'm only worried about the native TNG template.  WP install is good.

 

Share this post


Link to post
Share on other sites
tngrlkrz
17 minutes ago, RickM said:

Would you be able to supply the solution you supplied to Ron (or a later version if there is one) please??

Rick, will PM you  the changes I made based on what Cathrin had sent, adapted to my private mod to remove sprites from dropdowns.

 

Share this post


Link to post
Share on other sites
cfj

@Paul Barrett  Can you try this code:

ul.tngdd ul li a .menu-icon {
    display: none;
}

 

Share this post


Link to post
Share on other sites
RickM

Many Thanks Cathrin..

Between you and Ron, I think we have it sorted..

Strangely, I have been rooting round the Template 19 files (at least the index.php and top_menu.php) and have noticed lines that mention 'noicons'

I'm going to ask on the TNGUSERS2 list what this refers too, as I think that is the right place to do so..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×