Jump to content
TNG Community
PvanAchterberg

Advice sought with TNG plugin Wordpress integration

Recommended Posts

PvanAchterberg

I did follow the steps as mentioned in this guide.

I have 2 sub folders:

image.png

I have the following diagnostics: see image attached: Aantekening 2020-08-30 200509.png

I followed all the steps and when I open the adress https://www.paulvanachterberg.nl/genealogie/ it leaves all blank.

I also added the TNG pugin options. See the image TNG Plugin options.

I also added Site Design and Definition. See the image Desing and setting.

Any ideas what I might have missed?

 

 

Aantekening 2020-08-30 200509.png

TNG Plugin options.png

Design and setting.png

Share this post


Link to post
Share on other sites
theKiwi

Have you tried a different theme?

Have you changed the permalink settings to something that isn't the default? If so, try changing them to something else and then back to what you had - this will force a rewrite of the contents of the .htaccess file.

Try unchecking the "Replace TNG Home page with WordPress page" option.

Have you tried deactivating all of the installed plugins?

Something else seems to be wrong too - once I'm at the empty page of 

https://www.paulvanachterberg.nl/genealogie/

and then try to view say

https://www.paulvanachterberg.nl/genealogie/surnames.php

it redirects back to 

https://www.paulvanachterberg.nl/genealogie/

same for trying

https://www.paulvanachterberg.nl/genealogie/places.php

What is causing this redirect?

Interestingly this one

https://www.paulvanachterberg.nl/genealogie/browsemedia.php?mediatypeID=photos

does load "a" page (not the right one) but the URL is rewritten to

https://www.paulvanachterberg.nl/genealogie/?mediatypeID=photos

So something is rewriting your URLs that shouldn't be.

Roger

Share this post


Link to post
Share on other sites
PvanAchterberg

Hi Roger,

Thank you for your tips.

Unchecking the box did the trick. I still need to customize some things, because it doesn't look pretty.

The other hints I need to look after. Thank you!

 

Best regards,

Paul

Share this post


Link to post
Share on other sites
PvanAchterberg
On 8/31/2020 at 4:21 PM, theKiwi said:

So something is rewriting your URLs that shouldn't be.

 

I have been trying some options. When I moved my wordpress installation to a sub folder the htacces was changed to:

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP_HOST} ^(www.)?paulvanachterberg.nl$
RewriteCond %{REQUEST_URI} !^/wp/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /wp/$1
RewriteCond %{HTTP_HOST} ^(www.)?paulvanachterberg.nl$
RewriteRule ^(/)?$ wp/index.php [L]
</IfModule>

 

This isn't a copy of the htacces file in de sub folder:

# BEGIN WordPress
# De richtlijnen (regels) tussen `BEGIN WordPress` and `END WordPress` worden
# dynamisch aangemaakt en zouden enkel aangepast mogen worden via WordPress filters.
# Elke wijziging aan deze richtlijnen tussen deze markeringen worden overschreven.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

There are 700 more rules of code, but they disappear when I turn off my security plugin. When I do so the website is still working, but nog the genealogy page.

When I add the index.php to the root my site is not reachable.

I tried different thems. When I deactivate all my plugins my site isnt working anymore. So something should be there but I don't know where to look.

Share this post


Link to post
Share on other sites
theKiwi

Try removing this blocks of code from all of the .htaccess files you can find and then go to WordPress Admin. I think at that point it offers to fix the .htaccess file - see which one it fixes - that will tell you which one is in effect - certainly there should be only one, not multiple ones.

Roger

Share this post


Link to post
Share on other sites
PvanAchterberg

Hi there Roger,

I am experiencing a lot of troubles trying to make Wordpress work with TNG. And I can't find what I am doing wrong.

I registered a new domain: familievanachterberg.eu to have a fresh clean start. I even have chosen the advertised provider on the TNG website.

I did a new Wordpress install in the wp folder as instructed. I did a new install of TNG which is working. Except not in Wordpress.

I have attached new screen shots of my setting as well the code from the .htaccess files and index files.

Hopefully you can give me more insight.

 

root structure.png

index root folder.png

htaccess in root folder.png

index wp folder.png

htaccess wp folder.png

site settings tng.png

Share this post


Link to post
Share on other sites
fluffy82

I never succeeded in making the plugin work either. I started using the "Kloosterman method", have you ever considered that? It looks overwhelming to get it right, but it's actually really easy. Once everything installed, it works like a charm.

Share this post


Link to post
Share on other sites
theKiwi
On 9/19/2020 at 4:34 PM, PvanAchterberg said:

Hi there Roger,

I am experiencing a lot of troubles trying to make Wordpress work with TNG. And I can't find what I am doing wrong.

I registered a new domain: familievanachterberg.eu to have a fresh clean start. I even have chosen the advertised provider on the TNG website.

I did a new Wordpress install in the wp folder as instructed. I did a new install of TNG which is working. Except not in Wordpress.

I have attached new screen shots of my setting as well the code from the .htaccess files and index files.

Hopefully you can give me more insight.

 

root structure.png

index root folder.png

htaccess in root folder.png

index wp folder.png

htaccess wp folder.png

site settings tng.png

You should only need one .htaccess file - the one in the wp directory is redundant I think.

If you want me to take a look send an eMail to rogerkiwi@aol.com containing

FTP loginID and password

WordPress Admin loginID and password

TNG Admin loginID and password.

Roger

Share this post


Link to post
Share on other sites
theKiwi

Actually I just took a look at your home page, and see that TNG is actually almost working on the "sample page" page.

So make sure that you've identified the correct page for TNG to appear on in the WordPress Admin ------> TNG screen - to tell it TNG is to appear on genealogie not on sample-page

Roger

Share this post


Link to post
Share on other sites
PvanAchterberg
6 hours ago, theKiwi said:

Actually I just took a look at your home page, and see that TNG is actually almost working on the "sample page" page.

So make sure that you've identified the correct page for TNG to appear on in the WordPress Admin ------> TNG screen - to tell it TNG is to appear on genealogie not on sample-page

Roger

That was not correct indeed.

So it appears to be working now? The only thing left is to customize the page. I will have another into that.

 

Share this post


Link to post
Share on other sites
PvanAchterberg

I want to thank everyone for helping me out.

Today I tried the Kloosteman method and it finally worked on my wordpress site. Many many thanks.

Now it's time to focus on getting everything nice.

Best regards,

Paul

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×