Jump to content
TNG Community
glporterfield

Tab will not close after edit person/family

Recommended Posts

glporterfield

This problem just started today.  It may be browser unique, but I am not aware of any update that was applied to FireFox since yesterday.

Problem:  After editing a person or family, when I click Save with the "Close Window" option checked, the tab used by the edit process does not close.  The tab remains open and it is blank.  It used to close the tab until today.  The URL showing for the blank tab is pointing to /admin_updateperson.php or /admin_updatefamily.php.  If I examine the source code for the blank page, I see the following code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<body>
<script type="text/javascript">
	top.close();
</script>
</body>
</html>

The console shows this error: "Scripts may not close windows that were not opened by script."

I can close the tab manually and it will go away.  It does appear that all updates are being applied.  The admin log is also getting updated.

This does not happen if I have selected one of the other closing options, such as return to this page.

I am running TNG 12.1 on a GoDaddy hosted site.  The template is customized one based on templates 12 & 15. 

Site URL: http://porterfieldjunction.net

UserID and password: Debug /xyZZy

 

Thanks for any suggestions,

George

 

 

Share this post


Link to post
Share on other sites
manofmull

If you hadn't mentioned Firefox, I would have guessed.

Firefox 78 was crashing tabs and replaced yesterday by 79 not closing tabs.

In about:config

dom.allow_scripts_to_close_windows 

Change from false to true and that should work for you = does for me!

Share this post


Link to post
Share on other sites
glporterfield

Thanks.  The change to about:config did the trick.

Share this post


Link to post
Share on other sites
MadRanger

I am experiencing the same problem; Where do I find about:config

...meanwhile I am going back to search for it...

Thanks

EDIT:

Type about:config in the address bar and press enter.  Search for the aforementioned "dom.allow_scripts_to_close_windows" 

...and change False to True.

To paraphrase manofmull - that worked for me.

Edited by MadRanger
Answer

Share this post


Link to post
Share on other sites
stores

Type about:config in the firefox search bar, click "accept the Risk and Continue" then scroll down...

Share this post


Link to post
Share on other sites
manofmull

It's actually the address bar per MadRanger's edit.

I didn't mention this in my reply to the original poster as I thought everyone knew where to access about:config (those using Firefox).

I've tweaked quite a lot in there, but be careful as you can mess things up.

Glad the guys got things sorted.

Share this post


Link to post
Share on other sites
Michel KIRSCH

Thanks for the fix !
Michel

Share this post


Link to post
Share on other sites
manofmull

Michel

My pleasure. It's nice to get a thank you, which people sometimes don't bother to do

 

M

Share this post


Link to post
Share on other sites
Michel KIRSCH

Yes. I've seen it many times... Let's keep on thanking each other. There will always be something left of it !

Michel

Share this post


Link to post
Share on other sites
ton van lil

I have the same problem but then with MS Edge.

Get the following message:

A change in your browser's default behavior is preventing this window from closing.

To change this behavior, type about:config in the browser address bar and press enter.

Then search for dom.allow_scripts_to_close_windows and change the value of that setting from False to True.

About:config does not work with Edge. Anyone who knows the solution to this?

Greetings

Ton van Lil

Share this post


Link to post
Share on other sites
manofmull

Ton

I jokingly suggest using Firefox! = problem ended.😄

The new Edge can be uninstalled with CCleaner with no adverse effects.

A registry tweak can prevent it from re-installing via W10 updates.

Share this post


Link to post
Share on other sites
ton van lil

Sure that is one solution but it's the easy way out.

It must be possible with Edge.

 

Share this post


Link to post
Share on other sites
manofmull

Ton

I meant to add that is the reason I don't use Edge.

It does't have the same user-control as Firefox

Share this post


Link to post
Share on other sites
wkenddad

I've started encountering the same with the upgrade to v13.02

I have an iMac and generally use Google Chrome

The problems don't occur using Safari

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×