Jump to content
TNG Community
KlausiMaus

TNG WordPress Integration - no links working

Recommended Posts

theKiwi

Do you have the right path to TNG files set in the TNG-WordPress plugin?

Have you changed the permalink structure in the WordPress settings to be not the default setting?

Roger

 

Share this post


Link to post
Share on other sites
KlausiMaus

Yes, I did all of these things, otherwise the page wouldn't be visible - right?

Share this post


Link to post
Share on other sites
theKiwi
6 hours ago, KlausiMaus said:

Yes, I did all of these things, otherwise the page wouldn't be visible - right?

Yes, but the links not working would indicate some kind of path problem, or an issue in the rewrite rules that WordPress uses to make URLs work.

If you change the permlink settings again, and then change them back to the suggested one does that make any difference? This should cause WordPress to rewrite the rewrite rules.

Have you tried deactivating all of the WordPress plugins you're using - conflicts and problems there are not uncommon.

Roger

Share this post


Link to post
Share on other sites
KlausiMaus

OK, I have changed and restored the permanent links, but no success.

I need some time to check the plugins,  are already plugins know which cause problems?

Share this post


Link to post
Share on other sites
KlausiMaus

All plugins except TNG WordPress Integration disabled, but still no working links😒

Share this post


Link to post
Share on other sites
KlausiMaus

By disabling enabling plugins I get this error

Zitat

Die REST-API-Anfrage ist aufgrund eines Fehlers fehlgeschlagen.
Fehler: cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received (http_request_failed)

as soon TNG WordPress Integration is enabled

Share this post


Link to post
Share on other sites
manofmull

Like Roger, I too suspect a path problem.

What is your root path in  Admin/Paths?

I had Wordpress installed years ago (too much work) and the TNG root path had to change to accomodate the Wordpress instal

Note that https://kuhnert.ch/stammbaum/TNG

gives a different page if the TNG were removed. It's likely Darrin could sort this in seconds.

 

Share this post


Link to post
Share on other sites
KlausiMaus

Have a look to these screenshots (hope translation is not necessary)

 

10-07-_2020_15-29-41.jpg

10-07-_2020_15-30-37.jpg

Share this post


Link to post
Share on other sites
manofmull

Why httpd?

This doesn't look correct. My own with no Wordpress = /home/********/public_html/

I have no config path either.

Drop an email to Darrin and he will keep you right. Maybe Roger can spot what's wrong from your image path.

I know that with TNG only you can remove the root path, save and the path will refill correctly when settings are opened again. I'm not sure if this also works with Wordpress though.

Share this post


Link to post
Share on other sites
KlausiMaus

Sorry these paths are correct and the TNG works. 

The plugin itself find the same path.

Share this post


Link to post
Share on other sites
KlausiMaus

Sorry, there is still the problem that no link ist working.

Have a look to the integrated page and try any link you see

Share this post


Link to post
Share on other sites
KlausiMaus

Hm, the plugin is very old:

Zitat

This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

remember also Error: cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received (http_request_failed)

Share this post


Link to post
Share on other sites
manofmull

Klaus

I think that's the problem. I understand that the Wordpress/TNG plugin does not work.

Why don't you try the Kloosterman method?

 

Share this post


Link to post
Share on other sites
KlausiMaus

Ok, and how to do this with the current implementation, I will not change anything on my site.

Just here I  want to see the embedded TNG site.

Share this post


Link to post
Share on other sites
theKiwi
2 hours ago, KlausiMaus said:

Sorry, there is still the problem that no link ist working.

Have a look to the integrated page and try any link you see

The content that is on this page - is this showing the TNG index.php page? Or is it content that you put onto the Stammbaum page in WordPress?

I noticed that you seem to have the config.php files in a sub-folder from TNG, when TNG normally places them in the same level as all the other TNG files.

I wonder if that's confusing the plugin since it would be looking in the TNG folder for the config files?! Can you try removing them from the config folder and put them in the TNG folder, and then reset the subroot setting so that TNG knows where the files are.

Here's my testing site, running WordPress 5.4.2 showing a TNG 12.2b1 page with no problems.

http://tngwp.lisaandroger.com/genealogy/getperson.php?personID=I16&tree=Roger

Roger

Share this post


Link to post
Share on other sites
KlausiMaus
Zitat

The content that is on this page - is this showing the TNG index.php page? Or is it content that you put onto the Stammbaum page in WordPress?

This is the  TNG index.php page, the Stammbaum page is an empty one!

Zitat

I wonder if that's confusing the plugin since it would be looking in the TNG folder for the config files?! Can you try removing them from the config folder and put them in the TNG folder, and then reset the subroot setting so that TNG knows where the files are.

I've done that some time ago, the result was he same.

What do you mean by "reset the subroot setting"?

What is about that Error: cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received (http_request_failed)?

Share this post


Link to post
Share on other sites
theKiwi
4 hours ago, KlausiMaus said:

What do you mean by "reset the subroot setting"?

Here

image.png

 

in the Config Path - if you move the files outside of the TNG folder you're meant to put the path to them in that empty box - if you've moved them below the TNG folder then I assume you'd also need to fill in that box with the path to the config files.

4 hours ago, KlausiMaus said:

 What is about that Error: cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received (http_request_failed)?

I have no idea - except that it's coming from the cURL.php file in WordPress.

Can you send by eMail the following things

TNG Admin login ID and password

WordPress Admin login and password

FTP access to the site loginID and password

to rogerkiwi@aol.com

and I'll take a look see if I can spot what's wrong.

One other thing to try is a different theme than you're using - there definitely are themes that the plugin won't work with - it does work with Atahualpa for example.

Roger

Share this post


Link to post
Share on other sites
KlausiMaus

I have cleared the config path, but still no link is working.

Zitat

.TNG Admin login ID and password

Please apply for the user name "Roger", as soon as I have the registration I will grant the corresponding rights.

Zitat

WordPress Admin login and password

Please register here as "Roger", this username is automatically created in WP. After registration I will grant the corresponding rights.

Zitat

FTP access to the site loginID and password

An account will be set up, the data will then be communicated.

Share this post


Link to post
Share on other sites
KlausiMaus

After some htaccess modifications (rewrite rules), the links are now working.

Next step schuld be to ingrate a TNG - Template

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×