Jump to content
TNG Community
Israel

RootsMagic 7 gedcom file fails to import half way on TNG v.12.3

Recommended Posts

Israel

For some reason, when I try to import a gedcom file from RootsMagic 7, it stops half way. My gedcom file is very small compared to other ones I've seen, mine is just 1.5 megabytes and it has around 3000 thousand people. The progress bar stopped working after updating to version 12.0, but it didn't matter because it imported the full file with no issues.  I tried everything, I even did a full install to rule out any issues, and it keeps happening. I tried uploading the gedcom file to the gedcom folder and it still din't work. I wonder if the problem is with RootsMagic and may be is messing up the Gedcom file when it does the export. I really don't know how to find errors when opening the Gedcom file in a text editor. I don't know what to do next. I hope that someone can help me figure out what the issue is.

 

Share this post


Link to post
Share on other sites
Rob Severijns

Hi,

I don't use RootsMagic myself but instead of importing the complete gedcom at first you coud try to import only a few records just to see if that works.

Have you tried importing by using the different import options too?

Kind regards,

 

Rob

Share this post


Link to post
Share on other sites
Israel
19 minutes ago, Rob Severijns said:

Hi,

I don't use RootsMagic myself but instead of importing the complete gedcom at first you coud try to import only a few records just to see if that works.

Have you tried importing by using the different import options too?

Kind regards,

 

Rob

Thanks, I could try that, but I've tried previous Gedcom files that worked from RootsMagic, and now they also stop around the fifteen hundred person. Another possibility that might be causing trouble, is my website's server, or some bug on TNG.

Share this post


Link to post
Share on other sites
Rob Severijns

It is very well possible that the problem lies with your ISP.

There's been a posting not to long ago about failing GEDCOM import in TNG and the problem was the ISP and somekind of timer.

You could contact them too.

I don't think it's a bug within TNG for that would have been reported earlier on.

 

Rob

Share this post


Link to post
Share on other sites
bhemph

This mod fixes the progress bar bug.  Darrin is supposed to be aware of the bug having been reintroduced in 12.3 and the fix.

import_fix.cfg

Share this post


Link to post
Share on other sites
Ken Roy

Brent,

I am not seeing problems with my import of 25,000+ individuals but looking at your code fix, I can see where the fix might be necessary based on some server settings.

Darrin normally merges critical fixes back into the download zip files.  i do not see that fix in the upgrade I just downloaded. 

 

Share this post


Link to post
Share on other sites
Israel

I finally found  a way to make it work, but I wish it could just work  like it should. After trying all kinds of things, like the import_fix mod, downgrading to the 11.1.2 TNG version,  and upgrading back again to the latest version, I tried to do another import. Just after I clicked the  "Import Data" button, I waited about 10  seconds and clicked the "Stop" button, then waited about 4 seconds, and clicked the "Resume" button, and continued repeating the same process until it imported all the people. The progress bar worked, although it didn't reach 100%, it stopped at around 95%,  it imported the full file.  Any ideas of why this worked?

Share this post


Link to post
Share on other sites
theKiwi
1 hour ago, Israel said:

I finally found  a way to make it work, but I wish it could just work  like it should. After trying all kinds of things, like the import_fix mod, downgrading to the 11.1.2 TNG version,  and upgrading back again to the latest version, I tried to do another import. Just after I clicked the  "Import Data" button, I waited about 10  seconds and clicked the "Stop" button, then waited about 4 seconds, and clicked the "Resume" button, and continued repeating the same process until it imported all the people. The progress bar worked, although it didn't reach 100%, it stopped at around 95%, but it imported the full file.  Any ideas of why this worked?

Perhaps you prevented the server getting to the point where a limit on execution time, or number of processes, or something else got invoked and shut down the overall process.

Roger

Share this post


Link to post
Share on other sites
Israel
5 minutes ago, theKiwi said:

Perhaps you prevented the server getting to the point where a limit on execution time, or number of processes, or something else got invoked and shut down the overall process.

Roger

That's what it looks like, just like Rob Severijns suggested. I'm glad it works now :)

Share this post


Link to post
Share on other sites
Rob Severijns

Just talk to your ISP and have them adjust the setting in order for the Gedcom to import properly.

They should know how to fix that.

But until then you at least found a way to import your Gedcom.

Good luck and stay safe,

 

Rob

Share this post


Link to post
Share on other sites
Israel
9 minutes ago, Rob Severijns said:

Just talk to your ISP and have them adjust the setting in order for the Gedcom to import properly.

They should know how to fix that.

But until then you at least found a way to import your Gedcom.

Good luck and stay safe,

 

Rob

Thanks for all the help

Share this post


Link to post
Share on other sites
Rob Severijns

Well it wasn't just me.

It's the sum of all contributors on the forum but thanks anyway  :-)

 

Rob

Share this post


Link to post
Share on other sites
Ancestrees

I'm having the same problem when importing for Family Tree Maker or Legacy Family tree.   I have a tree that is 17000 plus individuals and I can't imagine stopping it every few seconds and restarting it to get it to load.   I use IPage as my service.   It crashes at about 5400 people and 7500 inquiries in the ftp process.  Thanks.   I'm a newbie at using TNG and would love to just bring my tree in.  

Also, I was wondering if anyone knows if Ancestry transferred into Family Tree Maker and then exported out as a Gedcom retains the same ID numbers over time so my Individuals will still be indexed properly by Google on updates in the future once I have this issue resolved?

Thank you!

Share this post


Link to post
Share on other sites
Michel KIRSCH

Rob and thekiwi are correct :

It's a problem of ISP. Some of them doesn't want to have too much traffic. So they block their buffers and the

commands

    @ob_flush();
    @flush();


have no effect.

... and you can't see the progress bar in action. But everything works fine and your gedcom is imported.

Did  you Try to import with the boxe "old_method" checked ?

Michel

Read more about this subject in

 

Share this post


Link to post
Share on other sites
Ken Roy
On 8/27/2020 at 4:30 AM, Michel KIRSCH said:

It's a problem of ISP. Some of them doesn't want to have too much traffic. So they block their buffers and the

commands

    @ob_flush();
    @flush();


have no effect.

... and you can't see the progress bar in action. But everything works fine and your gedcom is imported.

I ran into that issue yesterday when I created a new subdomain to test the full install of TNG 13.  It turns out that some hosts are now implementing PHP using FPM with OPcache , where the output buffer flush instructions might have no effect. While FPM with OPcache is supposedly faster it does not show either the progress bar nor the old counts display.

If your host allows you to select PHP with  CGI  try changing it to use that option for the PHP Handler.  

Share this post


Link to post
Share on other sites
Michel KIRSCH
5 hours ago, Ken Roy said:

I ran into that issue yesterday when I created a new subdomain to test the full install of TNG 13.  It turns out that some hosts are now implementing PHP using FPM with OPcache , where the output buffer flush instructions might have no effect. While FPM with OPcache is supposedly faster it does not show either the progress bar nor the old counts display.

If your host allows you to select PHP with  CGI  try changing it to use that option for the PHP Handler.  

My ISP (one.com) uses the Varnish cache. On demand (by mail), it can be turned off for a short period...

Michel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×