Jump to content
TNG Community
bryanlewis

Histories Thumbnail Lacks Mouseover Tooltip on Person page

Recommended Posts

bryanlewis

I have added my first History and linked it to a few people on my tree.  This is a text account taken from an original document.  I added my own "Histories" thumbnail and everything shows up just fine.  However, unlike photos which have both a popup image and show the title/description, when you mouseover the icon in the histories section, it shows nothing.  This makes it difficult for the user to understand what this is and if you have more than one, it would be confusing.  

In digging into the code, I see that it's creating an "alt" tag for my thumbnail (on it's IMG tag) with the title of the History, but NOT a "title" tag.  Modern browsers generally take title tags and turn them into tooltips.  But I cannot figure out in the TNG code where this it happening.  I would like to add the title tag if possible, or if someone else has a suggested solution for showing a mouseover of the History title, that would be appreciated.

Example page:  https://genealogy.lewisfamily.us/getperson.php?personID=I41&tree=lewisbratti

Share this post


Link to post
Share on other sites
bryanlewis

Thanks. Based on your username and the author name on the wiki, it appears that you are the author of that mod.  However, the download links on the wiki are not working.  Can you correct the wiki or attach the mod here?  Thanks.

UPDATE: Actually after reloading the page, I was able to download it.  But sometimes it works and sometimes it doesn't. About half the time, I get this error:

Fatal error: Uncaught exception 'phpmailerException' with message 'SMTP Error: Could not authenticate.' in /var/www/bh/bhemphill/public_html/genealogy/class.phpmailer.php:1692 Stack trace: #0 /var/www/bh/bhemphill/public_html/genealogy/class.phpmailer.php(1540): PHPMailer->smtpConnect(Array) #1 /var/www/bh/bhemphill/public_html/genealogy/class.phpmailer.php(1335): PHPMailer->smtpSend('Date: Mon, 29 J...', 'Person Media Ti...') #2 /var/www/bh/bhemphill/public_html/genealogy/class.phpmailer.php(1213): PHPMailer->postSend() #3 /var/www/bh/bhemphill/public_html/genealogy/tngmaillib.php(53): PHPMailer->send() #4 /var/www/bh/bhemphill/public_html/genealogy/ccount/click.php(130): tng_sendmail('TNG Wiki Count', 'bhemphill@wiese...', 'Brent Hemphill', 'bhemphill@wiese...', 'Mod Download: P...', 'Person Media Ti...', 'bhemphill@wiese...', 'bhemphill@wiese...') #5 {main} thrown in /var/www/bh/bhemphill/public_html/genealogy/class.phpmailer.php on line 1692

So you may want to look into that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×