Jump to content
TNG Community
Renze

cannot install "Person Media Title"

Recommended Posts

Renze

Indicates the following error (line 416 & line 570):

Quote
lijn 14: %target:@languages/English/cust_text.php% gecontroleerd

lijn 16: %location:% #1 niet geïnstalleerd

lijn 34: %target:@languages/English/config_help.php% gecontroleerd

lijn 36: %location:% #1 niet geïnstalleerd

lijn 76: %target:@languages/English-UTF8/cust_text.php% gecontroleerd

lijn 78: %location:% #1 niet geïnstalleerd

lijn 96: %target:@languages/French/cust_text.php% gecontroleerd

lijn 98: %location:% #1 niet geïnstalleerd

lijn 116: %target:@languages/French-UTF8/cust_text.php% gecontroleerd

lijn 118: %location:% #1 niet geïnstalleerd

lijn 136: %target:@languages/German/cust_text.php% gecontroleerd

lijn 138: %location:% #1 niet geïnstalleerd

lijn 156: %target:@languages/German-UTF8/cust_text.php% gecontroleerd

lijn 158: %location:% #1 niet geïnstalleerd

lijn 176: %target:@languages/Dutch/cust_text.php% gecontroleerd

lijn 178: %location:% #1 niet geïnstalleerd

lijn 196: %target:@languages/Dutch-UTF8/cust_text.php% gecontroleerd

lijn 198: %location:% #1 niet geïnstalleerd

lijn 216: %target:admin_genconfig.php% gecontroleerd

lijn 218: %location:% #1 niet geïnstalleerd
lijn 255: %location:% #2 niet geïnstalleerd

lijn 352: %target:admin_updateconfig.php% gecontroleerd

lijn 354: %location:% #1 niet geïnstalleerd

lijn 377: %target:personlib.php% gecontroleerd

lijn 379: %location:% #1 niet geïnstalleerd
lijn 386: %location:% #2 niet geïnstalleerd
lijn 393: %location:% #3 niet geïnstalleerd
lijn 407: %location:% #4 niet geïnstalleerd
lijn 416: %location:% #5 Ongeldig doel
lijn 424: %location:% #6 niet geïnstalleerd
lijn 431: %location:% #7 niet geïnstalleerd
lijn 451: %location:% #8 niet geïnstalleerd
lijn 458: %location:% #9 niet geïnstalleerd
lijn 466: %location:% #10 niet geïnstalleerd
lijn 475: %location:% #11 niet geïnstalleerd
lijn 484: %location:% #12 niet geïnstalleerd
lijn 496: %location:% #13 niet geïnstalleerd
lijn 505: %location:% #14 niet geïnstalleerd
lijn 512: %location:% #15 niet geïnstalleerd
lijn 525: %location:% #16 niet geïnstalleerd
lijn 532: %location:% #17 niet geïnstalleerd
lijn 547: %location:% #18 niet geïnstalleerd
lijn 570: %location:% #19 Ongeldig doel
lijn 584: %location:% #20 niet geïnstalleerd

lijn 604: %target:genlib.php% gecontroleerd

lijn 606: %location:% #1 niet geïnstalleerd
lijn 613: %location:% #2 niet geïnstalleerd
lijn 620: %location:% #3 niet geïnstalleerd

lijn 630: %target:getperson.php% gecontroleerd

lijn 633: %location:% #1 niet geïnstalleerd
lijn 683: %location:% #2 niet geïnstalleerd

lijn 693: %target:js/net.js% gecontroleerd

lijn 695: %location:% #1 niet geïnstalleerd
lijn 731: %location:% #2 niet geïnstalleerd

My installed mods:

wiki16.png
Geïnstalleerd [Opties]
 
wiki16.png
Geïnstalleerd [Opties]
 
wiki16.png
Geïnstalleerd
 
 
Geïnstalleerd
 
wiki16.png
Geïnstalleerd   
 
wiki16.png
Geïnstalleerd
 
wiki16.png
Geïnstalleerd [Opties]
 
wiki16.png
Geïnstalleerd
 
wiki16.png
Kan niet installeren   
 
wiki16.png
Geïnstalleerd [Opties]   
 
wiki16.png
Geïnstalleerd
 
wiki16.png
Geïnstalleerd
 
wiki16.png
Geïnstalleerd [Opties]
 
wiki16.png
Geïnstalleerd [Opties]

 

 

Share this post


Link to post
Share on other sites
tngrlkrz

Hello Renze,

You didn't mention what TNG version, but presume  v12.3 is installed?

English display would help.  Have you tried uninstalling all other mods, then try installing just the Person Media Title, and if that installs, then work your way through the rest of the mods, one at a time, until errors arise, likely in another mod, to isolate the conflict?

Or, another way, uninstall other mods, one at a time, until the 'cannot install' for Person Media Title becomes 'ok to install'.

 

Share this post


Link to post
Share on other sites
Renze

I did that but no success. I think both mods are not suitable for TNG 12. + Thanks for your comment.

Share this post


Link to post
Share on other sites
bhemph

Renze,
     Darrin published a new personlib.php for TNG 12.3 after you downloaded it.  It also looks like there was a change to Public Access Mod that I need to account for.  Would you mind sharing the Dutch translation for me to publish with the mod?  I will give you credit for the translation.

Brent

Share this post


Link to post
Share on other sites
Renze

******* Dutch/cust_text.php *******
%target:languages/Dutch/cust_text.php%
%fileoptional:%
%location:%
//Mods should put their changes before this line, local changes should come after it.
%end:%
%insert:before%
// Added by Person Media Title
$admtext['showmediatitle'] = "Geef mediatitels weer bij thumbnails";
$admtext['reqmediathumbsset'] = "\"Toon foto's op één rij\" moet zijn ingesteld op Ja om deze optie in te schakelen";
$admtext['documentthumbs'] = "Toon documenten op één rij";
$admtext['headstonethumbs'] = "Toon grafstenen op één rij";
$admtext['historythumbs'] = "Toon verhalen op één rij";
$admtext['recordingthumbs'] = "Toon opnames op één rij";
$admtext['videothumbs'] = "Toon video's op één rij";
$admtext['showcitethumbs'] = "Toon Thumbnails in citaten";
// end by Person Media Title additions
%end:%

******************************************
******* Dutch-UTF8/cust_text.php *******
%target:languages/Dutch-UTF8/cust_text.php%
%fileoptional:%
%location:%
//Mods should put their changes before this line, local changes should come after it.
%end:%
%insert:before%
// Added by Person Media Title
$admtext['showmediatitle'] = "Geef mediatitels weer bij thumbnails";
$admtext['reqmediathumbsset'] = "\"Toon foto's op één rij\" moet zijn ingesteld op JA om deze optie in te schakelen";
$admtext['documentthumbs'] = "Toon documenten op één rij";
$admtext['headstonethumbs'] = "Toon grafstenen op één rij";
$admtext['historythumbs'] = "Toon verhalen op één rij";
$admtext['recordingthumbs'] = "Toon opnames op één rij";
$admtext['videothumbs'] = "Toon video's op één rij";
$admtext['showcitethumbs'] = "Toon thumbnails in citaten";
// end by Person Media Title additions
%end:%

Share this post


Link to post
Share on other sites
Renze

I have now installed the new version. Now get an error: "line 416:% location:% # 5 Bad target"

Share this post


Link to post
Share on other sites
bhemph

For the version of personlib that you have, that location needs to be:
 

%location:%
			$mediaoutput .= "<tr><td class=\"databack\" colspan=\"2\">$thumbdivs</td></tr>\n";
%end:%

Darrin added 

 class=\"t{$eventcounter}\"$toggle

to the line after initial release of TNG 12.3 in order to fix a display issue.

Share this post


Link to post
Share on other sites
Renze

Line 416 adapted and solved! Thanks!

Share this post


Link to post
Share on other sites
Ken Roy

You might consider downloading the upgrade zip file again.  There were also a couple of Mod Manager fixes that were merged into the zip file after TNG 12.3 was released.

Share this post


Link to post
Share on other sites
Renze

@ Ken I will reinstall the TNG update file.

One more note about this mod. If there is one image in the folder. The title is mentioned twice.

 

vrbled-09.jpg

Share this post


Link to post
Share on other sites
Ken Roy

Sorry, I do not use that mod, so cannot help there.

You should not need to re-install the upgrade.  You should only need to download the zip file and extract it and then look for modules with a change date after the original release of TNG 12.3.  looks like the changes in the TNG root folder were to personlib.php and 2 import modules - gedimport_families.php and gedimport_people.php

The Mod Manager module is in classes/modeditor.class.php

You should uninstall any mods that make changes to personlib.php.  Or more prudently, uninstall all mods and then re-install them after you have FTPed the new modules to your host

Share this post


Link to post
Share on other sites
bhemph

Renze,
     That should be back to how it was in TNG 12.1 and 12.2 with not having the double title when there is only one media item.

Brent

Share this post


Link to post
Share on other sites
Renze
3 hours ago, bhemph said:

Renze,
     That should be back to how it was in TNG 12.1 and 12.2 with not having the double title when there is only one media item.

Brent

Fixed issue after installing version 12.3.0.4b . Thank you for the assistance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×