Jump to content
TNG Community
Sign in to follow this  
raymondo

Establish a connection to your database

Recommended Posts

raymondo

Hi to everyone.  I am setting up a home server on Wamp64 v3.2 which I downloaded from Sourceforge.  I am installing the latest version of TNG 122.  The installation of Wamp seems to have installed ok and setup the virtualhost responds ok from the browser i.e. http://localhost also from my virtualhost http://mortred which is the renamed tngfile122 situated in C:\wamp\www\mortred.

Having got to the TNG Installation via the browser (http://localhost/mortred/readme.html)  Set Permissions ok. (Green)  Rename Folders ok (Green Languages and Char set ok (green)

When I try to Establish a connection to my database with,

Host Name           localhost

Database Name  mortred

User Name           root

Pass Word           ray                I keep getting that the information has been saved but Either the database name, or user name, or password are wrong.  I have interchanged these datails and even left the password vacant as in earlier versions of wamp but still cannot work out what is required.     (I notice that this latest version of Wamp 3.2 seems to use the MariaDB a the default database and not MySql)

Has anyone already  installed TNG12.2 on Wamp64 3.2 that can suggest where I am going wrong I will be extremely grateful for you help.

Regards to all

raymondo

Share this post


Link to post
Share on other sites
bhemph

You may need to set your port to 3307 in TNG, or change the MariaDB port to 3306 since MySql looks like it is probably not running on port 3306 as would be the case with a clean install of the latest version of WAMP.

Share this post


Link to post
Share on other sites
Ken Roy
17 hours ago, raymondo said:

Has anyone already  installed TNG12.2 on Wamp64 3.2

If you installed the full WampServer 3.2, the default Database Management System (DBMS) is now MariaDB.  In order to use MySQL your either need to:

  • Change the DBMS to MySQL or
  • specify Port 3308 in the TNG Admin > Setup > General Settings > Database section   (port 3308 is now used for MySQL if I am remember correctly.  Sorry, I cannot check since I just wiped my laptop to be sent back to the vendor for repair)

Edited - I found my notes for when I installed a full version of WampServer 3.2 and can verify that the default DBMS on port 3306 is MariaDB and that the port assignment for MySQL is 3308.

When I get a chance, I will update the TNG Wiki page on WampServer

Share this post


Link to post
Share on other sites
raymondo
13 hours ago, bhemph said:

You may need to set your port to 3307 in TNG, or change the MariaDB port to 3306 since MySql looks like it is probably not running on port 3306 as would be the case with a clean install of the latest version of WAMP.

1

Thank you bhemph for responding with your advice which I will take and impliment.  I will also let you know if I am successful.

regards raymondo

Share this post


Link to post
Share on other sites
raymondo

Thank you Ken for responding with your advice.  I have checked out both ports.  MariaDB is running on 3306,  Mysql is running on 3308. I now have the options to connect to one or the other DB.  I will let you know which has been successful.

regards raymondo

Share this post


Link to post
Share on other sites
Ken Roy

If you use MariaDB, you do not need to specify a port in the WampServer 3.2 full install.

For WampServer versions 3.2 upgrade from a previous version the default 3306 port is still used by MySQL.  There is also a Tools option in WampServer if you right click the icon and select the Tools menu that allows you to change the default DBMS for port 3306 in which case you do not need to specify a port in the TNG setup

I did not have a running WampServer available when I replied this morning.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×