Jump to content
TNG Community
remo

The letter Ñ Tilde

Recommended Posts

remo

Hello

When I am in admin user mode and I add a person with the name of Briseño notice the tilde over the " N "

then go to the descendants tab on the family tree I see this on the name Casimiro Briseño

If I remove the tilde from the name under people the name is good.

Here is the main page site.

This site powered by TNG ©, v. 10.0.0

http://brisenofamily.com

here is the descendant page look on the far left side look for Casimiro Briseno

http://brisenofamily.com/descend.php?personID=I2&tree=briseno

I have attached a picture of the people entry

Screen Shot 2020-02-23 at 8.36.13 AM.png

Screen Shot 2020-02-23 at 8.36.39 AM.png

Share this post


Link to post
Share on other sites
Newfloridian

Hi

I always write accented characters and special symbols by using the html character set. I would write yours as:

Casimiro Briseño

(the lower case n tilde has the html entity ñ)

 There's a handy chart here:

HTML Entity List

 

Alan

 

 

 

 

Share this post


Link to post
Share on other sites
bhemph

Your character set sends "charset=ISO-8859-1" so this must be what you have set up in the languages.  So then your database must be set to UTF-8 and the mismatch (ISO-8859 and UTF-8) is why n tilde it coming up with those incorrect characters instead.  Both have to be in the same character set to work correctly and not end up with mangled characters.

Share this post


Link to post
Share on other sites
remo

Hello Newfloridian

That advice worked 

Thank You 

 

Hello bhemph

I tried your advice and it did not work. I was looking forward for it to work so that I don't have to redo all the

names with the tilde in them. I attached a picture of the before and after language settings,... let me know if that is how to configure it.

Thanks

Screen Shot 2020-02-23 at 4.17.00 PM.png

Screen Shot 2020-02-23 at 4.17.40 PM.png

Share this post


Link to post
Share on other sites
Ken Roy

For character set not to get mangled:

TNG charset in Admin > Setup > General Settings  > Language section

* Admin > Languages

* database collation sequence

* gedcom if you import data

must all be the same - UTF-8

Also if you edit files, they must be encoded UTF-8 without BOM in Notepad++   Alan's solution of using HTML special characters is only needed in mods that provide ISO-8859-1 for accented characters when the file is encoded as UTF-8. So Brent's solution is  really the long-term solution. 

Share this post


Link to post
Share on other sites
remo

Hello Ken

 I changed the following 

*  TNG charset in Admin > Setup > General Settings  > Language section

* Admin > Languages

I have attached pictures please let me know if the settings I have are correct.

 

 

I do not see this setting. I do see something in Admin > Setup > General Settings>Database

* database collation sequence

I only see database I do not see collation sequence 

Am I missing something a step ?

 

 

I do not import gedcom data 

* gedcom if you import data

must all be the same - UTF-8

Thanks

Remo

 

ThanksScreen Shot 2020-02-23 at 7.18.16 PM.pngScreen Shot 2020-02-23 at 7.18.16 PM.pngScreen Shot 2020-02-23 at 7.18.16 PM.png

Screen Shot 2020-02-23 at 7.18.31 PM.png

Share this post


Link to post
Share on other sites
Ken Roy

the database  information is found using  phpMyAdmin

Share this post


Link to post
Share on other sites
remo

Hello Ken 

Looks like I had to refresh or log out an log back in.

I noticed that that fixed it. I am going to keep an eye on it if anything changes 

I will update it here.

Many Thanks 

Remo

Share this post


Link to post
Share on other sites
remo

Hello Ken 

Now when I switch to spanish in admin mode I get these triangles

with ? marks in them.

See attachement.

Remo

Screen Shot 2020-02-23 at 9.00.16 PM.png

Share this post


Link to post
Share on other sites
Ken Roy

Remo,

The  characters  being mangled in Spanish would indicate the use of the ANSI language folder Spanish or ANSI language files within the Spanish-UTF8 folder.  It is very difficult to debug problems with screen captures.  Look  at your Spanish-UTF8/admintext.php file using your Control Panel or Notepad++ and make sure that it contains the accented characters correctly. 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×